Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

mystery index found

3 posts in General Discussion Last posting was on 2011-10-04 18:37:56.0Z
rick_806 Posted on 2011-10-04 16:14:56.0Z
Sender: 31ec.4e8b3019.1804289383@sybase.com
From: rick_806
Newsgroups: sybase.public.ase.general
Subject: mystery index found
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4e8b3100.3232.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 4 Oct 2011 09:14:56 -0700
X-Trace: forums-1-dub 1317744896 10.22.241.41 (4 Oct 2011 09:14:56 -0700)
X-Original-Trace: 4 Oct 2011 09:14:56 -0700, 10.22.241.41
Lines: 9
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:30568
Article PK: 72743

ASE 15.5 ESD3 I ran sp_spaceused "table",1 on my table and
found 5 indices where there should only be 4. In addition
this mystery index is named the same as the table with an
extra "t" in front "ttable_name". "sp_help table" does not
show this index? It is larger than the all the data in the
table so I would like to find out more about it.

thx,
rick_806


"Mark A. Parsons" <iron_horse Posted on 2011-10-04 16:39:18.0Z
From: "Mark A. Parsons" <iron_horse@no_spamola.compuserve.com>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101207 Lightning/1.0b2 Thunderbird/3.1.7
MIME-Version: 1.0
Newsgroups: sybase.public.ase.general
Subject: Re: mystery index found
References: <4e8b3100.3232.1681692777@sybase.com>
In-Reply-To: <4e8b3100.3232.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4e8b36b6@forums-1-dub>
Date: 4 Oct 2011 09:39:18 -0700
X-Trace: forums-1-dub 1317746358 10.22.241.152 (4 Oct 2011 09:39:18 -0700)
X-Original-Trace: 4 Oct 2011 09:39:18 -0700, vip152.sybase.com
Lines: 18
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:30569
Article PK: 72742

The 't' index is a place keep for all blob (text/image) page chains in the table.

You'll also find it in sysindexes with indid=255.

It's not really an index but rather a means of keeping track of space usage for the blob page chains.

On 10/04/2011 12:14, rick_806 wrote:
> ASE 15.5 ESD3 I ran sp_spaceused "table",1 on my table and
> found 5 indices where there should only be 4. In addition
> this mystery index is named the same as the table with an
> extra "t" in front "ttable_name". "sp_help table" does not
> show this index? It is larger than the all the data in the
> table so I would like to find out more about it.
>
> thx,
> rick_806


Bret Halford Posted on 2011-10-04 18:37:56.0Z
From: Bret Halford <bret@sybase.com>
User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:6.0.2) Gecko/20110902 Thunderbird/6.0.2
MIME-Version: 1.0
Newsgroups: sybase.public.ase.general
Subject: Re: mystery index found
References: <4e8b3100.3232.1681692777@sybase.com> <4e8b36b6@forums-1-dub>
In-Reply-To: <4e8b36b6@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4e8b5284$1@forums-1-dub>
Date: 4 Oct 2011 11:37:56 -0700
X-Trace: forums-1-dub 1317753476 10.22.241.152 (4 Oct 2011 11:37:56 -0700)
X-Original-Trace: 4 Oct 2011 11:37:56 -0700, vip152.sybase.com
Lines: 34
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:30571
Article PK: 72744

The ASE documentation is available online at
http://sybooks.sybase.com/nav/summary.do?prod=9938&lang=en&submit=%A0Go%A0&prodName=Adaptive+Server+Enterprise&archive=0

The Reference Manual: Procedures in particular documents stored
procedures such as sp_spaceused

http://infocenter.sybase.com/help/topic/com.sybase.infocenter.dc36273.1550/html/sprocs/X50477.htm

Cheers,
-bret

On 10/4/2011 10:39 AM, Mark A. Parsons wrote:
> The 't' index is a place keep for all blob (text/image) page chains in
> the table.
>
> You'll also find it in sysindexes with indid=255.
>
> It's not really an index but rather a means of keeping track of space
> usage for the blob page chains.
>
>
>
> On 10/04/2011 12:14, rick_806 wrote:
>> ASE 15.5 ESD3 I ran sp_spaceused "table",1 on my table and
>> found 5 indices where there should only be 4. In addition
>> this mystery index is named the same as the table with an
>> extra "t" in front "ttable_name". "sp_help table" does not
>> show this index? It is larger than the all the data in the
>> table so I would like to find out more about it.
>>
>> thx,
>> rick_806