Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Cannot execute stored procedure in Appeon 6.5 datawindow/datastores

9 posts in Appeon (partner product) Last posting was on 2011-11-01 06:07:01.0Z
Ray Webb Posted on 2011-10-14 17:19:39.0Z
From: "Ray Webb" <hrwebb@spsinc.com>
Newsgroups: sybase.public.appeon
Subject: Cannot execute stored procedure in Appeon 6.5 datawindow/datastores
Lines: 27
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5931
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.6109
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4e986f2b$1@forums-1-dub>
Date: 14 Oct 2011 10:19:39 -0700
X-Trace: forums-1-dub 1318612779 10.22.241.152 (14 Oct 2011 10:19:39 -0700)
X-Original-Trace: 14 Oct 2011 10:19:39 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:2798
Article PK: 13603

My company currently has Appeon 5.x apps that include several
datawindow/datastores defined to execute stored procedures rather than
embedded SQL. The apps runs with no problems.

We're migrating to Appeon 6.5 with EAServer 6.3 using SQL Server as the
database. We are using the the latest jTDS drivers to access SQL Server
(both with Appeon 5.x and 6.5). First I used SQL Profiler to see the SQL
actually being passed to SQL Server. When a datawindow/datastore Retrieve()
was using a stored procedure nothing was traced in SQL Profiler. So I placed
some code in the sqlpreview event for the datawindows/datastores. In every
instance, when calling a stored procedure the sqlsyntax argument passed to
the sqlpreview event is an empty string. When the datawindow/datastore uses
embedded SQL the sqlsyntax is the expected SQL statement. Continuing to
execute the datawindow/datastore with the stored procedure causes an error
to be triggered through the dberror event with the following arguments
passed to the event:

sqldbcode = 13007
sqlerrtext = "Register parameter error: index = 1124888, jdbcType = {1},
value = {2}."
sqlsyntax = "Register parameter error: index = 1124888, jdbcType = {1},
value = {2}."

I don't know whether this is an Appeon bug or something not configured
correctly in EAServer or Appeon. Any ideas would be appreciated.


Steven Posted on 2011-10-18 06:40:43.0Z
Sender: 7f3.4e9d0c31.1804289383@sybase.com
From: steven
Newsgroups: sybase.public.appeon
Subject: Re: Cannot execute stored procedure in Appeon 6.5 datawindow/datastores
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4e9d1f6b.dd4.1681692777@sybase.com>
References: <4e986f2b$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 17 Oct 2011 23:40:43 -0700
X-Trace: forums-1-dub 1318920043 10.22.241.41 (17 Oct 2011 23:40:43 -0700)
X-Original-Trace: 17 Oct 2011 23:40:43 -0700, 10.22.241.41
Lines: 12
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:2800
Article PK: 21880

Hi,
Please send us the following information for further
investigation.
1. Syntax of the stored procedure and related with the
datawindow srd file.
2. Log files(appeonerror.log and appeonserver.log) with
debug mode.(And please clear the log files first, set the
Log mode to Debug in AEM, and then reproduce the issue on
the Web).

Regards,
Steven


Ray Webb Posted on 2011-10-18 13:29:34.0Z
From: "Ray Webb" <hrwebb@spsinc.com>
Newsgroups: sybase.public.appeon
References: <4e986f2b$1@forums-1-dub> <4e9d1f6b.dd4.1681692777@sybase.com>
Subject: Re: Cannot execute stored procedure in Appeon 6.5 datawindow/datastores
Lines: 665
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5931
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.6109
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4e9d7f3e$1@forums-1-dub>
Date: 18 Oct 2011 06:29:34 -0700
X-Trace: forums-1-dub 1318944574 10.22.241.152 (18 Oct 2011 06:29:34 -0700)
X-Original-Trace: 18 Oct 2011 06:29:34 -0700, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:2801
Article PK: 21883

The requested logs are attached along with one of the datawindows that
exhibited the problem.

I reviewed the Server log and noticed that the executes for the stored
procedures were converted to 'call sp ()' format. I wasn't sure whether this
is what gets passed to the database.

Thanks for your assistance. Please let me know if additional information is
needed.

<steven> wrote in message news:4e9d1f6b.dd4.1681692777@sybase.com...
> Hi,
> Please send us the following information for further
> investigation.
> 1. Syntax of the stored procedure and related with the
> datawindow srd file.
> 2. Log files(appeonerror.log and appeonserver.log) with
> debug mode.(And please clear the log files first, set the
> Log mode to Debug in AEM, and then reproduce the issue on
> the Web).
>
> Regards,
> Steven


Steven Posted on 2011-10-19 14:49:56.0Z
Sender: 1050.4e9ee0bd.1804289383@sybase.com
From: steven
Newsgroups: sybase.public.appeon
Subject: Re: Cannot execute stored procedure in Appeon 6.5 datawindow/datastores
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4e9ee394.113d.1681692777@sybase.com>
References: <4e9d7f3e$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 19 Oct 2011 07:49:56 -0700
X-Trace: forums-1-dub 1319035796 10.22.241.41 (19 Oct 2011 07:49:56 -0700)
X-Original-Trace: 19 Oct 2011 07:49:56 -0700, 10.22.241.41
Lines: 5
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:2802
Article PK: 21889

Whether your Appeon version is 6.5.0202, if not, could you
upgrade your Appeon server and developer to the 6.5.0202,
and full deploy your application and try again.
If still can't solve this issue, could you provide the
syntax of the stored procedure and retrieve arguments value.