Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Sybase 15.5 to use kerberos

5 posts in General Discussion Last posting was on 2011-11-22 16:28:52.0Z
RayLee Posted on 2011-11-21 16:18:47.0Z
From: RayLee <pp@hot.com>
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20111105 Thunderbird/8.0
MIME-Version: 1.0
Newsgroups: sybase.public.ase.general
Subject: Sybase 15.5 to use kerberos
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4eca79e7$1@forums-1-dub>
Date: 21 Nov 2011 08:18:47 -0800
X-Trace: forums-1-dub 1321892327 10.22.241.152 (21 Nov 2011 08:18:47 -0800)
X-Original-Trace: 21 Nov 2011 08:18:47 -0800, vip152.sybase.com
Lines: 12
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:30704
Article PK: 73596

Hi,

I am new to this forum and hope I post to a right forum for my question.

We want to upgrade our sybase server from 12.5.3 to 15.5 or 15.7.

If we want to use Windows authentication for our sybase applications,
I guess we need to enable Kerberos in the sybase server, does it require
to separate license for Kerberos?

Thanks,
Raymond


J Posted on 2011-11-21 17:34:54.0Z
From: jtotally_bogus@sbcglobal.net (J)
Newsgroups: sybase.public.ase.general
Subject: Re: Sybase 15.5 to use kerberos
Reply-To: J@bogusemailAddress.com
Message-ID: <4eca882b.613136078@forums.sybase.com>
References: <4eca79e7$1@forums-1-dub>
X-Newsreader: Forte Free Agent 1.21/32.243
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 21 Nov 2011 09:34:54 -0800
X-Trace: forums-1-dub 1321896894 10.22.241.152 (21 Nov 2011 09:34:54 -0800)
X-Original-Trace: 21 Nov 2011 09:34:54 -0800, vip152.sybase.com
Lines: 30
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:30706
Article PK: 73597

On 21 Nov 2011 08:18:47 -0800, RayLee <pp@hot.com> wrote:

If all clients are on Windows and the domain is Active Directory then
you might be able to use "Windows Integrate login" without any special
features as documented in this older paper: but it is LAN Manager and
named pipes oriented. I have not looked at this in a very long time.

http://m.sybase.com/detail?id=1011503

If you want to use more modern Windows SSPI and Kerberos clients (e.g.
some Unix clients) and use more current integrated login support then
the ASE_ASM or ASE_SECDIR licensing is required. You might already
have the feature for other needs like ssl. Check with sales re.
costing.

Jay

>Hi,
>
>I am new to this forum and hope I post to a right forum for my question.
>
>We want to upgrade our sybase server from 12.5.3 to 15.5 or 15.7.
>
>If we want to use Windows authentication for our sybase applications,
>I guess we need to enable Kerberos in the sybase server, does it require
>to separate license for Kerberos?
>
>Thanks,
>Raymond


RayLee Posted on 2011-11-22 16:07:39.0Z
From: RayLee <pp@hot.com>
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20111105 Thunderbird/8.0
MIME-Version: 1.0
Newsgroups: sybase.public.ase.general
Subject: Re: Sybase 15.5 to use kerberos
References: <4eca79e7$1@forums-1-dub> <4eca882b.613136078@forums.sybase.com>
In-Reply-To: <4eca882b.613136078@forums.sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4ecbc8cb$1@forums-1-dub>
Date: 22 Nov 2011 08:07:39 -0800
X-Trace: forums-1-dub 1321978059 10.22.241.152 (22 Nov 2011 08:07:39 -0800)
X-Original-Trace: 22 Nov 2011 08:07:39 -0800, vip152.sybase.com
Lines: 44
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:30713
Article PK: 73602

Hi Jay,

Thanks for your reply. Really happy to see someone response to my
question as I have been long time not using newsgroup.

http://m.sybase.com/detail?id=1011503

I see this link is for NT platform, do you have any for windows 2003 or
2008?

Thanks

On 11/22/2011 1:34 AM, J wrote:
> On 21 Nov 2011 08:18:47 -0800, RayLee<pp@hot.com> wrote:
>
> If all clients are on Windows and the domain is Active Directory then
> you might be able to use "Windows Integrate login" without any special
> features as documented in this older paper: but it is LAN Manager and
> named pipes oriented. I have not looked at this in a very long time.
>
> http://m.sybase.com/detail?id=1011503
>
> If you want to use more modern Windows SSPI and Kerberos clients (e.g.
> some Unix clients) and use more current integrated login support then
> the ASE_ASM or ASE_SECDIR licensing is required. You might already
> have the feature for other needs like ssl. Check with sales re.
> costing.
>
> Jay
>
>> Hi,
>>
>> I am new to this forum and hope I post to a right forum for my question.
>>
>> We want to upgrade our sybase server from 12.5.3 to 15.5 or 15.7.
>>
>> If we want to use Windows authentication for our sybase applications,
>> I guess we need to enable Kerberos in the sybase server, does it require
>> to separate license for Kerberos?
>>
>> Thanks,
>> Raymond
>


J Posted on 2011-11-22 16:28:52.0Z
From: jtotally_bogus@sbcglobal.net (J)
Newsgroups: sybase.public.ase.general
Subject: Re: Sybase 15.5 to use kerberos
Reply-To: J@bogusemailAddress.com
Message-ID: <4ecbcd89.696431078@forums.sybase.com>
References: <4eca79e7$1@forums-1-dub> <4eca882b.613136078@forums.sybase.com> <4ecbc8cb$1@forums-1-dub>
X-Newsreader: Forte Free Agent 1.21/32.243
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 22 Nov 2011 08:28:52 -0800
X-Trace: forums-1-dub 1321979332 10.22.241.152 (22 Nov 2011 08:28:52 -0800)
X-Original-Trace: 22 Nov 2011 08:28:52 -0800, vip152.sybase.com
Lines: 53
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:30715
Article PK: 73606

On 22 Nov 2011 08:07:39 -0800, RayLee <pp@hot.com> wrote:

My understanding is that the old NT LanMan support still works on
those releases of MS Server. I am most familar with the Kerberos
support.

Jay

>Hi Jay,
>
>Thanks for your reply. Really happy to see someone response to my
>question as I have been long time not using newsgroup.
>
>http://m.sybase.com/detail?id=1011503
>
>I see this link is for NT platform, do you have any for windows 2003 or
>2008?
>
>Thanks
>
>On 11/22/2011 1:34 AM, J wrote:
>> On 21 Nov 2011 08:18:47 -0800, RayLee<pp@hot.com> wrote:
>>
>> If all clients are on Windows and the domain is Active Directory then
>> you might be able to use "Windows Integrate login" without any special
>> features as documented in this older paper: but it is LAN Manager and
>> named pipes oriented. I have not looked at this in a very long time.
>>
>> http://m.sybase.com/detail?id=1011503
>>
>> If you want to use more modern Windows SSPI and Kerberos clients (e.g.
>> some Unix clients) and use more current integrated login support then
>> the ASE_ASM or ASE_SECDIR licensing is required. You might already
>> have the feature for other needs like ssl. Check with sales re.
>> costing.
>>
>> Jay
>>
>>> Hi,
>>>
>>> I am new to this forum and hope I post to a right forum for my question.
>>>
>>> We want to upgrade our sybase server from 12.5.3 to 15.5 or 15.7.
>>>
>>> If we want to use Windows authentication for our sybase applications,
>>> I guess we need to enable Kerberos in the sybase server, does it require
>>> to separate license for Kerberos?
>>>
>>> Thanks,
>>> Raymond
>>
>


Eisen Posted on 2011-11-22 07:04:10.0Z
Sender: 52b2.4ecb3f11.1804289383@sybase.com
From: Eisen
Newsgroups: sybase.public.ase.general
Subject: Re: Sybase 15.5 to use kerberos
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4ecb496a.5855.1681692777@sybase.com>
References: <4eca882b.613136078@forums.sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 21 Nov 2011 23:04:10 -0800
X-Trace: forums-1-dub 1321945450 10.22.241.41 (21 Nov 2011 23:04:10 -0800)
X-Original-Trace: 21 Nov 2011 23:04:10 -0800, 10.22.241.41
Lines: 41
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:30712
Article PK: 73605

Hi Jay
I saw in your old post, dba would use sp_loginconfig and
sp_logininfo to map the AD user and DB user. but these two
SP are both only for NT platform, how can we set up the map
of a Sybase DB user based on Unix platform to a Windows AD
user? Thanks.

Best Regards
Eisen

> On 21 Nov 2011 08:18:47 -0800, RayLee <pp@hot.com> wrote:
>
> If all clients are on Windows and the domain is Active
> Directory then you might be able to use "Windows Integrate
> login" without any special features as documented in this
> older paper: but it is LAN Manager and named pipes
> oriented. I have not looked at this in a very long time.
>
> http://m.sybase.com/detail?id=1011503
>
> If you want to use more modern Windows SSPI and Kerberos
> clients (e.g. some Unix clients) and use more current
> integrated login support then the ASE_ASM or ASE_SECDIR
> licensing is required. You might already have the feature
> for other needs like ssl. Check with sales re. costing.
>
> Jay
>
> >Hi,
> >
> >I am new to this forum and hope I post to a right forum
> for my question. >
> >We want to upgrade our sybase server from 12.5.3 to 15.5
> or 15.7. >
> >If we want to use Windows authentication for our sybase
> applications, >I guess we need to enable Kerberos in the
> sybase server, does it require >to separate license for
> Kerberos? >
> >Thanks,
> >Raymond
>