Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

isql with "-X" paramter problem

5 posts in General Discussion Last posting was on 2012-05-30 12:54:15.0Z
John Posted on 2012-02-22 06:40:26.0Z
From: "John" <johntlf@hotmail.com>
Newsgroups: sybase.public.ase.general
Subject: isql with "-X" paramter problem
Lines: 14
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5931
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.6109
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4f448dda@forums-1-dub>
Date: 21 Feb 2012 22:40:26 -0800
X-Trace: forums-1-dub 1329892826 10.22.241.152 (21 Feb 2012 22:40:26 -0800)
X-Original-Trace: 21 Feb 2012 22:40:26 -0800, vip152.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:30938
Article PK: 73827

The error ocurr when call "isql -Sxxx -Uxxx -Pxxx -X" in Sybase 15.7 but it
is fine in Sybase 12.5.4. Please cause is it?

"ct_connet(): protocol specific layer: internal Client Library error: There
is a tds login error. The installed encryption handler returned a status
that was not CS_SUCCEED."
Adaptive Server Enterprise/12.5.4/EBF 13383/P/RS6000/AIX
5.1/ase1254/2006/64-bit/FBO/Sat May 20 07:06:10 2006
Adaptive Server Enterprise/15.7.0/EBF 19625 SMP ONE-OFF/P/RS6000/AIX
6.1/ase157/2820/64-bit/FBO/Fri Oct 14 11:43:25 2011

John


"Mark A. Parsons" <iron_horse Posted on 2012-02-22 13:45:10.0Z
From: "Mark A. Parsons" <iron_horse@no_spamola.compuserve.com>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101207 Lightning/1.0b2 Thunderbird/3.1.7
MIME-Version: 1.0
Newsgroups: sybase.public.ase.general
Subject: Re: isql with "-X" paramter problem
References: <4f448dda@forums-1-dub>
In-Reply-To: <4f448dda@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4f44f166$1@forums-1-dub>
Date: 22 Feb 2012 05:45:10 -0800
X-Trace: forums-1-dub 1329918310 10.22.241.152 (22 Feb 2012 05:45:10 -0800)
X-Original-Trace: 22 Feb 2012 05:45:10 -0800, vip152.sybase.com
Lines: 43
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:30940
Article PK: 73829

From solved cases @ sybase.com:

======================
case: 11600992

Description:

After enabling configuration parameter "net password encryption reqd" unable to connect to ASE (15.5 on AIX)

$ isql -U sa -P -X
CT-LIBRARY error:
ct_connect(): protocol specific layer: internal Client Library error: There is a tds login error. The installed
encryption handler returned a status that was not CS_SUCCEED.

Tip/Workaround:

verify OS - problem only exists on AIX (tested internally on Windows & Solaris this is not a problem).

Related to CR 631281: isql -X failing on AIX platform when packaged with ASE server.

Move the lib3p directory in front of the lib3p64 directory in the LIBPATH variable

The problem turns out to be that the isql binary that ships with ASE 15.5/64-bit is a 32 bit app. It requires the 32 bit
version of the csi libs, found in the OCS-15_0/lib3p directory. Move the lib3p directory in front of the lib3p64
directory in the LIBPATH variable then isql -X works. Because ASE is a 64 bit app, it needs the lib3p64 directory to be
first in the LIBPATH variable (That is why the SYBASE.csh file is setup with lib3p64 first).
======================

On 02/21/2012 23:40, John wrote:
> The error ocurr when call "isql -Sxxx -Uxxx -Pxxx -X" in Sybase 15.7 but it
> is fine in Sybase 12.5.4. Please cause is it?
>
> "ct_connet(): protocol specific layer: internal Client Library error: There
> is a tds login error. The installed encryption handler returned a status
> that was not CS_SUCCEED."
> Adaptive Server Enterprise/12.5.4/EBF 13383/P/RS6000/AIX
> 5.1/ase1254/2006/64-bit/FBO/Sat May 20 07:06:10 2006
> Adaptive Server Enterprise/15.7.0/EBF 19625 SMP ONE-OFF/P/RS6000/AIX
> 6.1/ase157/2820/64-bit/FBO/Fri Oct 14 11:43:25 2011
>
> John
>
>


Murali Minchala Posted on 2012-05-30 10:14:20.0Z
Sender: 79a4.4fc5ec64.1804289383@sybase.com
From: Murali Minchala
Newsgroups: sybase.public.ase.general
Subject: Re: isql with "-X" paramter problem
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4fc5f2fc.7aa2.1681692777@sybase.com>
References: <4f44f166$1@forums-1-dub>
NNTP-Posting-Host: 172.20.134.41
X-Original-NNTP-Posting-Host: 172.20.134.41
Date: 30 May 2012 03:14:20 -0700
X-Trace: forums-1-dub 1338372860 172.20.134.41 (30 May 2012 03:14:20 -0700)
X-Original-Trace: 30 May 2012 03:14:20 -0700, 172.20.134.41
Lines: 85
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:31160
Article PK: 74049

Hi

i am still having this problem:

/sybase/syb157>isql -Usa -SCBSDRUAT -w2000 -X
Password:
CT-LIBRARY error:
ct_connect(): protocol specific layer: internal
Client Library error: There is a tds login error. The
installed encryption handler returned a status that was not
CS_SUCCEED.

/sybase/syb157/ASE-15_0/bin>dataserver -v
Adaptive Server Enterprise/15.7.0/EBF 19625 SMP
ONE-OFF/P/RS6000/AIX 6.1/ase157/2820/64-bit/FBO/Fri Oct 14
11:43:25 2011

I changed from

####LIBPATH="/sybase/syb157/OCS-15_0/lib:/sybase/syb157/OCS-15_0/lib3p64:/sybase/syb157/OCS-15_0/lib3p":$LIBPATH

to

LIBPATH="/sybase/syb157/OCS-15_0/lib:/sybase/syb157/OCS-15_0/lib3p:/sybase/syb157/OCS-15_0/lib3p64":$LIBPATH
export LIBPATH

But, still i am having problem. Pls. suggest....

Regards,
Murali Minchala

> From solved cases @ sybase.com:
>
> ======================
> case: 11600992
>
> Description:
>
> After enabling configuration parameter "net password
> encryption reqd" unable to connect to ASE (15.5 on AIX)
>
> $ isql -U sa -P -X
> CT-LIBRARY error:
> ct_connect(): protocol specific layer: internal Client
> Library error: There is a tds login error. The installed
> encryption handler returned a status that was not
> CS_SUCCEED.
>
> Tip/Workaround:
>
> verify OS - problem only exists on AIX (tested internally
> on Windows & Solaris this is not a problem).
>
> Related to CR 631281: isql -X failing on AIX platform when
> packaged with ASE server.
>
> Move the lib3p directory in front of the lib3p64 directory
> in the LIBPATH variable
>
> The problem turns out to be that the isql binary that
> ships with ASE 15.5/64-bit is a 32 bit app. It requires
> the 32 bit version of the csi libs, found in the
> OCS-15_0/lib3p directory. Move the lib3p directory in
> front of the lib3p64 directory in the LIBPATH variable
> then isql -X works. Because ASE is a 64 bit app, it needs
> the lib3p64 directory to be first in the LIBPATH variable
> (That is why the SYBASE.csh file is setup with lib3p64
> first). ======================
>
> On 02/21/2012 23:40, John wrote:
> > The error ocurr when call "isql -Sxxx -Uxxx -Pxxx -X" in
> > Sybase 15.7 but it is fine in Sybase 12.5.4. Please
> cause is it? >
> > "ct_connet(): protocol specific layer: internal Client
> > Library error: There is a tds login error. The
> > installed encryption handler returned a status that was
> > not CS_SUCCEED." Adaptive Server Enterprise/12.5.4/EBF
> > 13383/P/RS6000/AIX 5.1/ase1254/2006/64-bit/FBO/Sat May
> > 20 07:06:10 2006 Adaptive Server Enterprise/15.7.0/EBF
> > 19625 SMP ONE-OFF/P/RS6000/AIX
> 6.1/ase157/2820/64-bit/FBO/Fri Oct 14 11:43:25 2011 >
> > John
> >
> >


Rob V Posted on 2012-05-30 12:54:15.0Z
From: Rob V <rob@sypron.nl>
Reply-To: rob@sypron.nl
User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20120428 Thunderbird/12.0.1
MIME-Version: 1.0
Newsgroups: sybase.public.ase.general
Subject: Re: isql with "-X" paramter problem
References: <4f44f166$1@forums-1-dub> <4fc5f2fc.7aa2.1681692777@sybase.com>
In-Reply-To: <4fc5f2fc.7aa2.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4fc61877$1@forums-1-dub>
Date: 30 May 2012 05:54:15 -0700
X-Trace: forums-1-dub 1338382455 10.22.241.152 (30 May 2012 05:54:15 -0700)
X-Original-Trace: 30 May 2012 05:54:15 -0700, vip152.sybase.com
Lines: 111
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:31162
Article PK: 74051

The 32/64-bit issue is on the client side, not on the ASE server side.
Therefore, the version string of the ASE server (dataserver -v) is
unrelated. Check isql -v instead. If you're using 32-bit isql, remove
all 64-bit libraries from your PATH.

HTH,

Rob V.
-----------------------------------------------------------------
Rob Verschoor

Certified Professional DBA for Sybase ASE, IQ, Replication Server

Author of Sybase books (order online at www.sypron.nl/shop):
"Tips, Tricks & Recipes for Sybase ASE"
"The Complete Sybase IQ Quick Reference Guide" (new!)
"The Complete Sybase ASE Quick Reference Guide"
"The Complete Sybase Replication Server Quick Reference Guide"

rob@NO.SPAM.sypron.nl | www.sypron.nl | Twitter: @rob_verschoor
Sypron B.V., The Netherlands | Chamber of Commerce 27138666
-----------------------------------------------------------------

On 30-May-2012 12:14, Murali Minchala wrote:
> Hi
>
> i am still having this problem:
>
> /sybase/syb157>isql -Usa -SCBSDRUAT -w2000 -X
> Password:
> CT-LIBRARY error:
> ct_connect(): protocol specific layer: internal
> Client Library error: There is a tds login error. The
> installed encryption handler returned a status that was not
> CS_SUCCEED.
>
> /sybase/syb157/ASE-15_0/bin>dataserver -v
> Adaptive Server Enterprise/15.7.0/EBF 19625 SMP
> ONE-OFF/P/RS6000/AIX 6.1/ase157/2820/64-bit/FBO/Fri Oct 14
> 11:43:25 2011
>
> I changed from
>
> ####LIBPATH="/sybase/syb157/OCS-15_0/lib:/sybase/syb157/OCS-15_0/lib3p64:/sybase/syb157/OCS-15_0/lib3p":$LIBPATH
>
> to
>
> LIBPATH="/sybase/syb157/OCS-15_0/lib:/sybase/syb157/OCS-15_0/lib3p:/sybase/syb157/OCS-15_0/lib3p64":$LIBPATH
> export LIBPATH
>
> But, still i am having problem. Pls. suggest....
>
> Regards,
> Murali Minchala
>
>
>> From solved cases @ sybase.com:
>>
>> ======================
>> case: 11600992
>>
>> Description:
>>
>> After enabling configuration parameter "net password
>> encryption reqd" unable to connect to ASE (15.5 on AIX)
>>
>> $ isql -U sa -P -X
>> CT-LIBRARY error:
>> ct_connect(): protocol specific layer: internal Client
>> Library error: There is a tds login error. The installed
>> encryption handler returned a status that was not
>> CS_SUCCEED.
>>
>> Tip/Workaround:
>>
>> verify OS - problem only exists on AIX (tested internally
>> on Windows& Solaris this is not a problem).
>>
>> Related to CR 631281: isql -X failing on AIX platform when
>> packaged with ASE server.
>>
>> Move the lib3p directory in front of the lib3p64 directory
>> in the LIBPATH variable
>>
>> The problem turns out to be that the isql binary that
>> ships with ASE 15.5/64-bit is a 32 bit app. It requires
>> the 32 bit version of the csi libs, found in the
>> OCS-15_0/lib3p directory. Move the lib3p directory in
>> front of the lib3p64 directory in the LIBPATH variable
>> then isql -X works. Because ASE is a 64 bit app, it needs
>> the lib3p64 directory to be first in the LIBPATH variable
>> (That is why the SYBASE.csh file is setup with lib3p64
>> first). ======================
>>
>> On 02/21/2012 23:40, John wrote:
>>> The error ocurr when call "isql -Sxxx -Uxxx -Pxxx -X" in
>>> Sybase 15.7 but it is fine in Sybase 12.5.4. Please
>> cause is it?>
>>> "ct_connet(): protocol specific layer: internal Client
>>> Library error: There is a tds login error. The
>>> installed encryption handler returned a status that was
>>> not CS_SUCCEED." Adaptive Server Enterprise/12.5.4/EBF
>>> 13383/P/RS6000/AIX 5.1/ase1254/2006/64-bit/FBO/Sat May
>>> 20 07:06:10 2006 Adaptive Server Enterprise/15.7.0/EBF
>>> 19625 SMP ONE-OFF/P/RS6000/AIX
>> 6.1/ase157/2820/64-bit/FBO/Fri Oct 14 11:43:25 2011>
>>> John
>>>
>>>


Murali Minchala Posted on 2012-05-30 10:23:20.0Z
Sender: 7adc.4fc5f4b5.1804289383@sybase.com
From: Murali Minchala
Newsgroups: sybase.public.ase.general
Subject: Re: isql with "-X" paramter problem
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4fc5f518.7af4.1681692777@sybase.com>
References: <4f44f166$1@forums-1-dub>
NNTP-Posting-Host: 172.20.134.41
X-Original-NNTP-Posting-Host: 172.20.134.41
Date: 30 May 2012 03:23:20 -0700
X-Trace: forums-1-dub 1338373400 172.20.134.41 (30 May 2012 03:23:20 -0700)
X-Original-Trace: 30 May 2012 03:23:20 -0700, 172.20.134.41
Lines: 86
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:31161
Article PK: 74050

Hi

i am still having this problem:

/sybase/syb157>isql -Usa -SCBSDRUAT -w2000 -X
Password:
CT-LIBRARY error:
ct_connect(): protocol specific layer: internal
Client Library error: There is a tds login error. The
installed encryption handler returned a status that was not
CS_SUCCEED.

/sybase/syb157/ASE-15_0/bin>dataserver -v
Adaptive Server Enterprise/15.7.0/EBF 19625 SMP
ONE-OFF/P/RS6000/AIX 6.1/ase157/2820/64-bit/FBO/Fri Oct 14
11:43:25 2011

I changed from

####LIBPATH="/sybase/syb157/OCS-15_0/lib:/sybase/syb157/OCS-15_0/lib3p64:/sybase/syb157/OCS-15_0/lib3p":$LIBPATH

to

LIBPATH="/sybase/syb157/OCS-15_0/lib:/sybase/syb157/OCS-15_0/lib3p:/sybase/syb157/OCS-15_0/lib3p64":$LIBPATH
export LIBPATH

But, still i am having problem. Pls. suggest....

Regards,
Murali Minchala

> From solved cases @ sybase.com:
>
> ======================
> case: 11600992
>
> Description:
>
> After enabling configuration parameter "net password
> encryption reqd" unable to connect to ASE (15.5 on AIX)
>
> $ isql -U sa -P -X
> CT-LIBRARY error:
> ct_connect(): protocol specific layer: internal Client
> Library error: There is a tds login error. The installed
> encryption handler returned a status that was not
> CS_SUCCEED.
>
> Tip/Workaround:
>
> verify OS - problem only exists on AIX (tested internally
> on Windows & Solaris this is not a problem).
>
> Related to CR 631281: isql -X failing on AIX platform when
> packaged with ASE server.
>
> Move the lib3p directory in front of the lib3p64 directory
> in the LIBPATH variable
>
> The problem turns out to be that the isql binary that
> ships with ASE 15.5/64-bit is a 32 bit app. It requires
> the 32 bit version of the csi libs, found in the
> OCS-15_0/lib3p directory. Move the lib3p directory in
> front of the lib3p64 directory in the LIBPATH variable
> then isql -X works. Because ASE is a 64 bit app, it needs
> the lib3p64 directory to be first in the LIBPATH variable
> (That is why the SYBASE.csh file is setup with lib3p64
> first). ======================
>
> On 02/21/2012 23:40, John wrote:
> > The error ocurr when call "isql -Sxxx -Uxxx -Pxxx -X" in
> > Sybase 15.7 but it is fine in Sybase 12.5.4. Please
> cause is it? >
> > "ct_connet(): protocol specific layer: internal Client
> > Library error: There is a tds login error. The
> > installed encryption handler returned a status that was
> > not CS_SUCCEED." Adaptive Server Enterprise/12.5.4/EBF
> > 13383/P/RS6000/AIX 5.1/ase1254/2006/64-bit/FBO/Sat May
> > 20 07:06:10 2006 Adaptive Server Enterprise/15.7.0/EBF
> > 19625 SMP ONE-OFF/P/RS6000/AIX
> 6.1/ase157/2820/64-bit/FBO/Fri Oct 14 11:43:25 2011 >
> > John
> >
> >