Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

How to add SELECT operation in MBO manually.

2 posts in General Discussion Last posting was on 2012-04-04 13:58:23.0Z
param Posted on 2012-03-29 13:54:25.0Z
Sender: a26.4f746817.1804289383@sybase.com
From: Param
Newsgroups: sybase.public.sup.general
Subject: How to add SELECT operation in MBO manually.
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4f746991.a61.1681692777@sybase.com>
NNTP-Posting-Host: 172.20.134.41
X-Original-NNTP-Posting-Host: 172.20.134.41
Date: 29 Mar 2012 05:54:25 -0800
X-Trace: forums-1-dub 1333029265 172.20.134.41 (29 Mar 2012 05:54:25 -0800)
X-Original-Trace: 29 Mar 2012 05:54:25 -0800, 172.20.134.41
Lines: 18
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.sup.general:933
Article PK: 1087085

Hi List,

We are trying to create a custom SELECT operation having
query as "select customer.id, customer.lname from customer
where customer.fname like "%" + :fname + "%"; its returning
in workspace text execution. But when i select this on
Workflow Menu, I am not getting any Output Key as a List...
This is y my result in simulator coming blank...

How i can capture the return result on this operation?
i tried cache group also but its working only as object
query "findByParameter" ....

Is there anyone? who faced this issue? and solved it?

Please help

-Param


"Reed Shilts [Sybase]" Posted on 2012-04-04 13:58:23.0Z
From: "Reed Shilts [Sybase]" <reed dot shilts at sybase dot com>
Newsgroups: sybase.public.sup.general
Subject: Re: How to add SELECT operation in MBO manually.
Message-ID: <jjkon7lm85g4h09cl0rd4d13tnnlp5rkrn@4ax.com>
References: <4f746991.a61.1681692777@sybase.com>
X-Newsreader: Forte Agent 1.93/32.576 English (American)
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 4 Apr 2012 06:58:23 -0700
X-Trace: forums-1-dub 1333547903 10.22.241.152 (4 Apr 2012 06:58:23 -0700)
X-Original-Trace: 4 Apr 2012 06:58:23 -0700, vip152.sybase.com
Lines: 32
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.sup.general:951
Article PK: 1087103

Does the actual SQL use single quotes ??
Using double quotes would cause a problem.

That's the problem I usually have on this...
(I also force everything to lower case first, or use a
case-insensitive select - server dependent....)

HTH,
Reed Shilts
<Standard-Disclaimers-Apply/>

On 29 Mar 2012 05:54:25 -0800, Param wrote:

>Hi List,
>
>We are trying to create a custom SELECT operation having
>query as "select customer.id, customer.lname from customer
>where customer.fname like "%" + :fname + "%"; its returning
>in workspace text execution. But when i select this on
>Workflow Menu, I am not getting any Output Key as a List...
>This is y my result in simulator coming blank...
>
>How i can capture the return result on this operation?
>i tried cache group also but its working only as object
>query "findByParameter" ....
>
>Is there anyone? who faced this issue? and solved it?
>
>Please help
>
>-Param