Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

stack dump trying to run/create a stored proc

3 posts in General Discussion Last posting was on 2012-05-25 21:10:30.0Z
Ericrad Posted on 2012-05-25 16:50:26.0Z
Sender: 3c77.4fbfb648.1804289383@sybase.com
From: ericrad
Newsgroups: sybase.public.ase.general
Subject: stack dump trying to run/create a stored proc
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4fbfb852.3ce8.1681692777@sybase.com>
NNTP-Posting-Host: 172.20.134.41
X-Original-NNTP-Posting-Host: 172.20.134.41
Date: 25 May 2012 09:50:26 -0700
X-Trace: forums-1-dub 1337964626 172.20.134.41 (25 May 2012 09:50:26 -0700)
X-Original-Trace: 25 May 2012 09:50:26 -0700, 172.20.134.41
Lines: 28
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:31154
Article PK: 74048

A proc that has been running for a long time started to
cause stack dumps in our test env (see version below).

Calling the proc with a parameter (order_number) = -1
causes a return in the first couple of steps in the proc. If
order_number = -1 return 0. There is a lot of other work in
the proc but this call causes the stack dump.

I thought I would rename the proc and rebuild it. The
rename on the proc caused a stack dump and killed my
connection.

I dropped the proc and after a few seconds it was gone.

When I tried to reload the proc I get a stack dump and lose
the connection. The proc has been stable since 2009 and it
used all the time.

Any suggestions on how to trouble-shoot this so I can
reload the proc?

Thanks
eric

select @@version
Adaptive Server Enterprise/15.5/EBF 18657 SMP
ESD#4/P/Sun_svr4/OS 5.8/asear155/2545/64-bit/FBO/Thu Jun 16
10:29:40 2011


Ericrad Posted on 2012-05-25 20:36:49.0Z
Sender: 3c77.4fbfb648.1804289383@sybase.com
From: ericrad
Newsgroups: sybase.public.ase.general
Subject: Re: stack dump trying to run/create a stored proc
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4fbfed61.4623.1681692777@sybase.com>
References: <4fbfb852.3ce8.1681692777@sybase.com>
NNTP-Posting-Host: 172.20.134.41
X-Original-NNTP-Posting-Host: 172.20.134.41
Date: 25 May 2012 13:36:49 -0700
X-Trace: forums-1-dub 1337978209 172.20.134.41 (25 May 2012 13:36:49 -0700)
X-Original-Trace: 25 May 2012 13:36:49 -0700, 172.20.134.41
Lines: 38
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:31158
Article PK: 74047

Hi,
As I began to experience more odd behavior I decided to
reboot my db server and that seems to have cleared it all
up. The commands that were failing now work.

Any insight into what may have been going on?

Thanks
eric

> A proc that has been running for a long time started to
> cause stack dumps in our test env (see version below).
>
> Calling the proc with a parameter (order_number) = -1
> causes a return in the first couple of steps in the proc.
> If order_number = -1 return 0. There is a lot of other
> work in the proc but this call causes the stack dump.
>
> I thought I would rename the proc and rebuild it. The
> rename on the proc caused a stack dump and killed my
> connection.
>
> I dropped the proc and after a few seconds it was gone.
>
> When I tried to reload the proc I get a stack dump and
> lose the connection. The proc has been stable since 2009
> and it used all the time.
>
> Any suggestions on how to trouble-shoot this so I can
> reload the proc?
>
> Thanks
> eric
>
> select @@version
> Adaptive Server Enterprise/15.5/EBF 18657 SMP
> ESD#4/P/Sun_svr4/OS 5.8/asear155/2545/64-bit/FBO/Thu Jun
> 16 10:29:40 2011


Bret Halford Posted on 2012-05-25 21:10:30.0Z
From: Bret Halford <bret@sybase.com>
User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20120428 Thunderbird/12.0.1
MIME-Version: 1.0
Newsgroups: sybase.public.ase.general
Subject: Re: stack dump trying to run/create a stored proc
References: <4fbfb852.3ce8.1681692777@sybase.com> <4fbfed61.4623.1681692777@sybase.com>
In-Reply-To: <4fbfed61.4623.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4fbff546$1@forums-1-dub>
Date: 25 May 2012 14:10:30 -0700
X-Trace: forums-1-dub 1337980230 10.22.241.152 (25 May 2012 14:10:30 -0700)
X-Original-Trace: 25 May 2012 14:10:30 -0700, vip152.sybase.com
Lines: 46
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:31159
Article PK: 74046

Perhaps if you post the stacks and any other
errors?

-bret

On 5/25/2012 2:36 PM, ericrad wrote:
> Hi,
> As I began to experience more odd behavior I decided to
> reboot my db server and that seems to have cleared it all
> up. The commands that were failing now work.
>
> Any insight into what may have been going on?
>
> Thanks
> eric
>
>> A proc that has been running for a long time started to
>> cause stack dumps in our test env (see version below).
>>
>> Calling the proc with a parameter (order_number) = -1
>> causes a return in the first couple of steps in the proc.
>> If order_number = -1 return 0. There is a lot of other
>> work in the proc but this call causes the stack dump.
>>
>> I thought I would rename the proc and rebuild it. The
>> rename on the proc caused a stack dump and killed my
>> connection.
>>
>> I dropped the proc and after a few seconds it was gone.
>>
>> When I tried to reload the proc I get a stack dump and
>> lose the connection. The proc has been stable since 2009
>> and it used all the time.
>>
>> Any suggestions on how to trouble-shoot this so I can
>> reload the proc?
>>
>> Thanks
>> eric
>>
>> select @@version
>> Adaptive Server Enterprise/15.5/EBF 18657 SMP
>> ESD#4/P/Sun_svr4/OS 5.8/asear155/2545/64-bit/FBO/Thu Jun
>> 16 10:29:40 2011