Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

User Access Denied Error

2 posts in Windows NT Last posting was on 2001-01-18 21:17:00.0Z
kharper Posted on 2001-01-18 20:41:41.0Z
From: "kharper" <kharper@co.slo.ca.us>
Subject: User Access Denied Error
Date: Thu, 18 Jan 2001 12:41:41 -0800
Lines: 15
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2314.1300
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
Message-ID: <5R0oWFZgAHA.294@forums.sybase.com>
Newsgroups: sybase.public.sqlserver.nt
NNTP-Posting-Host: 204.88.255.73
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:1295
Article PK: 1088762

Hi:
I am submitting an Execute Stored Procedure command to my ASE 11.9.2 running
on Windows NT
via gateway between a mainframe CICS system and ASE 11.9.2 and it works
fine except for xp_cmdshell commands which return the error message "User
access denied. Not a member of NT Administrators group".

I gave the stored procedure execute security to the user id I am logging in
with. Do I need to define
this same user id to Windows NT in order to run the xp_cmdshell commands?

Thanks


kharper Posted on 2001-01-18 21:17:00.0Z
From: "kharper" <kharper@co.slo.ca.us>
References: <5R0oWFZgAHA.294@forums.sybase.com>
Subject: Re: User Access Denied Error
Date: Thu, 18 Jan 2001 13:17:00 -0800
Lines: 25
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2314.1300
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
Message-ID: <6L3qFZZgAHA.294@forums.sybase.com>
Newsgroups: sybase.public.sqlserver.nt
NNTP-Posting-Host: 204.88.255.73
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:1294
Article PK: 1088761

Problem fixed! It appears I needed to set my xp_cmdshell context to 0
rather than the default of 1. Now ASE 11.9.2
does not try and use the Windows NT user permissions.

kharper <kharper@co.slo.ca.us> wrote in message
news:5R0oWFZgAHA.294@forums.sybase.com...
> Hi:
> I am submitting an Execute Stored Procedure command to my ASE 11.9.2
running
> on Windows NT
> via gateway between a mainframe CICS system and ASE 11.9.2 and it works
> fine except for xp_cmdshell commands which return the error message "User
> access denied. Not a member of NT Administrators group".
>
> I gave the stored procedure execute security to the user id I am logging
in
> with. Do I need to define
> this same user id to Windows NT in order to run the xp_cmdshell commands?
>
> Thanks
>
>
>