Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

BCP connection woes

4 posts in Windows NT Last posting was on 1997-12-05 22:16:25.0Z
Victor Grazi Posted on 1997-12-01 21:48:06.0Z
From: "Victor Grazi" <victor@iy.com>
Subject: BCP connection woes
Date: Mon, 1 Dec 1997 16:48:06 -0500
Organization: Monmouth Internet
Lines: 24
Message-ID: <65vbca$kpr$1@news.monmouth.com>
X-Newsreader: Microsoft Outlook Express 4.71.1712.3
X-MimeOLE: Produced By Microsoft MimeOLE V4.71.1712.3
Newsgroups: sybase.public.sqlserver.nt
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com!node17.frontiernet.net!node2.frontiernet.net!europa.clark.net!4.1.16.34!cpk-news-hub1.bbnplanet.com!news.bbnplanet.com!newspeer.monmouth.com!news.monmouth.com!not-for-mail
Xref: forums-1-dub sybase.public.sqlserver.nt:5377
Article PK: 1081462

I am running Sybase Adaptive Server 11.5 on NT.
In Sybase Central I see my Server is STGNT01, database is stgData, and table
is orderHeader. The userid is 'usr' and password is 'pwd'

I wish to use BCP to load data from the file
C:\SYBASE\STGDATA\UNLOAD\161.dat
(which was generated by sqlAnywhere)

Here is the command line I use and the resulting error message

C:\>bcp stgData.products in C:\SYBASE\STGDATA\UNLOAD\161.dat -I usr -P pwd
-S STGNT01
CTLIB Message: - L6/O8/S5/N3/5/0:
ct_connect(): directory service layer: internal directory control layer
error: R
equested server name not found.
Establishing connection failed.

I have tried many variations with quotes, double quotes, etc. always the
same result.

Any ideas?


David Webb Posted on 1997-12-05 22:16:25.0Z
Message-ID: <34887D39.729F@nwrain.com>
Date: Fri, 05 Dec 1997 14:16:25 -0800
From: David Webb <dwebb@nwrain.com>
Reply-To: dwebb@nwrain.com
Organization: Frank Russell Company
X-Mailer: Mozilla 3.01 (Win95; I)
MIME-Version: 1.0
Subject: Re: BCP connection woes
References: <65vbca$kpr$1@news.monmouth.com>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.sqlserver.nt
Lines: 24
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.sqlserver.nt:5367
Article PK: 1081450


Victor Grazi wrote:
>
> I am running Sybase Adaptive Server 11.5 on NT.
> In Sybase Central I see my Server is STGNT01, database is stgData, and table
> is orderHeader. The userid is 'usr' and password is 'pwd'
>
> I wish to use BCP to load data from the file
> C:\SYBASE\STGDATA\UNLOAD\161.dat
> (which was generated by sqlAnywhere)
>
> Here is the command line I use and the resulting error message
>
> C:\>bcp stgData.products in C:\SYBASE\STGDATA\UNLOAD\161.dat -I usr -P pwd
> -S STGNT01
> CTLIB Message: - L6/O8/S5/N3/5/0:
> ct_connect(): directory service layer: internal directory control layer
> error: R
> equested server name not found.
> Establishing connection failed.
>
> I have tried many variations with quotes, double quotes, etc. always the
> same result.
>
> Any ideas?

Change the -I to -U. Also, I think the stgData.products should be
stgData..products

David Webb
Frank Russell Company


Matt Van Rensburg Posted on 1997-12-04 08:57:50.0Z
Message-ID: <3486708E.5851@usa.net>
Date: Thu, 04 Dec 1997 08:57:50 +0000
From: Matt Van Rensburg <mattvan@usa.net>
Reply-To: mattvan@usa.net
Organization: Exabyte
X-Mailer: Mozilla 3.0 (WinNT; I)
MIME-Version: 1.0
Subject: Re: BCP connection woes
References: <65vbca$kpr$1@news.monmouth.com>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.sqlserver.nt
Lines: 27
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.sqlserver.nt:5372
Article PK: 1081451

Hi Victor

Your problem is your bcp command. The flag "-I" is used to specify where
to
look for the sql.ini file. Replace "-I" with "-U"
The "-U" command specifies username.
Your command should look as follows:
C:\>bcp stgData.products in C:\SYBASE\STGDATA\UNLOAD\161.dat
-U usr -P pwd -S STGNT01

HTH
Matt Van Rensburg

Victor Grazi wrote:
>
> I am running Sybase Adaptive Server 11.5 on NT.
> In Sybase Central I see my Server is STGNT01, database is stgData, and table
> is orderHeader. The userid is 'usr' and password is 'pwd'
>
> I wish to use BCP to load data from the file
> C:\SYBASE\STGDATA\UNLOAD\161.dat
> (which was generated by sqlAnywhere)
>
> Here is the command line I use and the resulting error message
>
> C:\>bcp stgData.products in C:\SYBASE\STGDATA\UNLOAD\161.dat -I usr -P pwd
> -S STGNT01
> CTLIB Message: - L6/O8/S5/N3/5/0:
> ct_connect(): directory service layer: internal directory control layer
> error: R
> equested server name not found.
> Establishing connection failed.
>


Mark A. Parsons Posted on 1997-12-02 23:42:09.0Z
Message-ID: <34849CD1.7101@compuserve.com>
Date: Tue, 02 Dec 1997 18:42:09 -0500
From: "Mark A. Parsons" <Iron_Horse@compuserve.com>
Reply-To: Iron_Horse@compuserve.com
Organization: Iron Horse, Inc.
X-Mailer: Mozilla 3.01 (Win95; I)
MIME-Version: 1.0
Subject: Re: BCP connection woes
References: <65vbca$kpr$1@news.monmouth.com>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.sqlserver.nt
Lines: 48
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.sqlserver.nt:5375
Article PK: 1081457

I zero'd in on the "Requested server name not found." This could mean
one of several things ...

1) STGNT01 is not defined properly in your interfaces file. (If it *is*
there ... how did it get entered? by hand? by the ini editor? by
sybconfig? If by hand you may not have followed the 'proper' format ...
try redefining via the ini editor or sybconfig?)

2) Your $SYBASE environment variable is not pointing at the directory
where your interfaces file is located. Can you verify that your $SYBASE
environment variable is set properly? A quick check to see if this is
the problem ... use the 'I <interfaces_file>' option to bcp (I've used
the UNIX flag ... check your NT Utilities manual for specific flag
useage) ... if this works (putting the interfaces file location on the
bcp command line) then you know you have a problem with the
value/setting of your $SYBASE environment variable.

Then again ... there may be something else to your error messages ...
but, alas, I'm not much of an NT 'type' .... ???

Mark Parsons
Iron Horse, Inc.

Victor Grazi wrote:
>
> I am running Sybase Adaptive Server 11.5 on NT.
> In Sybase Central I see my Server is STGNT01, database is stgData, and table
> is orderHeader. The userid is 'usr' and password is 'pwd'
>
> I wish to use BCP to load data from the file
> C:\SYBASE\STGDATA\UNLOAD\161.dat
> (which was generated by sqlAnywhere)
>
> Here is the command line I use and the resulting error message
>
> C:\>bcp stgData.products in C:\SYBASE\STGDATA\UNLOAD\161.dat -I usr -P pwd
> -S STGNT01
> CTLIB Message: - L6/O8/S5/N3/5/0:
> ct_connect(): directory service layer: internal directory control layer
> error: R
> equested server name not found.
> Establishing connection failed.
>
> I have tried many variations with quotes, double quotes, etc. always the
> same result.
>
> Any ideas?