Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

lock sleep processes, CPU usage at 90% + on the NT 4.0 server using 11.5

2 posts in Windows NT Last posting was on 1999-12-04 07:51:16.0Z
saeed Posted on 1999-12-03 12:25:19.0Z
From: "saeed" <saeed@ixpnet.com>
Subject: lock sleep processes, CPU usage at 90% + on the NT 4.0 server using 11.5
Date: Fri, 3 Dec 1999 04:25:19 -0800
Lines: 11
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2314.1300
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
Message-ID: <67gDP4eP$GA.204@forums.sybase.com>
Newsgroups: sybase.public.sqlserver.nt
NNTP-Posting-Host: 12.18.130.249
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:2898
Article PK: 1090335

I get lock sleep processes under the server and CPU usage goes up and stays
at 90% + on the NT 4.0 server using 11.5.

I would not wish this on anyone, but has anyone had this problem. I have
been fighting this, already opened case with Sybase, no solution yet.
Customer getting angry. Any ideas.


Saeed


Arun Kamat Posted on 1999-12-04 07:51:16.0Z
Message-ID: <3848C7F4.A1286972@tkg.att.ne.jp>
Date: Sat, 04 Dec 1999 16:51:16 +0900
From: Arun Kamat <annarun@tkg.att.ne.jp>
X-Mailer: Mozilla 4.05 [en] (Win95; I)
MIME-Version: 1.0
To: saeed <saeed@ixpnet.com>
Subject: Re: lock sleep processes, CPU usage at 90% + on the NT 4.0 server using 11.5
References: <67gDP4eP$GA.204@forums.sybase.com>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.sqlserver.nt
Lines: 27
NNTP-Posting-Host: 50.pool19.tokyo.att.ne.jp 165.76.224.65
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:2897
Article PK: 1090333

Saeed,

You would see lock sleep processes if they are waiting to acquire locks on a
page/table. This could be due to various direct & indirect reasons such as
database design, app design, long transactions, low cache etc. The system also
should have high speed hardware to complete transactions in a short time. Also
it depends on how many users you have on the NT server and on ASE server. Did
the cpu utilisation show 90% due to ASE only or were there any other processes
running at the same time?

To start with could you please specify the following:
ASE version - do a select @@version
total memory for ASE
total NT server memory
cpu specifications, no. of cpus
No. of ASE engines, min and max
No. of users on the ASE server - and what they do when the CPU show 90%
No. of other processes on the NT server
Output of sp_sysmon for a short time interval when cpu hits 90% or so...

cheers,
arun

> I get lock sleep processes under the server and CPU usage goes up and stays
> at 90% + on the NT 4.0 server using 11.5.
>