Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Manage Anywhere Studio agent on XP Embedded?

6 posts in General Discussion Last posting was on 2003-01-30 07:37:22.0Z
Phil_Beutel Posted on 2003-01-29 07:20:51.0Z
From: Phil_Beutel
Date: Wed, 29 Jan 2003 02:20:51 -0500
Newsgroups: ianywhere.public.general
Subject: Manage Anywhere Studio agent on XP Embedded?
Message-ID: <83E113A81AF0A9D600285C5385256CBD.00285C7285256CBD@webforums>
Lines: 19
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com!webforums.sybase.com!news
Xref: forums-1-dub ianywhere.public.general:228
Article PK: 2049

Hi,
Has anyone run the Manage Anywhere Studio agent on Windows XP Embedded?

The first time that I install and run the agent everything works fine,
packages execute etc as per normal but when I reboot, the agent never
contacts the server again.

It looks like the agent creates (or causes something else to) the
directories c:\Windows\Cookies, c:\Windows\History and c:\Windows\Temporary
Internet Files when the PC is rebooted after the initial installation of
the agent and this causes all internet based functionality of XPE to fail
because of cache errors. Is there any reason that MAS agent would do this?

We have installed nothing else, used internet explorer and rebooted many
times prior to the installation of MAS Agent without these directories
being created.

Regards
Phil Beutel


Raymond_Kwong Posted on 2003-01-30 00:22:38.0Z
From: Raymond_Kwong
Date: Wed, 29 Jan 2003 19:22:38 -0500
Newsgroups: ianywhere.public.general
Subject: Re: Manage Anywhere Studio agent on XP Embedded?
Message-ID: <1FBA6FB8EFA355860002127685256CBE.002BAF2085256CBD@webforums>
References: <83E113A81AF0A9D600285C5385256CBD.00285C7285256CBD@webforums>
Lines: 10
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com!webforums.sybase.com!news
Xref: forums-1-dub ianywhere.public.general:214
Article PK: 2034

I seriously doubt if MAS has anything to do with this.

1. Usually agent installation does not require reboot.

2. The agent comminicates with the Command server through HTTP. Does the
Web browser have difficulty accessing http://Servername/ma2000?

3. What would happen if you simply copy the setup.exe file from the Command
Server to a diskette (or place it over a network share) and have the XPE
boxes execute setup.exe directly?


Phil_Beutel Posted on 2003-01-30 07:37:22.0Z
From: Phil_Beutel
Date: Thu, 30 Jan 2003 02:37:22 -0500
Newsgroups: ianywhere.public.general
Subject: Re: Manage Anywhere Studio agent on XP Embedded?
Message-ID: <E2A790CB6D13ED940029DF3F85256CBE.000552C185256CBE@webforums>
References: <83E113A81AF0A9D600285C5385256CBD.00285C7285256CBD@webforums> <1FBA6FB8EFA355860002127685256CBE.002BAF2085256CBD@webforums>
Lines: 13
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com!webforums.sybase.com!news
Xref: forums-1-dub ianywhere.public.general:210
Article PK: 2029

Looks like I have solved my problem.

When I reboot the PC it looks like something to do with MAS agent
overwrites the following files in c:\windows\system32
- schannel.dll
- wininet.dll
- regsvr32.exe

So by replacing these files with original ones and removing the cookies and
history directories under c:\windows all it works again.

Thanks
Phil.


Phil_Beutel Posted on 2003-01-30 04:18:31.0Z
From: Phil_Beutel
Date: Wed, 29 Jan 2003 23:18:31 -0500
Newsgroups: ianywhere.public.general
Subject: Re: Manage Anywhere Studio agent on XP Embedded?
Message-ID: <87070144A1B4D6940017AAB485256CBE.000552C185256CBE@webforums>
References: <83E113A81AF0A9D600285C5385256CBD.00285C7285256CBD@webforums> <1FBA6FB8EFA355860002127685256CBE.002BAF2085256CBD@webforums>
Lines: 11
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com!webforums.sybase.com!news
Xref: forums-1-dub ianywhere.public.general:211
Article PK: 2031

Raymond,
I have installed the agent both ways, that is via http://servername\ma2000
and by copying setup.exe over to the client machine. Both methods work
fine and the agent installs correctly and runs fine, packages install
etc...

It is only when I reboot (not because MAS agent asked to) that things go
wrong.

I have also noticed that the WebClient service does not run after the
reboot and can not be started, I don't know why it won't start.

Phil


Eric Bencina Posted on 2003-01-29 16:14:33.0Z
From: "Eric Bencina" <nospam_ebencina@sybase.com>
References: <83E113A81AF0A9D600285C5385256CBD.00285C7285256CBD@webforums>
Subject: Re: Manage Anywhere Studio agent on XP Embedded?
Date: Wed, 29 Jan 2003 11:14:33 -0500
Lines: 31
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.50.4807.1700
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4910.0300
Message-ID: <FK6OlQ7xCHA.254@forums.sybase.com>
Newsgroups: ianywhere.public.general
NNTP-Posting-Host: 172.31.141.130
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub ianywhere.public.general:223
Article PK: 2047

Hi Phil,

What version of Manage Anywhere are you using?

Eric Bencina

<Phil_Beutel> wrote in message
news:83E113A81AF0A9D600285C5385256CBD.00285C7285256CBD@webforums...
> Hi,
> Has anyone run the Manage Anywhere Studio agent on Windows XP Embedded?
>
> The first time that I install and run the agent everything works fine,
> packages execute etc as per normal but when I reboot, the agent never
> contacts the server again.
>
> It looks like the agent creates (or causes something else to) the
> directories c:\Windows\Cookies, c:\Windows\History and
c:\Windows\Temporary
> Internet Files when the PC is rebooted after the initial installation of
> the agent and this causes all internet based functionality of XPE to fail
> because of cache errors. Is there any reason that MAS agent would do this?
>
> We have installed nothing else, used internet explorer and rebooted many
> times prior to the installation of MAS Agent without these directories
> being created.
>
> Regards
> Phil Beutel
>


Phil_Beutel Posted on 2003-01-29 22:46:07.0Z
From: Phil_Beutel
Date: Wed, 29 Jan 2003 17:46:07 -0500
Newsgroups: ianywhere.public.general
Subject: Re: Manage Anywhere Studio agent on XP Embedded?
Message-ID: <2F8A7E4A1AF4C34D007D124C85256CBD.0060249685256CBD@webforums>
References: <83E113A81AF0A9D600285C5385256CBD.00285C7285256CBD@webforums> <FK6OlQ7xCHA.254@forums.sybase.com>
Lines: 4
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com!webforums.sybase.com!news
Xref: forums-1-dub ianywhere.public.general:216
Article PK: 2035

Eric,
I am using version 4.6.1235.0.

Phil