Hello,

we are running MS SQL Server 6.5 on an Alpha NT Platform. Recently we added
a Sybase ASE 12 SQL Server running on an Intel NT platform. We want to
replicate a small set of data from the Alpha System to the new Server using
ODBC replication. Unfortunately there seems to be no ODBC Driver for Sybase
running on a Alpha platform available. So we tried to use the Microsoft
ODBC Driver. Before we have installed the new Sybase ASE 12 Server we
already tried it with an older Version (11.x) and everything worked fine.
Replicating to version 12 already fails during the connection of the
distribution task. We traced the ODBC API calls and have found out that the
task hangs when releasing the last statement resources. The last command
sent to the Sybase Server was SQLGetTypeInfo(-3) which in return calls the
stored procedure "sp_datatype_info -3". After the result has been fetched
the replication task uses SQLFreeStmt to release allocated resources. The
function never returns. The server process is active. It is not poss
ible to kill the process. Using sp_who the following information is
returned:

fid spid status loginame ...
------ ------ ------------ ------------
0 10 recv sleep sa

origname hostname blk_spid dbname ...
------------ ---------- -------- ----------
sa 0 IpVox

cmd block_xloid
---------------- -----------
AWAITING COMMAND 0

BTW: Connecting the sybase server with other ODBC Applications works fine
(msquery for example).

Our question: Does anybody know if there is a solution for this problem.
The best solution would be a native ODBC driver for Alpha NT.

Thanks in advance
Ralf