Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

sp_threshold action not executing, why

7 posts in Backup and Recovery Last posting was on 2001-04-03 00:02:39.0Z
Jeff.schlaver Posted on 2001-03-14 21:24:56.0Z
From: Jeff.schlaver@starzencore.com
Date: Wed, 14 Mar 2001 16:24:56 -0500
Newsgroups: sybase.public.sqlserver.backup+recovery
Subject: sp_threshold action not executing, why
Message-ID: <C373B2E63C4E978D0075A39F85256A0F.0075A3AF85256A0F@webforums>
Lines: 11
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com!webforums.sybase.com!news
Xref: forums-1-dub sybase.public.sqlserver.backup+recovery:400
Article PK: 1060922

Has any one encountered this problem, and know how to fix it??

I created the sp_thresholdaction, granted all on sp_thresholdaction to
public,
sp_adthreshold [db], logsegment, [free_space], sp_thresholdaction.

I can watch the free space fall below the free_space I set and the
sp_thresholdaction
never executes.

Adaptive Server Enterprise/12.0.0.1/P/SWR 9190 ESD 2/HP9000-829/HP-UX
11.0/1626/32bit/FBO/Thu Aug 3 13:45:41 2000


Anthony Mandic <amandic Posted on 2001-03-15 05:52:25.0Z
Date: Thu, 15 Mar 2001 16:52:25 +1100
From: Anthony Mandic <amandic@*t.com.au>
Organization: Mandic Consulting Pty. Ltd.
X-Mailer: Mozilla 4.72 [en] (X11; U; Linux 2.2.14-5.0 i686)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Re: sp_threshold action not executing, why
References: <C373B2E63C4E978D0075A39F85256A0F.0075A3AF85256A0F@webforums>
Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: 8bit
Message-ID: <hv4zEZRrAHA.266@forums.sybase.com>
Newsgroups: sybase.public.sqlserver.backup+recovery
Lines: 7
NNTP-Posting-Host: 210.9.51.46
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.backup+recovery:398
Article PK: 1060916


Jeff.schlaver@starzencore.com wrote:
>
> Has any one encountered this problem, and know how to fix it??

Can you post your sp_thresholdaction sproc? How is the
log being filled? By multiple transactions or one large
one that is still open?

-am © 2001


Jeff Posted on 2001-03-15 15:43:17.0Z
From: Jeff
Date: Thu, 15 Mar 2001 10:43:17 -0500
Newsgroups: sybase.public.sqlserver.backup+recovery
Subject: Re: sp_threshold action not executing, why
Message-ID: <E3E39DE08335F34D00565C4485256A10.0022BA1485256A10@webforums>
References: <C373B2E63C4E978D0075A39F85256A0F.0075A3AF85256A0F@webforums> <hv4zEZRrAHA.266@forums.sybase.com>
Lines: 17
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com!webforums.sybase.com!news
Xref: forums-1-dub sybase.public.sqlserver.backup+recovery:396
Article PK: 1060915

create proc first_alert
(@dbname varchar(30),
@segmentname varchar(30),
@space_left int,
@status int)

as
print "Only %1! pages left in %2! of %3!.", @space_left, @segmentname,
@dbname

return
go
grant all on first_alert to public
go

Multiple transactions, and I watched it sit at a level just past the
threshold for 2 minutes, before loggin more transactions.


Anthony Mandic <amandic Posted on 2001-03-15 22:39:20.0Z
Date: Fri, 16 Mar 2001 09:39:20 +1100
From: Anthony Mandic <amandic@*t.com.au>
Organization: Mandic Consulting Pty. Ltd.
X-Mailer: Mozilla 4.72 [en] (X11; U; Linux 2.2.14-5.0 i686)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Re: sp_threshold action not executing, why
References: <C373B2E63C4E978D0075A39F85256A0F.0075A3AF85256A0F@webforums> <hv4zEZRrAHA.266@forums.sybase.com> <E3E39DE08335F34D00565C4485256A10.0022BA1485256A10@webforums>
Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: 8bit
Message-ID: <XCVEyLarAHA.53@forums.sybase.com>
Newsgroups: sybase.public.sqlserver.backup+recovery
Lines: 18
NNTP-Posting-Host: 210.9.51.46
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.backup+recovery:392
Article PK: 1060910


Jeff wrote:
>
> create proc first_alert
> (@dbname varchar(30),
> @segmentname varchar(30),
> @space_left int,
> @status int)
>
> as
> print "Only %1! pages left in %2! of %3!.", @space_left, @segmentname,
> @dbname
>
> return
> go
> grant all on first_alert to public
> go
>
> Multiple transactions, and I watched it sit at a level just past the
> threshold for 2 minutes, before loggin more transactions.

I'm confused (in the sense that I have no idea what this is
supposed to be). Ordinarily, you would create an sproc called
'sp_thresholdaction' which executes a transaction log dump.
I can see what the above sproc does, but where does it fit in?

-am © 2001


Jeff Posted on 2001-03-15 23:07:03.0Z
From: Jeff
Date: Thu, 15 Mar 2001 18:07:03 -0500
Newsgroups: sybase.public.sqlserver.backup+recovery
Subject: Re: sp_threshold action not executing, why
Message-ID: <FB4533D3E8163428007EFD0585256A10.007E31C585256A10@webforums>
References: <C373B2E63C4E978D0075A39F85256A0F.0075A3AF85256A0F@webforums> <hv4zEZRrAHA.266@forums.sybase.com> <E3E39DE08335F34D00565C4485256A10.0022BA1485256A10@webforums> <XCVEyLarAHA.53@forums.sybase.com>
Lines: 18
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com!webforums.sybase.com!news
Xref: forums-1-dub sybase.public.sqlserver.backup+recovery:391
Article PK: 1060909

Sorry,
It does not matter if it is sp_thresholdaction or first_alert
I set an sp_addthreshold for both. Neither executes.

I removed the thresholdaction and added the "first_alert"
just wanted to see if something would show up in the log file. I set
several thresholds about 2M appart. no log entries showed up.

I also found that sp_helpsegment logsegment returns the following

total_size total_pages free_pages used_pages
---------------------- ----------- ----------- -----------
425.0MB 217600 783121 -565521

I'm thinking that this has something to do with my problem.
But can't figure out how to correct this.

Hope this clairifies thanks


"Mark A. Parsons" <pegasys Posted on 2001-04-03 00:02:39.0Z
Message-ID: <3AC9131F.3D4D4899@_internet.co.nz>
Date: Tue, 03 Apr 2001 12:02:39 +1200
From: "Mark A. Parsons" <pegasys@_internet.co.nz>
Organization: Pegasys (2000) Limited
X-Mailer: Mozilla 4.76 [en] (Win98; U)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Re: sp_threshold action not executing, why
References: <C373B2E63C4E978D0075A39F85256A0F.0075A3AF85256A0F@webforums> <hv4zEZRrAHA.266@forums.sybase.com> <E3E39DE08335F34D00565C4485256A10.0022BA1485256A10@webforums> <XCVEyLarAHA.53@forums.sybase.com> <FB4533D3E8163428007EFD0585256A10.007E31C585256A10@webforums>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.sqlserver.backup+recovery
Lines: 32
NNTP-Posting-Host: ip-210-48-25-181.asiaonline.net.nz 210.48.25.181
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.backup+recovery:343
Article PK: 1060858

Just curious ...

What command(s) did you use to define the thresholds and the associated
actions?

Can you actually see the thresholds and first_alert defined/attached to
your various thresholds? (The name of the system proc escapes me at the
moment ... something like sp_helpthreshold ?)

Just asking the normal 'stupid' questions first ... ?? <g>

Jeff wrote:

> Sorry,
> It does not matter if it is sp_thresholdaction or first_alert
> I set an sp_addthreshold for both. Neither executes.
>
> I removed the thresholdaction and added the "first_alert"
> just wanted to see if something would show up in the log file. I set
> several thresholds about 2M appart. no log entries showed up.
>
> I also found that sp_helpsegment logsegment returns the following
>
> total_size total_pages free_pages used_pages
> ---------------------- ----------- ----------- -----------
> 425.0MB 217600 783121 -565521
>
> I'm thinking that this has something to do with my problem.
> But can't figure out how to correct this.
>
> Hope this clairifies thanks

--
Mark A. Parsons

Iron Horse, Inc. iron_horse@compuserve.com
Pegasys (2000), Ltd pegasys@internet.co.nz


Anthony Mandic <amandic Posted on 2001-03-15 23:47:31.0Z
Date: Fri, 16 Mar 2001 10:47:31 +1100
From: Anthony Mandic <amandic@*t.com.au>
Organization: Mandic Consulting Pty. Ltd.
X-Mailer: Mozilla 4.72 [en] (X11; U; Linux 2.2.14-5.0 i686)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Re: sp_threshold action not executing, why
References: <C373B2E63C4E978D0075A39F85256A0F.0075A3AF85256A0F@webforums> <hv4zEZRrAHA.266@forums.sybase.com> <E3E39DE08335F34D00565C4485256A10.0022BA1485256A10@webforums> <XCVEyLarAHA.53@forums.sybase.com> <FB4533D3E8163428007EFD0585256A10.007E31C585256A10@webforums>
Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: 8bit
Message-ID: <ZeWG5xarAHA.302@forums.sybase.com>
Newsgroups: sybase.public.sqlserver.backup+recovery
Lines: 28
NNTP-Posting-Host: 210.9.51.46
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.backup+recovery:390
Article PK: 1060908


Jeff wrote:

> It does not matter if it is sp_thresholdaction or first_alert
> I set an sp_addthreshold for both. Neither executes.
>
> I removed the thresholdaction and added the "first_alert"
> just wanted to see if something would show up in the log file. I set
> several thresholds about 2M appart. no log entries showed up.
>
> I also found that sp_helpsegment logsegment returns the following
>
> total_size total_pages free_pages used_pages
> ---------------------- ----------- ----------- -----------
> 425.0MB 217600 783121 -565521
>
> I'm thinking that this has something to do with my problem.
> But can't figure out how to correct this.

Its a bug to do with free space accounting. I'm not sure
if its related to the problem or not, but if you contact
Sybase Tech Support they'll be able to help you correct it.
You may want to check the threshold issue with them as well.
Perhaps, fixing the free space will solve the threshold issue
but if not, you can raise it as a bug with Tech Support.

-am © 2001