Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

CIS on Win 2K Server?

2 posts in Windows NT Last posting was on 2000-12-15 22:11:43.0Z
lritter Posted on 2000-12-14 17:07:56.0Z
From: lritter@CreativeSolutions.com
Date: Thu, 14 Dec 2000 12:07:56 -0500
Newsgroups: sybase.public.sqlserver.nt
Subject: CIS on Win 2K Server?
Message-ID: <C693900CA48F74B1005E1C25852569B5.005E1C33852569B5@webforums>
Lines: 28
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com!webforums.sybase.com!news
Xref: forums-1-dub sybase.public.sqlserver.nt:1403
Article PK: 1088869

We are in the process of converting a critical system from ASE 11.9.2.3 on
Win NT 4 to ASE 11.9.2.3 on Win 2000 Server.

Everything seems to be functioning ok EXCEPT I'm not able to use CIS to
connect to a remote ASE 11.9.2.3 database.

I am able to logon to the local server and run SQL Advantage logging in to
the remote server.

sp_configure has been run to turn cis on.

sp_addserver has been run to establish both local and remote servers.

sp_addexternlogin has been run to establish the login (same on both
servers)

server has been restarted several times.

when logged in via Sql Advantage using the identified login,

connect to remote_server_name returns:

Server Message: Number 10331, Severity 14
Server 'DEXSYB01', Line 1:
CONNECT permission denied, database master, owner dbo

Thanks!

Linda


Gordon Posted on 2000-12-15 22:11:43.0Z
Message-ID: <3A3A971F.ABD871DA@sybase.com>
Date: Fri, 15 Dec 2000 15:11:43 -0700
From: Gordon <gsams@sybase.com>
Organization: Sybase, Inc.
X-Mailer: Mozilla 4.7 [en]C-CCK-MCD (WinNT; I)
X-Accept-Language: en
MIME-Version: 1.0
To: lritter@CreativeSolutions.com
Subject: Re: CIS on Win 2K Server?
References: <C693900CA48F74B1005E1C25852569B5.005E1C33852569B5@webforums>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.sqlserver.nt
Lines: 32
NNTP-Posting-Host: gsams-pc2.sybase.com 157.133.215.54
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:1388
Article PK: 1088854

Linda,

Try granting connect to authority to the login you are using.

grant connect to user_name

This is discussed in Chapter 2 of the CIS User's Guide under the heading "The
connect to Command".

I believe sa has this privilege implicitly, but any other login must have it
granted.

Gordon R Sams
Sybase Omni Engineering

lritter@CreativeSolutions.com wrote:

> We are in the process of converting a critical system from ASE 11.9.2.3 on
> Win NT 4 to ASE 11.9.2.3 on Win 2000 Server.
>
> Everything seems to be functioning ok EXCEPT I'm not able to use CIS to
> connect to a remote ASE 11.9.2.3 database.
>
> I am able to logon to the local server and run SQL Advantage logging in to
> the remote server.
>
> sp_configure has been run to turn cis on.
>
> sp_addserver has been run to establish both local and remote servers.
>
> sp_addexternlogin has been run to establish the login (same on both
> servers)
>
> server has been restarted several times.
>
> when logged in via Sql Advantage using the identified login,
>
> connect to remote_server_name returns:
>
> Server Message: Number 10331, Severity 14
> Server 'DEXSYB01', Line 1:
> CONNECT permission denied, database master, owner dbo
>
> Thanks!
>
> Linda