Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

A lot of connections and permission denied

6 posts in General Discussion Last posting was on 2005-11-21 15:07:49.0Z
Henrik Glimberg Posted on 2005-11-14 15:37:46.0Z
From: Henrik Glimberg <henrik.glimberg@tietoenator.com>
Newsgroups: sybase.public.workspace.general
Subject: A lot of connections and permission denied
Message-ID: <MPG.1de2cc01b1526683989680@forums.sybase.com>
Organization: TietoEnator
MIME-Version: 1.0
Content-Type: text/plain; charset="iso-8859-15"
Content-Transfer-Encoding: quoted-printable
User-Agent: MicroPlanet-Gravity/2.70.2067
NNTP-Posting-Host: alv-global.enator.se
X-Original-NNTP-Posting-Host: alv-global.enator.se
Date: 14 Nov 2005 07:37:46 -0800
X-Trace: forums-1-dub 1131982666 193.15.240.60 (14 Nov 2005 07:37:46 -0800)
X-Original-Trace: 14 Nov 2005 07:37:46 -0800, alv-global.enator.se
Lines: 17
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.workspace.general:23
Article PK: 1087753

I just installed WS eval 1.0.

The first thing I tried out was the database development part - but I
imediately run in to some problems.

1 - I noticed that when creating a connection to my server (ASE 12.5.3
on HP-UX) the tool actually created 3 connections.... kind of a
waste...., and the same happened when creating a second connection to
the same server....

2 - when trying to create a proc or edit a proc the tool tells me that
my dbo user doesn?t have permission to do that ! - and that is terribly
wrong....

After that I didn?t get much done...

/Henrik


Samir Nigam Posted on 2005-11-15 21:11:31.0Z
From: "Samir Nigam" <Samir_N.O.S.P.A.M_Nigam@sybase.com>
Newsgroups: sybase.public.workspace.general
References: <MPG.1de2cc01b1526683989680@forums.sybase.com>
Subject: Re: A lot of connections and permission denied
Lines: 35
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
NNTP-Posting-Host: snigamxp.sybase.com
X-Original-NNTP-Posting-Host: snigamxp.sybase.com
Message-ID: <437a4f03$1@forums-1-dub>
Date: 15 Nov 2005 13:11:31 -0800
X-Trace: forums-1-dub 1132089091 10.22.85.194 (15 Nov 2005 13:11:31 -0800)
X-Original-Trace: 15 Nov 2005 13:11:31 -0800, snigamxp.sybase.com
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.workspace.general:25
Article PK: 1087761

Henrik,

Please see <SN> below..

"Henrik Glimberg" <henrik.glimberg@tietoenator.com> wrote in message
news:MPG.1de2cc01b1526683989680@forums.sybase.com...
I just installed WS eval 1.0.

The first thing I tried out was the database development part - but I
imediately run in to some problems.

1 - I noticed that when creating a connection to my server (ASE 12.5.3
on HP-UX) the tool actually created 3 connections.... kind of a
waste...., and the same happened when creating a second connection to
the same server....

<SN> Three connections are needed at this point for three internal
components. This is a known issue and we are planning to resolve it. At this
time though, it is not targeted for the next release due to some technical
reasons. However, in the next release we are adding support for mutiple
databases from the same connection profile which would preserve database
server's user connections. That would address your concern on the
connections created to some extent.<SN>

2 - when trying to create a proc or edit a proc the tool tells me that
my dbo user doesn?t have permission to do that ! - and that is terribly
wrong....

<SN> This may be some bug. Please send me some more information to reproduce
this problem and will take it from there. <SN>

Thanks,
Samir


Henrik Glimberg Posted on 2005-11-18 08:23:49.0Z
From: Henrik Glimberg <henrik.glimberg@tietoenator.com>
Newsgroups: sybase.public.workspace.general
Subject: Re: A lot of connections and permission denied
Message-ID: <MPG.1de7ac30139e7a78989681@forums.sybase.com>
References: <MPG.1de2cc01b1526683989680@forums.sybase.com> <437a4f03$1@forums-1-dub>
Organization: TietoEnator
MIME-Version: 1.0
Content-Type: text/plain; charset="iso-8859-15"
Content-Transfer-Encoding: quoted-printable
User-Agent: MicroPlanet-Gravity/2.70.2067
X-Original-NNTP-Posting-Host: alv-global.enator.se
X-Original-Trace: 18 Nov 2005 00:17:06 -0800, alv-global.enator.se
Lines: 29
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 18 Nov 2005 00:17:07 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 18 Nov 2005 00:23:49 -0800
X-Trace: forums-1-dub 1132302229 10.22.108.75 (18 Nov 2005 00:23:49 -0800)
X-Original-Trace: 18 Nov 2005 00:23:49 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.workspace.general:29
Article PK: 1087764


> 2 - when trying to create a proc or edit a proc the tool tells me that
> my dbo user doesn?t have permission to do that ! - and that is terribly
> wrong....
>
> <SN> This may be some bug. Please send me some more information to reproduce
> this problem and will take it from there. <SN>
>

Ok - when I am trying to save a proc I get the following error message:

-----------------------
Save could not be completed
Reason
Save to db fail: java.sql.SQLException : User "dbo" does not have save
permission
-----------------------

This is not true....

And there is even a workaround in WS 1.0 - since if I just highlight a
create or drop procedure statement and executes it it works fine....


I don?t have a user in the database where i try to do the save - instead
my login is aliased to the dbo user.

/Henrik


Mike Crocker Posted on 2005-11-18 22:31:58.0Z
From: "Mike Crocker" <crocker@sybase.com>
Newsgroups: sybase.public.workspace.general
References: <MPG.1de2cc01b1526683989680@forums.sybase.com> <437a4f03$1@forums-1-dub> <MPG.1de7ac30139e7a78989681@forums.sybase.com>
Subject: Re: A lot of connections and permission denied
Lines: 53
Organization: Sybase, Inc.
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
NNTP-Posting-Host: crockerw2k4.sybase.com
X-Original-NNTP-Posting-Host: crockerw2k4.sybase.com
Message-ID: <437e565e$1@forums-1-dub>
Date: 18 Nov 2005 14:31:58 -0800
X-Trace: forums-1-dub 1132353118 10.24.112.180 (18 Nov 2005 14:31:58 -0800)
X-Original-Trace: 18 Nov 2005 14:31:58 -0800, crockerw2k4.sybase.com
X-Authenticated-User: workspace
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.workspace.general:33
Article PK: 1087767

Henrik,

The Release Bulletin outlined a work around for an HP-UX ASE connection
issue that was based on default charsets. Did you implement this?

CR # 400163

Description: Failures occur when connecting the Database Explorer to ASE on
HP-UX.

Workaround: Add the following two connection properties to the Connection
Profile:

Charset=iso_1Properties='user=<userid>;password=<pw>;Charset=iso_1;'

The user and password values are required and the syntax of Properties must
be maintained, as shown above, with semicolons and quotation marks.

thanks,
mike

"Henrik Glimberg" <henrik.glimberg@tietoenator.com> wrote in message
news:MPG.1de7ac30139e7a78989681@forums.sybase.com...
> 2 - when trying to create a proc or edit a proc the tool tells me that
> my dbo user doesn?t have permission to do that ! - and that is terribly
> wrong....
>
> <SN> This may be some bug. Please send me some more information to
reproduce
> this problem and will take it from there. <SN>
>

Ok - when I am trying to save a proc I get the following error message:

-----------------------
Save could not be completed
Reason
Save to db fail: java.sql.SQLException : User "dbo" does not have save
permission
-----------------------

This is not true....

And there is even a workaround in WS 1.0 - since if I just highlight a
create or drop procedure statement and executes it it works fine....


I don?t have a user in the database where i try to do the save - instead
my login is aliased to the dbo user.

/Henrik


Henrik Glimberg Posted on 2005-11-21 08:20:10.0Z
From: Henrik Glimberg <henrik.glimberg@tietoenator.com>
Newsgroups: sybase.public.workspace.general
Subject: Re: A lot of connections and permission denied
Message-ID: <MPG.1deb9fc56e752b8b989684@forums.sybase.com>
References: <MPG.1de2cc01b1526683989680@forums.sybase.com> <437a4f03$1@forums-1-dub> <MPG.1de7ac30139e7a78989681@forums.sybase.com> <437e565e$1@forums-1-dub>
Organization: TietoEnator
MIME-Version: 1.0
Content-Type: text/plain; charset="iso-8859-15"
Content-Transfer-Encoding: quoted-printable
User-Agent: MicroPlanet-Gravity/2.70.2067
NNTP-Posting-Host: alv-global.enator.se
X-Original-NNTP-Posting-Host: alv-global.enator.se
Date: 21 Nov 2005 00:20:10 -0800
X-Trace: forums-1-dub 1132561210 193.15.240.60 (21 Nov 2005 00:20:10 -0800)
X-Original-Trace: 21 Nov 2005 00:20:10 -0800, alv-global.enator.se
Lines: 8
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.workspace.general:34
Article PK: 1087763

I hadn?t seen that one before - but after trying it out - I can only
report that it didn?t help me. - but it did seem proming since we are
actually running our ASE on HP-UX on Itanium.
/Henrik

In article <437e565e$1@forums-1-dub>, crocker@sybase.com says...

> 400163
>


Mike Crocker Posted on 2005-11-21 15:07:49.0Z
From: "Mike Crocker" <crocker@sybase.com>
Newsgroups: sybase.public.workspace.general
References: <MPG.1de2cc01b1526683989680@forums.sybase.com> <437a4f03$1@forums-1-dub> <MPG.1de7ac30139e7a78989681@forums.sybase.com> <437e565e$1@forums-1-dub> <MPG.1deb9fc56e752b8b989684@forums.sybase.com>
Subject: Re: A lot of connections and permission denied
Lines: 36
Organization: Sybase, Inc.
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Original-NNTP-Posting-Host: crockerw2k4.sybase.com
Message-ID: <4381e11d$1@forums-2-dub>
X-Original-Trace: 21 Nov 2005 07:00:45 -0800, crockerw2k4.sybase.com
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 21 Nov 2005 07:00:46 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 21 Nov 2005 07:07:49 -0800
X-Trace: forums-1-dub 1132585669 10.22.108.75 (21 Nov 2005 07:07:49 -0800)
X-Original-Trace: 21 Nov 2005 07:07:49 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.workspace.general:36
Article PK: 1087935

Henrik,

We were able to reproduce this problem. Here's the email from the engineer
(between email markers):

<email>
I was able to reproduce the problem. This is a generic bug not specific to
HP/UX in DMP during permission checking, the query we issued is incorrect
that it missed the 'alias' scenario. I'll open a CR for this problem.
For now, the workaround is to use 'sa' in the connection profile (since the
original login Henrik used aliased to dbo), or create a user with proper
role to associate the login.

</email>

The first workaround means that the user connection property in the
connection profile needs to be sa. Something like this:

Properties='user=sa;password=<pw>;Charset=iso_1;'

Let us know if one of these workarounds does the trick.

thanks, mike

"Henrik Glimberg" <henrik.glimberg@tietoenator.com> wrote in message
news:MPG.1deb9fc56e752b8b989684@forums.sybase.com...
I hadn?t seen that one before - but after trying it out - I can only
report that it didn?t help me. - but it did seem proming since we are
actually running our ASE on HP-UX on Itanium.
/Henrik

In article <437e565e$1@forums-1-dub>, crocker@sybase.com says...

> 400163
>