Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

need help ..Error During Syncr. with version 7.0

8 posts in ,  General DiscussionGeneral Discussion General Discussion Last posting was on 2003-07-23 14:36:29.0Z
Matani Posted on 2003-07-15 13:02:12.0Z
Reply-To: "Matani" <S.Matani@ads-tec.de>
From: "Matani" <saleh@matani.net>
Subject: need help ..Error During Syncr. with version 7.0
Date: Tue, 15 Jul 2003 15:02:12 +0200
Lines: 52
Organization: sudent
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2600.0000
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2600.0000
Message-ID: <OPg9xXtSDHA.298@forums-2-dub>
Newsgroups: ianywhere.public.general,sybase.public.ase.general,sybase.public.sqlanywhere.general
NNTP-Posting-Host: gabriel.le1.ads-tec.de 62.153.239.43
Path: forums-1-dub!forums-master.sybase.com!forums-2-dub.sybase.com
Xref: forums-1-dub ianywhere.public.general:1331 sybase.public.ase.general:11569 sybase.public.sqlanywhere.general:80909
Article PK: 3566

any body can tell me why i get error when syncr. 2 simple tables!
it was working with the Version 8 but i use to work with the version 7 !
with version 7 i am getting this error.
----------------------------------------------------------------------------
-------
I. 07/15 14:44:23. <thread 1.5>: ml_scripts_modified last modified at:
2003-07-14 18:06:15.959000
I. 07/15 14:44:23. <thread 1.5>: Synchronization request from: ml_user
(version: default)
I. 07/15 14:44:23. [ml_user]: ODBC isolation set to: Read Committed
I. 07/15 14:44:23. [ml_user]: begin_connection <connection> (undefined)
I. 07/15 14:44:23. [ml_user]: COMMIT
I. 07/15 14:44:23. [ml_user]: begin_synchronization <connection> (undefined)
I. 07/15 14:44:23. [ml_user]: begin_synchronization cust (undefined)
I. 07/15 14:44:23. [ml_user]: COMMIT
I. 07/15 14:44:23. [ml_user]: begin_upload <connection> (undefined)
I. 07/15 14:44:23. [ml_user]: begin_upload cust (undefined)
I. 07/15 14:44:23. [ml_user]: begin_upload_rows cust (undefined)
I. 07/15 14:44:23. [ml_user]: Inserted row:
I. 07/15 14:44:23. [ml_user]: 10000001
I. 07/15 14:44:23. [ml_user]: newrecord
I. 07/15 14:44:23. [ml_user]: upload_cursor cust (open for read and write):
insert into cust(cust_id, cust_name) values ( ? , ? )
E. 07/15 14:44:23. [ml_user]: Error: Expecting 2 columns in cursor, but
found 0
E. 07/15 14:44:23. [ml_user]: Error: Unable to open upload_cursor
I. 07/15 14:44:23. [ml_user]: Warning: The handle_error script is not
defined. The default action code (3000) will decide error behaviour.
I. 07/15 14:44:23. [ml_user]: Parameters for handle_error:
sqlcode = 0
message = Expecting 2 columns in cursor, but found 0
user name = ml_user
table name = cust
script id = 2
E. 07/15 14:44:23. [ml_user]: Error: Unable to insert into table "cust"
using upload_cursor
I. 07/15 14:44:23. [ml_user]: ROLLBACK
I. 07/15 14:44:23. [ml_user]: end_connection <connection> (undefined)
I. 07/15 14:44:23. [ml_user]: COMMIT
I. 07/15 14:44:23. [ml_user]: Disconnected from consolidated database
I. 07/15 14:44:23. [ml_user]: Synchronization failed
----------------------------------------------------------------------------
------

thanks
Matani


Breck Carter [TeamSybase] Posted on 2003-07-15 13:53:02.0Z
From: "Breck Carter [TeamSybase]" <NOSPAM__bcarter@risingroad.com>
Subject: Re: need help ..Error During Syncr. with version 7.0
Date: Tue, 15 Jul 2003 09:53:02 -0400
Organization: RisingRoad Professional Services
Reply-To: NOSPAM__bcarter@risingroad.com
Message-ID: <l518hvgojn5i5mgg3fuh9cc7jfug19ngqf@4ax.com>
References: <OPg9xXtSDHA.298@forums-2-dub>
X-Newsreader: Forte Agent 1.8/32.548
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: ianywhere.public.general
NNTP-Posting-Host: bcarter.sentex.ca 64.7.134.118
Lines: 78
Path: forums-1-dub!forums-master.sybase.com!forums-2-dub.sybase.com
Xref: forums-1-dub ianywhere.public.general:1332
Article PK: 3567

You have written an old-style upload_cursor script with code that
looks like it belongs in an new-style upload_insert.

Suggestion: Since Version 7 doesn't have upload_insert, you're stuck
with upload_cursor, which must be coded as a SELECT which (AFAIK) is
used for a cursor which is opened, fetched and closed for every
uploaded insert, update and delete (sigh):

SELECT <every column>
WHERE <primary key column 1> = ?
AND <primary key column 2> = ?
AND ...

Breck

On Tue, 15 Jul 2003 15:02:12 +0200, "Matani" <saleh@matani.net> wrote:

>any body can tell me why i get error when syncr. 2 simple tables!
>it was working with the Version 8 but i use to work with the version 7 !
>with version 7 i am getting this error.
>----------------------------------------------------------------------------
>-------
>I. 07/15 14:44:23. <thread 1.5>: ml_scripts_modified last modified at:
>2003-07-14 18:06:15.959000
>I. 07/15 14:44:23. <thread 1.5>: Synchronization request from: ml_user
>(version: default)
>I. 07/15 14:44:23. [ml_user]: ODBC isolation set to: Read Committed
>I. 07/15 14:44:23. [ml_user]: begin_connection <connection> (undefined)
>I. 07/15 14:44:23. [ml_user]: COMMIT
>I. 07/15 14:44:23. [ml_user]: begin_synchronization <connection> (undefined)
>I. 07/15 14:44:23. [ml_user]: begin_synchronization cust (undefined)
>I. 07/15 14:44:23. [ml_user]: COMMIT
>I. 07/15 14:44:23. [ml_user]: begin_upload <connection> (undefined)
>I. 07/15 14:44:23. [ml_user]: begin_upload cust (undefined)
>I. 07/15 14:44:23. [ml_user]: begin_upload_rows cust (undefined)
>I. 07/15 14:44:23. [ml_user]: Inserted row:
>I. 07/15 14:44:23. [ml_user]: 10000001
>I. 07/15 14:44:23. [ml_user]: newrecord
>I. 07/15 14:44:23. [ml_user]: upload_cursor cust (open for read and write):
> insert into cust(cust_id, cust_name) values ( ? , ? )
>E. 07/15 14:44:23. [ml_user]: Error: Expecting 2 columns in cursor, but
>found 0
>E. 07/15 14:44:23. [ml_user]: Error: Unable to open upload_cursor
>I. 07/15 14:44:23. [ml_user]: Warning: The handle_error script is not
>defined. The default action code (3000) will decide error behaviour.
>I. 07/15 14:44:23. [ml_user]: Parameters for handle_error:
> sqlcode = 0
> message = Expecting 2 columns in cursor, but found 0
> user name = ml_user
> table name = cust
> script id = 2
>E. 07/15 14:44:23. [ml_user]: Error: Unable to insert into table "cust"
>using upload_cursor
>I. 07/15 14:44:23. [ml_user]: ROLLBACK
>I. 07/15 14:44:23. [ml_user]: end_connection <connection> (undefined)
>I. 07/15 14:44:23. [ml_user]: COMMIT
>I. 07/15 14:44:23. [ml_user]: Disconnected from consolidated database
>I. 07/15 14:44:23. [ml_user]: Synchronization failed
>----------------------------------------------------------------------------
>------
>
>thanks
>Matani
>
>
>
>
>

bcarter@risingroad.com
Mobile and Distributed Enterprise Database Applications
http://www.risingroad.com


Matani Posted on 2003-07-15 14:06:00.0Z
Reply-To: "Matani" <S.Matani@ads-tec.de>
From: "Matani" <saleh@matani.net>
References: <OPg9xXtSDHA.298@forums-2-dub> <l518hvgojn5i5mgg3fuh9cc7jfug19ngqf@4ax.com>
Subject: Re: need help ..Error During Syncr. with version 7.0
Date: Tue, 15 Jul 2003 16:06:00 +0200
Lines: 85
Organization: sudent
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2600.0000
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2600.0000
Message-ID: <uSpqTttSDHA.298@forums-2-dub>
Newsgroups: ianywhere.public.general
NNTP-Posting-Host: gabriel.le1.ads-tec.de 62.153.239.43
Path: forums-1-dub!forums-master.sybase.com!forums-2-dub.sybase.com
Xref: forums-1-dub ianywhere.public.general:1334
Article PK: 3568

Since Version 8 can "insert into" be used !
thank you , i will try

"Breck Carter [TeamSybase]" <NOSPAM__bcarter@risingroad.com> wrote in
message news:l518hvgojn5i5mgg3fuh9cc7jfug19ngqf@4ax.com...
> You have written an old-style upload_cursor script with code that
> looks like it belongs in an new-style upload_insert.
>
> Suggestion: Since Version 7 doesn't have upload_insert, you're stuck
> with upload_cursor, which must be coded as a SELECT which (AFAIK) is
> used for a cursor which is opened, fetched and closed for every
> uploaded insert, update and delete (sigh):
>
> SELECT <every column>
> WHERE <primary key column 1> = ?
> AND <primary key column 2> = ?
> AND ...
>
> Breck
>
> On Tue, 15 Jul 2003 15:02:12 +0200, "Matani" <saleh@matani.net> wrote:
>
> >any body can tell me why i get error when syncr. 2 simple tables!
> >it was working with the Version 8 but i use to work with the version 7 !
> >with version 7 i am getting this error.
>
>---------------------------------------------------------------------------
-
> >-------
> >I. 07/15 14:44:23. <thread 1.5>: ml_scripts_modified last modified at:
> >2003-07-14 18:06:15.959000
> >I. 07/15 14:44:23. <thread 1.5>: Synchronization request from: ml_user
> >(version: default)
> >I. 07/15 14:44:23. [ml_user]: ODBC isolation set to: Read Committed
> >I. 07/15 14:44:23. [ml_user]: begin_connection <connection> (undefined)
> >I. 07/15 14:44:23. [ml_user]: COMMIT
> >I. 07/15 14:44:23. [ml_user]: begin_synchronization <connection>
(undefined)
> >I. 07/15 14:44:23. [ml_user]: begin_synchronization cust (undefined)
> >I. 07/15 14:44:23. [ml_user]: COMMIT
> >I. 07/15 14:44:23. [ml_user]: begin_upload <connection> (undefined)
> >I. 07/15 14:44:23. [ml_user]: begin_upload cust (undefined)
> >I. 07/15 14:44:23. [ml_user]: begin_upload_rows cust (undefined)
> >I. 07/15 14:44:23. [ml_user]: Inserted row:
> >I. 07/15 14:44:23. [ml_user]: 10000001
> >I. 07/15 14:44:23. [ml_user]: newrecord
> >I. 07/15 14:44:23. [ml_user]: upload_cursor cust (open for read and
write):
> > insert into cust(cust_id, cust_name) values ( ? , ? )
> >E. 07/15 14:44:23. [ml_user]: Error: Expecting 2 columns in cursor, but
> >found 0
> >E. 07/15 14:44:23. [ml_user]: Error: Unable to open upload_cursor
> >I. 07/15 14:44:23. [ml_user]: Warning: The handle_error script is not
> >defined. The default action code (3000) will decide error behaviour.
> >I. 07/15 14:44:23. [ml_user]: Parameters for handle_error:
> > sqlcode = 0
> > message = Expecting 2 columns in cursor, but found 0
> > user name = ml_user
> > table name = cust
> > script id = 2
> >E. 07/15 14:44:23. [ml_user]: Error: Unable to insert into table "cust"
> >using upload_cursor
> >I. 07/15 14:44:23. [ml_user]: ROLLBACK
> >I. 07/15 14:44:23. [ml_user]: end_connection <connection> (undefined)
> >I. 07/15 14:44:23. [ml_user]: COMMIT
> >I. 07/15 14:44:23. [ml_user]: Disconnected from consolidated database
> >I. 07/15 14:44:23. [ml_user]: Synchronization failed
>
>---------------------------------------------------------------------------
-
> >------
> >
> >thanks
> >Matani
> >
> >
> >
> >
> >
>
> bcarter@risingroad.com
> Mobile and Distributed Enterprise Database Applications
> http://www.risingroad.com


Breck Carter [TeamSybase] Posted on 2003-07-15 14:26:08.0Z
From: "Breck Carter [TeamSybase]" <NOSPAM__bcarter@risingroad.com>
Subject: Re: need help ..Error During Syncr. with version 7.0
Date: Tue, 15 Jul 2003 10:26:08 -0400
Organization: RisingRoad Professional Services
Reply-To: NOSPAM__bcarter@risingroad.com
Message-ID: <1n38hv8ao21g0jmi6t54b4ck7s86bb8vs9@4ax.com>
References: <OPg9xXtSDHA.298@forums-2-dub> <l518hvgojn5i5mgg3fuh9cc7jfug19ngqf@4ax.com> <uSpqTttSDHA.298@forums-2-dub>
X-Newsreader: Forte Agent 1.8/32.548
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: ianywhere.public.general
NNTP-Posting-Host: bcarter.sentex.ca 64.7.134.118
Lines: 96
Path: forums-1-dub!forums-master.sybase.com!forums-2-dub.sybase.com
Xref: forums-1-dub ianywhere.public.general:1335
Article PK: 3572

INSERT INTO cannot be used in an upload_cursor, only upload_insert.
The upload_insert is new for V8.

Breck

On Tue, 15 Jul 2003 16:06:00 +0200, "Matani" <saleh@matani.net> wrote:

>Since Version 8 can "insert into" be used !
>thank you , i will try
>
>"Breck Carter [TeamSybase]" <NOSPAM__bcarter@risingroad.com> wrote in
>message news:l518hvgojn5i5mgg3fuh9cc7jfug19ngqf@4ax.com...
>> You have written an old-style upload_cursor script with code that
>> looks like it belongs in an new-style upload_insert.
>>
>> Suggestion: Since Version 7 doesn't have upload_insert, you're stuck
>> with upload_cursor, which must be coded as a SELECT which (AFAIK) is
>> used for a cursor which is opened, fetched and closed for every
>> uploaded insert, update and delete (sigh):
>>
>> SELECT <every column>
>> WHERE <primary key column 1> = ?
>> AND <primary key column 2> = ?
>> AND ...
>>
>> Breck
>>
>> On Tue, 15 Jul 2003 15:02:12 +0200, "Matani" <saleh@matani.net> wrote:
>>
>> >any body can tell me why i get error when syncr. 2 simple tables!
>> >it was working with the Version 8 but i use to work with the version 7 !
>> >with version 7 i am getting this error.
>>
>>---------------------------------------------------------------------------
>-
>> >-------
>> >I. 07/15 14:44:23. <thread 1.5>: ml_scripts_modified last modified at:
>> >2003-07-14 18:06:15.959000
>> >I. 07/15 14:44:23. <thread 1.5>: Synchronization request from: ml_user
>> >(version: default)
>> >I. 07/15 14:44:23. [ml_user]: ODBC isolation set to: Read Committed
>> >I. 07/15 14:44:23. [ml_user]: begin_connection <connection> (undefined)
>> >I. 07/15 14:44:23. [ml_user]: COMMIT
>> >I. 07/15 14:44:23. [ml_user]: begin_synchronization <connection>
>(undefined)
>> >I. 07/15 14:44:23. [ml_user]: begin_synchronization cust (undefined)
>> >I. 07/15 14:44:23. [ml_user]: COMMIT
>> >I. 07/15 14:44:23. [ml_user]: begin_upload <connection> (undefined)
>> >I. 07/15 14:44:23. [ml_user]: begin_upload cust (undefined)
>> >I. 07/15 14:44:23. [ml_user]: begin_upload_rows cust (undefined)
>> >I. 07/15 14:44:23. [ml_user]: Inserted row:
>> >I. 07/15 14:44:23. [ml_user]: 10000001
>> >I. 07/15 14:44:23. [ml_user]: newrecord
>> >I. 07/15 14:44:23. [ml_user]: upload_cursor cust (open for read and
>write):
>> > insert into cust(cust_id, cust_name) values ( ? , ? )
>> >E. 07/15 14:44:23. [ml_user]: Error: Expecting 2 columns in cursor, but
>> >found 0
>> >E. 07/15 14:44:23. [ml_user]: Error: Unable to open upload_cursor
>> >I. 07/15 14:44:23. [ml_user]: Warning: The handle_error script is not
>> >defined. The default action code (3000) will decide error behaviour.
>> >I. 07/15 14:44:23. [ml_user]: Parameters for handle_error:
>> > sqlcode = 0
>> > message = Expecting 2 columns in cursor, but found 0
>> > user name = ml_user
>> > table name = cust
>> > script id = 2
>> >E. 07/15 14:44:23. [ml_user]: Error: Unable to insert into table "cust"
>> >using upload_cursor
>> >I. 07/15 14:44:23. [ml_user]: ROLLBACK
>> >I. 07/15 14:44:23. [ml_user]: end_connection <connection> (undefined)
>> >I. 07/15 14:44:23. [ml_user]: COMMIT
>> >I. 07/15 14:44:23. [ml_user]: Disconnected from consolidated database
>> >I. 07/15 14:44:23. [ml_user]: Synchronization failed
>>
>>---------------------------------------------------------------------------
>-
>> >------
>> >
>> >thanks
>> >Matani
>> >
>> >
>> >
>> >
>> >
>>
>> bcarter@risingroad.com
>> Mobile and Distributed Enterprise Database Applications
>> http://www.risingroad.com
>

bcarter@risingroad.com
Mobile and Distributed Enterprise Database Applications
http://www.risingroad.com


Matani Posted on 2003-07-15 14:56:10.0Z
Reply-To: "Matani" <S.Matani@ads-tec.de>
From: "Matani" <saleh@matani.net>
References: <OPg9xXtSDHA.298@forums-2-dub> <l518hvgojn5i5mgg3fuh9cc7jfug19ngqf@4ax.com> <uSpqTttSDHA.298@forums-2-dub> <1n38hv8ao21g0jmi6t54b4ck7s86bb8vs9@4ax.com>
Subject: Re: need help ..Error During Syncr. with version 7.0
Date: Tue, 15 Jul 2003 16:56:10 +0200
Lines: 111
Organization: sudent
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2600.0000
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2600.0000
Message-ID: <eLifWJuSDHA.342@forums-2-dub>
Newsgroups: ianywhere.public.general
NNTP-Posting-Host: gabriel.le1.ads-tec.de 62.153.239.43
Path: forums-1-dub!forums-master.sybase.com!forums-2-dub.sybase.com
Xref: forums-1-dub ianywhere.public.general:1338
Article PK: 3574

thanks :)

"Breck Carter [TeamSybase]" <NOSPAM__bcarter@risingroad.com> wrote in
message news:1n38hv8ao21g0jmi6t54b4ck7s86bb8vs9@4ax.com...
> INSERT INTO cannot be used in an upload_cursor, only upload_insert.
> The upload_insert is new for V8.
>
> Breck
>
> On Tue, 15 Jul 2003 16:06:00 +0200, "Matani" <saleh@matani.net> wrote:
>
> >Since Version 8 can "insert into" be used !
> >thank you , i will try
> >
> >"Breck Carter [TeamSybase]" <NOSPAM__bcarter@risingroad.com> wrote in
> >message news:l518hvgojn5i5mgg3fuh9cc7jfug19ngqf@4ax.com...
> >> You have written an old-style upload_cursor script with code that
> >> looks like it belongs in an new-style upload_insert.
> >>
> >> Suggestion: Since Version 7 doesn't have upload_insert, you're stuck
> >> with upload_cursor, which must be coded as a SELECT which (AFAIK) is
> >> used for a cursor which is opened, fetched and closed for every
> >> uploaded insert, update and delete (sigh):
> >>
> >> SELECT <every column>
> >> WHERE <primary key column 1> = ?
> >> AND <primary key column 2> = ?
> >> AND ...
> >>
> >> Breck
> >>
> >> On Tue, 15 Jul 2003 15:02:12 +0200, "Matani" <saleh@matani.net> wrote:
> >>
> >> >any body can tell me why i get error when syncr. 2 simple tables!
> >> >it was working with the Version 8 but i use to work with the version 7
!
> >> >with version 7 i am getting this error.
> >>
>
>>--------------------------------------------------------------------------
-
> >-
> >> >-------
> >> >I. 07/15 14:44:23. <thread 1.5>: ml_scripts_modified last modified at:
> >> >2003-07-14 18:06:15.959000
> >> >I. 07/15 14:44:23. <thread 1.5>: Synchronization request from: ml_user
> >> >(version: default)
> >> >I. 07/15 14:44:23. [ml_user]: ODBC isolation set to: Read Committed
> >> >I. 07/15 14:44:23. [ml_user]: begin_connection <connection>
(undefined)
> >> >I. 07/15 14:44:23. [ml_user]: COMMIT
> >> >I. 07/15 14:44:23. [ml_user]: begin_synchronization <connection>
> >(undefined)
> >> >I. 07/15 14:44:23. [ml_user]: begin_synchronization cust (undefined)
> >> >I. 07/15 14:44:23. [ml_user]: COMMIT
> >> >I. 07/15 14:44:23. [ml_user]: begin_upload <connection> (undefined)
> >> >I. 07/15 14:44:23. [ml_user]: begin_upload cust (undefined)
> >> >I. 07/15 14:44:23. [ml_user]: begin_upload_rows cust (undefined)
> >> >I. 07/15 14:44:23. [ml_user]: Inserted row:
> >> >I. 07/15 14:44:23. [ml_user]: 10000001
> >> >I. 07/15 14:44:23. [ml_user]: newrecord
> >> >I. 07/15 14:44:23. [ml_user]: upload_cursor cust (open for read and
> >write):
> >> > insert into cust(cust_id, cust_name) values ( ? ,
? )
> >> >E. 07/15 14:44:23. [ml_user]: Error: Expecting 2 columns in cursor,
but
> >> >found 0
> >> >E. 07/15 14:44:23. [ml_user]: Error: Unable to open upload_cursor
> >> >I. 07/15 14:44:23. [ml_user]: Warning: The handle_error script is not
> >> >defined. The default action code (3000) will decide error behaviour.
> >> >I. 07/15 14:44:23. [ml_user]: Parameters for handle_error:
> >> > sqlcode = 0
> >> > message = Expecting 2 columns in cursor, but found
0
> >> > user name = ml_user
> >> > table name = cust
> >> > script id = 2
> >> >E. 07/15 14:44:23. [ml_user]: Error: Unable to insert into table
"cust"
> >> >using upload_cursor
> >> >I. 07/15 14:44:23. [ml_user]: ROLLBACK
> >> >I. 07/15 14:44:23. [ml_user]: end_connection <connection> (undefined)
> >> >I. 07/15 14:44:23. [ml_user]: COMMIT
> >> >I. 07/15 14:44:23. [ml_user]: Disconnected from consolidated database
> >> >I. 07/15 14:44:23. [ml_user]: Synchronization failed
> >>
>
>>--------------------------------------------------------------------------
-
> >-
> >> >------
> >> >
> >> >thanks
> >> >Matani
> >> >
> >> >
> >> >
> >> >
> >> >
> >>
> >> bcarter@risingroad.com
> >> Mobile and Distributed Enterprise Database Applications
> >> http://www.risingroad.com
> >
>
> bcarter@risingroad.com
> Mobile and Distributed Enterprise Database Applications
> http://www.risingroad.com


David Fishburn Posted on 2003-07-17 13:26:19.0Z
Subject: Re: need help ..Error During Syncr. with version 7.0
From: David Fishburn <fishburn_spam_off@ianywhere.com>
References: <OPg9xXtSDHA.298@forums-2-dub>
Organization: iAnywhere Solutions
Message-ID: <Xns93BB5E95313A9fishburnsybasecom@10.22.241.106>
User-Agent: Xnews/06.02.16
Newsgroups: ianywhere.public.general,sybase.public.ase.general,sybase.public.sqlanywhere.general
Date: Thu, 17 Jul 2003 06:26:19 -0700
NNTP-Posting-Host: fishburn-t30.sybase.com 172.31.141.114
Lines: 35
Path: forums-1-dub!forums-master.sybase.com!forums-2-dub.sybase.com
Xref: forums-1-dub ianywhere.public.general:1368 sybase.public.ase.general:11638 sybase.public.sqlanywhere.general:80996
Article PK: 3603


"Matani" <saleh@matani.net> wrote in news:OPg9xXtSDHA.298@forums-2-dub:

> I. 07/15 14:44:23. [ml_user]: upload_cursor cust (open for read and
> write):
> insert into cust(cust_id, cust_name) values ( ? , ?
> )
> E. 07/15 14:44:23. [ml_user]: Error: Expecting 2 columns in cursor,
> but found 0

Repliation and Synchronization Guide
PART 2. MobiLink Synchronization
CHAPTER 8. Reference Scripts
upload_cursor cursor script

Looking at this section of the 7.0.4 Help file (which I would highly
recommned you move to if you are staying on version 7), you need to
write this even in this format:

select cust_id, cust_name
from cust
where cust_id = ?

I assume only the cust_id column is part of the PK, otherwise it would
be like this:

select cust_id, cust_name
from cust
where cust_id = ?
and cust_name = ?
--
David Fishburn
NEW - Certified ASA Developer Version 8
Sybase - iAnywhere Solutions
Professional Services
Please only post to the newsgroup
Please ALWAYS include version and MORE importantly BUILD number with EACH
post (dbeng8 -v).

EBFs and Maintenance Releases
http://downloads.sybase.com/swx/sdmain.stm

Developer Community / Whitepapers
http://www.ianywhere.com/developer

CaseXpress - to report bugs
http://casexpress.sybase.com


Matani Posted on 2003-07-18 09:43:02.0Z
Reply-To: "Matani" <S.Matani@ads-tec.de>
From: "Matani" <saleh@matani.net>
References: <OPg9xXtSDHA.298@forums-2-dub> <Xns93BB5E95313A9fishburnsybasecom@10.22.241.106>
Subject: Re: need help ..Error During Syncr. with version 7.0
Date: Fri, 18 Jul 2003 11:43:02 +0200
Lines: 63
Organization: sudent
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2600.0000
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2600.0000
Message-ID: <O5EnaIRTDHA.346@forums-2-dub>
Newsgroups: ianywhere.public.general,sybase.public.ase.general,sybase.public.sqlanywhere.general
NNTP-Posting-Host: gabriel.le1.ads-tec.de 62.153.239.43
Path: forums-1-dub!forums-master.sybase.com!forums-2-dub.sybase.com
Xref: forums-1-dub ianywhere.public.general:1393 sybase.public.ase.general:11653 sybase.public.sqlanywhere.general:81049
Article PK: 3627

how to move to Version 7.0.4 ? do i need a new Licence , and where i can get
this Version to upgrade?
dose it matter if i keep my Database (*.db) at Version 7.0.0 ? because a
siemens Software working on it (Wincc 5.5) and this Software is just 7.0.0
compatible!

thanks for supporting
Matani.

"David Fishburn" <fishburn_spam_off@ianywhere.com> wrote in message
news:Xns93BB5E95313A9fishburnsybasecom@10.22.241.106...
> "Matani" <saleh@matani.net> wrote in news:OPg9xXtSDHA.298@forums-2-dub:
>
> > I. 07/15 14:44:23. [ml_user]: upload_cursor cust (open for read and
> > write):
> > insert into cust(cust_id, cust_name) values ( ? , ?
> > )
> > E. 07/15 14:44:23. [ml_user]: Error: Expecting 2 columns in cursor,
> > but found 0
>
>
> Repliation and Synchronization Guide
> PART 2. MobiLink Synchronization
> CHAPTER 8. Reference Scripts
> upload_cursor cursor script
>
> Looking at this section of the 7.0.4 Help file (which I would highly
> recommned you move to if you are staying on version 7), you need to
> write this even in this format:
>
> select cust_id, cust_name
> from cust
> where cust_id = ?
>
> I assume only the cust_id column is part of the PK, otherwise it would
> be like this:
>
> select cust_id, cust_name
> from cust
> where cust_id = ?
> and cust_name = ?
> --
> David Fishburn
> NEW - Certified ASA Developer Version 8
> Sybase - iAnywhere Solutions
> Professional Services
> Please only post to the newsgroup
> Please ALWAYS include version and MORE importantly BUILD number with EACH
> post (dbeng8 -v).
>
> EBFs and Maintenance Releases
> http://downloads.sybase.com/swx/sdmain.stm
>
> Developer Community / Whitepapers
> http://www.ianywhere.com/developer
>
> CaseXpress - to report bugs
> http://casexpress.sybase.com
>
>


David Fishburn Posted on 2003-07-23 14:36:29.0Z
Subject: Re: need help ..Error During Syncr. with version 7.0
From: David Fishburn <fishburn_spam_off@ianywhere.com>
References: <OPg9xXtSDHA.298@forums-2-dub> <Xns93BB5E95313A9fishburnsybasecom@10.22.241.106> <O5EnaIRTDHA.346@forums-2-dub>
Organization: iAnywhere Solutions
Message-ID: <Xns93C16A70B42F0fishburnsybasecom@10.22.241.106>
User-Agent: Xnews/06.02.16
Newsgroups: ianywhere.public.general,sybase.public.ase.general,sybase.public.sqlanywhere.general
Date: Wed, 23 Jul 2003 07:36:29 -0700
NNTP-Posting-Host: vpn-concord-089.sybase.com 158.159.8.89
Lines: 13
Path: forums-1-dub!forums-master.sybase.com!forums-2-dub.sybase.com
Xref: forums-1-dub ianywhere.public.general:1436 sybase.public.ase.general:11738 sybase.public.sqlanywhere.general:81203
Article PK: 3669


"Matani" <saleh@matani.net> wrote in news:O5EnaIRTDHA.346@forums-2-dub:

> how to move to Version 7.0.4 ? do i need a new Licence , and where i
> can get this Version to upgrade?
> dose it matter if i keep my Database (*.db) at Version 7.0.0 ? because
> a siemens Software working on it (Wincc 5.5) and this Software is just
> 7.0.0 compatible!

I answered this question on the MobiLink newsgroup. That is the best NG
for MobiLink related questions.

--
David Fishburn