Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

dbunload on ASA7

2 posts in General Discussion Last posting was on 2003-06-23 18:10:41.0Z
morales Posted on 2003-06-23 11:14:36.0Z
From: "morales" <morales@tehnicom.com>
Subject: dbunload on ASA7
Date: Mon, 23 Jun 2003 13:14:36 +0200
Lines: 19
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2600.0000
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2600.0000
Message-ID: <OxY6pmXODHA.362@forums-2-dub>
Newsgroups: ianywhere.public.general
NNTP-Posting-Host: grunf.tehnicom.com 62.193.140.1
Path: forums-1-dub!forums-master.sybase.com!forums-2-dub.sybase.com
Xref: forums-1-dub ianywhere.public.general:1229
Article PK: 3474

Unload utility works when good using Sybase Central, even TestEngine is
situated on another machine. But when I try to do this:

dbunload -c "uid=dba;pwd=sql;dbn=Test01;eng=TestEngine"

using command-line processor, it doesn't work in case of TestEngine is the
name of ASA service on another machine in network. Why?

The message is:
Adaptive Server Anywhere Unload Utility Version 7.0.4.2788
***** SQL error: Specified database not found
C:\>

And sure there is a database named test01 on server TestEngine, and the
proof for this is that the thing works good using unload utility. If I try
with ASA service on local machine, everything works fine, too.


Robert Waywell Posted on 2003-06-23 18:10:41.0Z
From: "Robert Waywell" <nospam_rwaywell@ianywhere.com>
References: <OxY6pmXODHA.362@forums-2-dub>
Subject: Re: dbunload on ASA7
Date: Mon, 23 Jun 2003 14:10:41 -0400
Lines: 49
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2600.0000
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2600.0000
Message-ID: <OaLqSPbODHA.339@forums-2-dub>
Newsgroups: ianywhere.public.general
NNTP-Posting-Host: rwaywell-pc.sybase.com 172.31.143.74
Path: forums-1-dub!forums-master.sybase.com!forums-2-dub.sybase.com
Xref: forums-1-dub ianywhere.public.general:1235
Article PK: 3479

Try adding the Links=... parameter to specify a network protocol to use:

dbunload -c "uid=dba;pwd=sql;dbn=Test01;eng=TestEngine;links=tcpip"

--
-----------------------------------------------
Robert Waywell
Sybase Adaptive Server Anywhere Developer - Version 8
Sybase Certified Professional

Sybase's iAnywhere Solutions

Please respond ONLY to newsgroup

EBF's and Patches: http://downloads.sybase.com
choose SQL Anywhere Studio >> change 'time frame' to all

To Submit Bug Reports: http://casexpress.sybase.com/cx/cx.stm

SQL Anywhere Studio Supported Platforms and Support Status
http://my.sybase.com/detail?id=1002288

Whitepapers, TechDocs, and bug fixes are all available through the iAnywhere
Developer Community at www.ianywhere.com/developer

"morales" <morales@tehnicom.com> wrote in message
news:OxY6pmXODHA.362@forums-2-dub...
> Unload utility works when good using Sybase Central, even TestEngine is
> situated on another machine. But when I try to do this:
>
> dbunload -c "uid=dba;pwd=sql;dbn=Test01;eng=TestEngine"
>
> using command-line processor, it doesn't work in case of TestEngine is
the
> name of ASA service on another machine in network. Why?
>
> The message is:
> Adaptive Server Anywhere Unload Utility Version 7.0.4.2788
> ***** SQL error: Specified database not found
> C:\>
>
> And sure there is a database named test01 on server TestEngine, and the
> proof for this is that the thing works good using unload utility. If I try
> with ASA service on local machine, everything works fine, too.
>
>
>