Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

The problem of building dbccdb?

6 posts in Windows NT Last posting was on 2001-03-13 17:38:54.0Z
Ray W Posted on 2001-03-12 15:59:08.0Z
From: "Ray W" <rw_ebox@yahoo.com>
Subject: The problem of building dbccdb?
Date: Mon, 12 Mar 2001 10:59:08 -0500
Lines: 44
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.50.4522.1200
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4522.1200
Message-ID: <QLgFgBxqAHA.274@forums.sybase.com>
Newsgroups: sybase.public.sqlserver.nt
NNTP-Posting-Host: 204.50.182.62
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:1119
Article PK: 1088621

Hi,

So far I happen a question about building dbccdb database. I met the
following error message when I run "dbcc checkstroage(db_name)" after I
finished building dbccdb database.

"Error: 9978, Severity: 20, State: 1
00:00000:00009:2001/03/10 13:47:34.95 server The 16K buffer pool in the
configured cache is too small. 640K is the minimum size."

Before I built dbccdb on that product server, I have tested the same
procedure on the test server. No problem. The following is my scripts.

sp_cacheconfig "dbccdb_cache","3M"
go
sp_poolconfig "dbcc_cache,"2048K","16K"
go
sp_dbcc_createws dbccdb,scan_seg,"$dbname",scan,"30M"
go
sp_dbcc_createws dbccdb,text_seg,"$dbname",text,"30M"
go
sp_dbcc_updateconfig db_name,"amx worker processes","2"
go
sp_dbcc_updateconfig db_name,"dbcc named cahe","default data cache","1280K"
go
sp_dbcc_updateconfig dbname,"scan workspace", scan_dbname, "4500K"
go
sp_dbcc_updateconfig dbname,"text workspace", text_dbname ,"1200K"
go
sp_dbcc_evaluatedb dbname
go
sp_dbcc_updateconfig dbname,"OAM count threshold","5,"
go
sp_dbcc_updateconfig dbname,"IO error abort","3"
go
sp_dbcc_updateconfig dbname,"linkage error abort","8"
go

Ray
March 12


Ray W Posted on 2001-03-13 17:38:54.0Z
From: "Ray W" <rw_ebox@yahoo.com>
References: <QLgFgBxqAHA.274@forums.sybase.com>
Subject: Answer my question.
Date: Tue, 13 Mar 2001 12:38:54 -0500
Lines: 8
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.50.4522.1200
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4522.1200
Message-ID: <NHdVZz#qAHA.199@forums.sybase.com>
Newsgroups: sybase.public.sqlserver.nt
NNTP-Posting-Host: 204.50.182.62
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:1106
Article PK: 1087707

After you bind a named cache such as "dbccdb_cahe" to dbccdb database , you
also need to allocate "16k" buffer pool in default data cache. Then you can
use "dbcc checkstorage(dbname)".

Ray
March 13


Bret Halford Posted on 2001-03-12 22:05:29.0Z
Message-ID: <3AAD4829.3180E20E@sybase.com>
Date: Mon, 12 Mar 2001 15:05:29 -0700
From: Bret Halford <bret@sybase.com>
Organization: Sybase, Inc.
X-Mailer: Mozilla 4.5 [en]C-CCK-MCD (WinNT; I)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Re: The problem of building dbccdb?
References: <QLgFgBxqAHA.274@forums.sybase.com>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.sqlserver.nt
Lines: 40
NNTP-Posting-Host: bret-pc.sybase.com 157.133.80.211
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:1114
Article PK: 1088603

Ah. You create a 2mb 16k pool in the "dbcc_cache" cache,
but then tell dbcc to use the "default data cache" instead. You also
misspell "cache" as "cahe" in this line:

sp_dbcc_updateconfig db_name,"dbcc named cahe","default data cache","1280K"

Ray W wrote:

> Hi,
>
> So far I happen a question about building dbccdb database. I met the
> following error message when I run "dbcc checkstroage(db_name)" after I
> finished building dbccdb database.
>
> "Error: 9978, Severity: 20, State: 1
> 00:00000:00009:2001/03/10 13:47:34.95 server The 16K buffer pool in the
> configured cache is too small. 640K is the minimum size."
>
> Before I built dbccdb on that product server, I have tested the same
> procedure on the test server. No problem. The following is my scripts.
>
> sp_cacheconfig "dbccdb_cache","3M"
> go
> sp_poolconfig "dbcc_cache,"2048K","16K"
> go
> sp_dbcc_createws dbccdb,scan_seg,"$dbname",scan,"30M"
> go
> sp_dbcc_createws dbccdb,text_seg,"$dbname",text,"30M"
> go
> sp_dbcc_updateconfig db_name,"amx worker processes","2"
> go
> sp_dbcc_updateconfig db_name,"dbcc named cahe","default data cache","1280K"
> go
> sp_dbcc_updateconfig dbname,"scan workspace", scan_dbname, "4500K"
> go
> sp_dbcc_updateconfig dbname,"text workspace", text_dbname ,"1200K"
> go
> sp_dbcc_evaluatedb dbname
> go
> sp_dbcc_updateconfig dbname,"OAM count threshold","5,"
> go
> sp_dbcc_updateconfig dbname,"IO error abort","3"
> go
> sp_dbcc_updateconfig dbname,"linkage error abort","8"
> go
>
> Ray
> March 12


Ray W Posted on 2001-03-13 17:30:10.0Z
From: "Ray W" <rw_ebox@yahoo.com>
References: <QLgFgBxqAHA.274@forums.sybase.com> <3AAD4829.3180E20E@sybase.com>
Subject: Re: The problem of building dbccdb?
Date: Tue, 13 Mar 2001 12:30:10 -0500
Lines: 45
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.50.4522.1200
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4522.1200
Message-ID: <8dBsUz#qAHA.199@forums.sybase.com>
Newsgroups: sybase.public.sqlserver.nt
NNTP-Posting-Host: 204.50.182.62
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:1107
Article PK: 1087709

Hi Bret,

I am sorry I made some mistakes in my scripts. Yes, I use the "default
data
cache" when I create dbccdb database. After that, I create a named
cache "dbccdb_cache" and allocate that cache and "16K" pool to dbccdb
database. My problem
is
that I use the same method to build dbccdb database on test server and
product server. It is successful on test server but failure on product
server. And get the pasted error message.

> > sp_cacheconfig "dbccdb_cache","3M"
> > go
> > sp_poolconfig "dbcc_cache","2048K","16K"
> > go
> > sp_dbcc_createws dbccdb,scan_seg,"$dbname",scan,"4500K"
> > go
> > sp_dbcc_createws dbccdb,text_seg,"$dbname",text,"1200K"
> > go
> > sp_dbcc_updateconfig db_name,"amx worker processes","2"
> > go
> > sp_dbcc_updateconfig db_name,"dbcc named cahe","default data
>cache","1280K"
> > go
> > sp_dbcc_updateconfig dbname,"scan workspace", scan_dbname, "4500K"
> > go
> > sp_dbcc_updateconfig dbname,"text workspace", text_dbname ,"1200K"
> > go
> > sp_dbcc_evaluatedb dbname
> > go
> > sp_dbcc_updateconfig dbname,"OAM count threshold","5,"
> > go
> > sp_dbcc_updateconfig dbname,"IO error abort","3"
> > go
> > sp_dbcc_updateconfig dbname,"linkage error abort","8"
> > go

Ray
March 13


Ray W Posted on 2001-03-13 16:18:22.0Z
From: "Ray W" <rw_ebox@yahoo.com>
References: <QLgFgBxqAHA.274@forums.sybase.com> <3AAD4829.3180E20E@sybase.com>
Subject: Re: The problem of building dbccdb?
Date: Tue, 13 Mar 2001 11:18:22 -0500
Lines: 44
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.50.4522.1200
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4522.1200
Message-ID: <5N0c8w9qAHA.301@forums.sybase.com>
Newsgroups: sybase.public.sqlserver.nt
NNTP-Posting-Host: 204.50.182.62
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:1110
Article PK: 1087712

Hi Bret,

I am sorry I made some mistakes in my scripts. Yes, I use the "default
data
cache" when I create dbccdb database. After that, I create a named
cache
"dbccdb_cache" and allocate that cache and 16K pool to dbccdb database. My
problem
is that I use the same method to build dbccdb database on test server and
product server. It is successful on test server but failure on product
server. And get the pasted error message.

> > sp_cacheconfig "dbccdb_cache","3M"
> > go
> > sp_poolconfig "dbcc_cache","2048K","16K"
> > go
> > sp_dbcc_createws dbccdb,scan_seg,"$dbname",scan,"4500K"
> > go
> > sp_dbcc_createws dbccdb,text_seg,"$dbname",text,"1200K"
> > go
> > sp_dbcc_updateconfig db_name,"amx worker processes","2"
> > go
> > sp_dbcc_updateconfig db_name,"dbcc named cahe","default data
>cache","1280K"
> > go
> > sp_dbcc_updateconfig dbname,"scan workspace", scan_dbname, "4500K"
> > go
> > sp_dbcc_updateconfig dbname,"text workspace", text_dbname ,"1200K"
> > go
> > sp_dbcc_evaluatedb dbname
> > go
> > sp_dbcc_updateconfig dbname,"OAM count threshold","5,"
> > go
> > sp_dbcc_updateconfig dbname,"IO error abort","3"
> > go
> > sp_dbcc_updateconfig dbname,"linkage error abort","8"
> > go

Ray
March 13


Bret Halford Posted on 2001-03-12 22:02:50.0Z
Message-ID: <3AAD478A.368344B9@sybase.com>
Date: Mon, 12 Mar 2001 15:02:50 -0700
From: Bret Halford <bret@sybase.com>
Organization: Sybase, Inc.
X-Mailer: Mozilla 4.5 [en]C-CCK-MCD (WinNT; I)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Re: The problem of building dbccdb?
References: <QLgFgBxqAHA.274@forums.sybase.com>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.sqlserver.nt
Lines: 37
NNTP-Posting-Host: bret-pc.sybase.com 157.133.80.211
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:1115
Article PK: 1088604

You seem to be missing a quote mark in the "sp_poolconfig" line, not sure if
that is the root of your problem or not.

-bret

Ray W wrote:

> Hi,
>
> So far I happen a question about building dbccdb database. I met the
> following error message when I run "dbcc checkstroage(db_name)" after I
> finished building dbccdb database.
>
> "Error: 9978, Severity: 20, State: 1
> 00:00000:00009:2001/03/10 13:47:34.95 server The 16K buffer pool in the
> configured cache is too small. 640K is the minimum size."
>
> Before I built dbccdb on that product server, I have tested the same
> procedure on the test server. No problem. The following is my scripts.
>
> sp_cacheconfig "dbccdb_cache","3M"
> go
> sp_poolconfig "dbcc_cache,"2048K","16K"
> go
> sp_dbcc_createws dbccdb,scan_seg,"$dbname",scan,"30M"
> go
> sp_dbcc_createws dbccdb,text_seg,"$dbname",text,"30M"
> go
> sp_dbcc_updateconfig db_name,"amx worker processes","2"
> go
> sp_dbcc_updateconfig db_name,"dbcc named cahe","default data cache","1280K"
> go
> sp_dbcc_updateconfig dbname,"scan workspace", scan_dbname, "4500K"
> go
> sp_dbcc_updateconfig dbname,"text workspace", text_dbname ,"1200K"
> go
> sp_dbcc_evaluatedb dbname
> go
> sp_dbcc_updateconfig dbname,"OAM count threshold","5,"
> go
> sp_dbcc_updateconfig dbname,"IO error abort","3"
> go
> sp_dbcc_updateconfig dbname,"linkage error abort","8"
> go
>
> Ray
> March 12