Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

PB10.2 on Vista prints extra copies of DWs when # of Copies set

6 posts in DataWindow Last posting was on 2008-05-02 20:20:23.0Z
Dan Cooperstock Posted on 2008-05-02 18:14:49.0Z
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: PB10.2 on Vista prints extra copies of DWs when # of Copies set
From: Dan Cooperstock <dcoops@sympatico.ca>
Message-ID: <Xns9A9290E9697E4dcoopssympaticoca@192.138.151.106>
User-Agent: Xnews/5.04.25
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 2 May 2008 11:14:49 -0700
X-Trace: forums-1-dub 1209752089 10.22.241.152 (2 May 2008 11:14:49 -0700)
X-Original-Trace: 2 May 2008 11:14:49 -0700, vip152.sybase.com
Lines: 12
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:86762
Article PK: 416021

When my application goes to print one of its reports (which is of course a
DataWindow), and in the Print dialog I select a number of copies, it prints
the square of the specified number of copies. I.e. if I specify 1 copy, I
get 1 copy, but specifying 2 gives 4 copies, and specifying 3 gives 9
copies!

This only seems to happen on Vista, and only with my real printer driver.
(I have a PDF printer driver, and it doesn't behave that way.)

I'm using PB 10.2.

Has anybody else seen this or know about a fix for it?


"Jason 'Bug' Fenter [TeamSybase]" <NO_SPAMMING_jason.fenter_ Posted on 2008-05-02 18:23:00.0Z
From: "Jason 'Bug' Fenter [TeamSybase]" <NO_SPAMMING_jason.fenter_@_teamsybase.com>
User-Agent: Thunderbird 2.0.0.14 (Windows/20080421)
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: PB10.2 on Vista prints extra copies of DWs when # of Copies set
References: <Xns9A9290E9697E4dcoopssympaticoca@192.138.151.106>
In-Reply-To: <Xns9A9290E9697E4dcoopssympaticoca@192.138.151.106>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <481b5c04@forums-1-dub>
Date: 2 May 2008 11:23:00 -0700
X-Trace: forums-1-dub 1209752580 10.22.241.152 (2 May 2008 11:23:00 -0700)
X-Original-Trace: 2 May 2008 11:23:00 -0700, vip152.sybase.com
Lines: 31
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:86763
Article PK: 416022

I don't want to sound like I'm just pointing the finger away from PB,
but I have to ask if your real printer driver is Vista-compatible.

Dan Cooperstock wrote:
> When my application goes to print one of its reports (which is of course a
> DataWindow), and in the Print dialog I select a number of copies, it prints
> the square of the specified number of copies. I.e. if I specify 1 copy, I
> get 1 copy, but specifying 2 gives 4 copies, and specifying 3 gives 9
> copies!
>
> This only seems to happen on Vista, and only with my real printer driver.
> (I have a PDF printer driver, and it doesn't behave that way.)
>
> I'm using PB 10.2.
>
> Has anybody else seen this or know about a fix for it?

--
Off topic:
Sybase has been reviewing NNTP availability and is looking at
alternative ways to build a user community. As a test-bed /
proof-of-concept, I have personally created a community on Ning
(http://powerbuilder.ning.com). While Ning certainly doesn't offer all
of the features that I'd like to see Sybase eventually implement, I am
trying to foster some community involvement on that site. Several of the
TeamSybase members have joined already and are available to answer
questions there.

Please sign up; give it a try. My hope is that it evolves into more than
just a Q&A database, but it won't get there without your participation.


"Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel Posted on 2008-05-02 18:47:18.0Z
From: "Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel@yahoo!.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <Xns9A9290E9697E4dcoopssympaticoca@192.138.151.106> <481b5c04@forums-1-dub>
Subject: Re: PB10.2 on Vista prints extra copies of DWs when # of Copies set
Lines: 37
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Response
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <481b61b6@forums-1-dub>
Date: 2 May 2008 11:47:18 -0700
X-Trace: forums-1-dub 1209754038 10.22.241.152 (2 May 2008 11:47:18 -0700)
X-Original-Trace: 2 May 2008 11:47:18 -0700, vip152.sybase.com
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:86765
Article PK: 416024

I'd also ask if this happens with any other applications on Vista.

"Jason 'Bug' Fenter [TeamSybase]"

<NO_SPAMMING_jason.fenter_@_teamsybase.com> wrote in message
news:481b5c04@forums-1-dub...
>I don't want to sound like I'm just pointing the finger away from PB, but I
>have to ask if your real printer driver is Vista-compatible.
>
>
> Dan Cooperstock wrote:
>> When my application goes to print one of its reports (which is of course
>> a DataWindow), and in the Print dialog I select a number of copies, it
>> prints the square of the specified number of copies. I.e. if I specify 1
>> copy, I get 1 copy, but specifying 2 gives 4 copies, and specifying 3
>> gives 9 copies!
>>
>> This only seems to happen on Vista, and only with my real printer driver.
>> (I have a PDF printer driver, and it doesn't behave that way.)
>>
>> I'm using PB 10.2.
>>
>> Has anybody else seen this or know about a fix for it?
>
> --
> Off topic:
> Sybase has been reviewing NNTP availability and is looking at alternative
> ways to build a user community. As a test-bed / proof-of-concept, I have
> personally created a community on Ning (http://powerbuilder.ning.com).
> While Ning certainly doesn't offer all of the features that I'd like to
> see Sybase eventually implement, I am trying to foster some community
> involvement on that site. Several of the TeamSybase members have joined
> already and are available to answer questions there.
>
> Please sign up; give it a try. My hope is that it evolves into more than
> just a Q&A database, but it won't get there without your participation.


Dan Cooperstock Posted on 2008-05-02 19:07:07.0Z
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: PB10.2 on Vista prints extra copies of DWs when # of Copies set
From: Dan Cooperstock <dcoops@sympatico.ca>
References: <Xns9A9290E9697E4dcoopssympaticoca@192.138.151.106> <481b5c04@forums-1-dub> <481b61b6@forums-1-dub>
Message-ID: <Xns9A9299C71F5E4dcoopssympaticoca@192.138.151.106>
User-Agent: Xnews/5.04.25
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 2 May 2008 12:07:07 -0700
X-Trace: forums-1-dub 1209755227 10.22.241.152 (2 May 2008 12:07:07 -0700)
X-Original-Trace: 2 May 2008 12:07:07 -0700, vip152.sybase.com
Lines: 17
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:86768
Article PK: 416027

"Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel@yahoo!.com> wrote in
news:481b61b6@forums-1-dub:

Sorry, should have mentioned that this does not happen with any other
applications, only my PB app. That's true both for the user of my
application that reported the problem, and for me on a Vista laptop I just
tried it on.

> I'd also ask if this happens with any other applications on Vista.
>
> "Jason 'Bug' Fenter [TeamSybase]"
> <NO_SPAMMING_jason.fenter_@_teamsybase.com> wrote in message
> news:481b5c04@forums-1-dub...
>>I don't want to sound like I'm just pointing the finger away from PB,
>>but I have to ask if your real printer driver is Vista-compatible.
>>
>>


Dan Cooperstock Posted on 2008-05-02 19:01:33.0Z
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: PB10.2 on Vista prints extra copies of DWs when # of Copies set
From: Dan Cooperstock <dcoops@sympatico.ca>
References: <Xns9A9290E9697E4dcoopssympaticoca@192.138.151.106> <481b5c04@forums-1-dub>
Message-ID: <Xns9A9298D558FE0dcoopssympaticoca@192.138.151.106>
User-Agent: Xnews/5.04.25
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 2 May 2008 12:01:33 -0700
X-Trace: forums-1-dub 1209754893 10.22.241.152 (2 May 2008 12:01:33 -0700)
X-Original-Trace: 2 May 2008 12:01:33 -0700, vip152.sybase.com
Lines: 30
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:86767
Article PK: 416026

"Jason 'Bug' Fenter [TeamSybase]"
<NO_SPAMMING_jason.fenter_@_teamsybase.com> wrote in
news:481b5c04@forums-1-dub:

Well, that was a really smart thought. I did just upgrade my driver to the
one Canon says is for Vista, per your suggestion, and the same behaviour is
continuing. Also, no other program I print with on this computer has ever
had this sort of problem, when printing multiple copies. That's why I was
asking here on the PB DW forum.

> I don't want to sound like I'm just pointing the finger away from PB,
> but I have to ask if your real printer driver is Vista-compatible.
>
>
> Dan Cooperstock wrote:
>> When my application goes to print one of its reports (which is of
>> course a DataWindow), and in the Print dialog I select a number of
>> copies, it prints the square of the specified number of copies. I.e.
>> if I specify 1 copy, I get 1 copy, but specifying 2 gives 4 copies,
>> and specifying 3 gives 9 copies!
>>
>> This only seems to happen on Vista, and only with my real printer
>> driver. (I have a PDF printer driver, and it doesn't behave that
>> way.)
>>
>> I'm using PB 10.2.
>>
>> Has anybody else seen this or know about a fix for it?
>


"Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel Posted on 2008-05-02 20:20:23.0Z
From: "Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel@yahoo!.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <Xns9A9290E9697E4dcoopssympaticoca@192.138.151.106> <481b5c04@forums-1-dub> <Xns9A9298D558FE0dcoopssympaticoca@192.138.151.106>
Subject: Re: PB10.2 on Vista prints extra copies of DWs when # of Copies set
Lines: 42
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <481b7787@forums-1-dub>
Date: 2 May 2008 13:20:23 -0700
X-Trace: forums-1-dub 1209759623 10.22.241.152 (2 May 2008 13:20:23 -0700)
X-Original-Trace: 2 May 2008 13:20:23 -0700, vip152.sybase.com
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:86770
Article PK: 416029

I am sorry to say that 10.2 was never supported on Vista, and you are
fortunate if that is your only problem. In fact, 10.5 came out a year before
Vista did. See http://www.sybase.com/detail?id=1052716 for details.
Given what you've said so far I'd guess it _is_ a PB problem and that until
you are ready to upgrade to 11.1 or above all you can do is print reports 1
by 1 (or by 4 or by 9 ...).

"Dan Cooperstock" <dcoops@sympatico.ca> wrote in message
news:Xns9A9298D558FE0dcoopssympaticoca@192.138.151.106...
> "Jason 'Bug' Fenter [TeamSybase]"
> <NO_SPAMMING_jason.fenter_@_teamsybase.com> wrote in
> news:481b5c04@forums-1-dub:
>
> Well, that was a really smart thought. I did just upgrade my driver to the
> one Canon says is for Vista, per your suggestion, and the same behaviour
> is
> continuing. Also, no other program I print with on this computer has ever
> had this sort of problem, when printing multiple copies. That's why I was
> asking here on the PB DW forum.
>
>> I don't want to sound like I'm just pointing the finger away from PB,
>> but I have to ask if your real printer driver is Vista-compatible.
>>
>>
>> Dan Cooperstock wrote:
>>> When my application goes to print one of its reports (which is of
>>> course a DataWindow), and in the Print dialog I select a number of
>>> copies, it prints the square of the specified number of copies. I.e.
>>> if I specify 1 copy, I get 1 copy, but specifying 2 gives 4 copies,
>>> and specifying 3 gives 9 copies!
>>>
>>> This only seems to happen on Vista, and only with my real printer
>>> driver. (I have a PDF printer driver, and it doesn't behave that
>>> way.)
>>>
>>> I'm using PB 10.2.
>>>
>>> Has anybody else seen this or know about a fix for it?
>>
>