Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Displaying BLOBs in datawindow

5 posts in DataWindow Last posting was on 2009-08-05 21:47:38.0Z
Avi Posted on 2009-08-04 10:53:42.0Z
From: Avi <averell.saldanha@gmail.com>
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Displaying BLOBs in datawindow
Date: Tue, 4 Aug 2009 03:53:42 -0700 (PDT)
Organization: http://groups.google.com
Lines: 4
Message-ID: <ac9cca83-3319-42eb-a06a-9d37938c2049@c34g2000yqi.googlegroups.com>
NNTP-Posting-Host: 69.115.237.197
Mime-Version: 1.0
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
X-Trace: posting.google.com 1249383223 9151 127.0.0.1 (4 Aug 2009 10:53:43 GMT)
X-Complaints-To: groups-abuse@google.com
NNTP-Posting-Date: Tue, 4 Aug 2009 10:53:43 +0000 (UTC)
Complaints-To: groups-abuse@google.com
Injection-Info: c34g2000yqi.googlegroups.com; posting-host=69.115.237.197; posting-account=Ua5F6QoAAAAokIRavBKJ0SiFBbzxcMle
User-Agent: G2/1.0
X-HTTP-UserAgent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/530.5 (KHTML, like Gecko) Chrome/2.0.172.39 Safari/530.5,gzip(gfe),gzip(gfe)
Path: forums-1-dub!forums-master!newssvr.sybase.com!news-sj-1.sprintlink.net!news-peer1.sprintlink.net!nntp1.phx1.gblx.net!nntp.gblx.net!nntp.gblx.net!newsfeed.news2me.com!nx01.iad01.newshosting.com!newshosting.com!216.196.98.140.MISMATCH!border1.nntp.dca.giganews.com!nntp.giganews.com!postnews.google.com!c34g2000yqi.googlegroups.com!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89733
Article PK: 418921

How do I set a bitmap(blob) to a picture control on a tab datawindow.
I have the bitmap in a blob datatype. None of the setitem functions
work. For a Picture Control on a window, I would use SetPicture(). Is
there something similar to this ?


John Strano[Sybase] Posted on 2009-08-04 13:28:23.0Z
From: "John Strano[Sybase]" <nichtspamjstrano@csi.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <ac9cca83-3319-42eb-a06a-9d37938c2049@c34g2000yqi.googlegroups.com>
Subject: Re: Displaying BLOBs in datawindow
Lines: 18
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4a783777$4@forums-3-dub.sybase.com>
Date: 4 Aug 2009 06:28:23 -0700
X-Trace: forums-3-dub.sybase.com 1249392503 10.22.241.152 (4 Aug 2009 06:28:23 -0700)
X-Original-Trace: 4 Aug 2009 06:28:23 -0700, vip152.sybase.com
X-Authenticated-User: TeamSybase
Path: forums-1-dub!forums-master!forums-3-dub.sybase.com!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89735
Article PK: 418923

Have you considered using an InkPicture control?

http://infocenter.sybase.com/help/topic/com.sybase.dc37783_1150/html/dwref/BGBFFDJI.htm

--
John Strano - Sybase Technology Evangelist

blog: http://powerbuilder.johnstrano.com/

"Avi" <averell.saldanha@gmail.com> wrote in message
news:ac9cca83-3319-42eb-a06a-9d37938c2049@c34g2000yqi.googlegroups.com...
> How do I set a bitmap(blob) to a picture control on a tab datawindow.
> I have the bitmap in a blob datatype. None of the setitem functions
> work. For a Picture Control on a window, I would use SetPicture(). Is
> there something similar to this ?


Chris Kean Posted on 2009-08-05 19:49:01.0Z
From: "Chris Kean" <christopher.kean@stld-cci.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <ac9cca83-3319-42eb-a06a-9d37938c2049@c34g2000yqi.googlegroups.com>
Subject: Re: Displaying BLOBs in datawindow
Lines: 41
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5512
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4a79e22d$3@forums-3-dub.sybase.com>
Date: 5 Aug 2009 12:49:01 -0700
X-Trace: forums-3-dub.sybase.com 1249501741 10.22.241.152 (5 Aug 2009 12:49:01 -0700)
X-Original-Trace: 5 Aug 2009 12:49:01 -0700, vip152.sybase.com
Path: forums-1-dub!forums-master!forums-3-dub.sybase.com!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89741
Article PK: 418929

Not to throw myself into someone else's thread, but I was actual working on
this same thing right now and have run into a problem.

Regarding John's comment, the inkpicture route works fine, so long as when
you're setting it up you make sure to select your image blob as the "Large
Binary Column for Background Image" and some other column for "Large Binary
Column for Ink data". PB wont let them be the same column, and the "Ink
data" column wont show up for displaying the image (I stared at a blank box
for about half an hour before I figured this one out playing around with the
control).

Here's the problem I'm having: I've read that the inkpicture can handle
BMPs, JPGs, GIFs, and ICOs. I've verified all but the JPG (as it doesn't
really pertain to what I'm doing) but I was wondering if there was a way to
use the transparent background found in the GIF and ICO files? The GIFs I
loaded with the inkpicture had their full backgrounds (usually the ugly
fuschia/magenta/magic pink color that I use for background transparency).
The ICOs had a solid black background where the normal transparency is (I'm
guessing its the bitmap without the transparency layer applied). Is there
any way around this, thus making the background of the inkpicture image
transparent?

I've tried Blob as an OLE, which gets me a box, but no image and nothing I
can apply bitmap() to. I've tried a Paint.Picture OLE and PBrush OLE,
neither of which seemed to work or be what I wanted, judging by the forum
comments I've seen. So is there a way to get transparent backgrounds for
images (preferably without having to resort to a 3rd party pay-for OLE/OCX
control)? BTW, I'm using 10.5.2.7826 for refrence.

Thanks for any help and sorry for intruding.

Chris

"Avi" <averell.saldanha@gmail.com> wrote in message
news:ac9cca83-3319-42eb-a06a-9d37938c2049@c34g2000yqi.googlegroups.com...
> How do I set a bitmap(blob) to a picture control on a tab datawindow.
> I have the bitmap in a blob datatype. None of the setitem functions
> work. For a Picture Control on a window, I would use SetPicture(). Is
> there something similar to this ?


John Strano[Sybase] Posted on 2009-08-05 21:47:38.0Z
From: "John Strano[Sybase]" <nichtspamjstrano@csi.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <ac9cca83-3319-42eb-a06a-9d37938c2049@c34g2000yqi.googlegroups.com> <4a79e22d$3@forums-3-dub.sybase.com>
Subject: Re: Displaying BLOBs in datawindow
Lines: 55
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4a79fdfa$2@forums-3-dub.sybase.com>
Date: 5 Aug 2009 14:47:38 -0700
X-Trace: forums-3-dub.sybase.com 1249508858 10.22.241.152 (5 Aug 2009 14:47:38 -0700)
X-Original-Trace: 5 Aug 2009 14:47:38 -0700, vip152.sybase.com
X-Authenticated-User: TeamSybase
Path: forums-1-dub!forums-master!forums-3-dub.sybase.com!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89743
Article PK: 418930

In PB11.5, picture controls in DWOs now have a TransparentColor attribute.
I feel adding this capability to InkPicture is a good candidate for an
enhancement request.

--
John Strano - Sybase Technology Evangelist

blog: http://powerbuilder.johnstrano.com/

"Chris Kean" <christopher.kean@stld-cci.com> wrote in message
news:4a79e22d$3@forums-3-dub.sybase.com...
> Not to throw myself into someone else's thread, but I was actual working
> on this same thing right now and have run into a problem.
>
> Regarding John's comment, the inkpicture route works fine, so long as when
> you're setting it up you make sure to select your image blob as the "Large
> Binary Column for Background Image" and some other column for "Large
> Binary Column for Ink data". PB wont let them be the same column, and the
> "Ink data" column wont show up for displaying the image (I stared at a
> blank box for about half an hour before I figured this one out playing
> around with the control).
>
> Here's the problem I'm having: I've read that the inkpicture can handle
> BMPs, JPGs, GIFs, and ICOs. I've verified all but the JPG (as it doesn't
> really pertain to what I'm doing) but I was wondering if there was a way
> to use the transparent background found in the GIF and ICO files? The GIFs
> I loaded with the inkpicture had their full backgrounds (usually the ugly
> fuschia/magenta/magic pink color that I use for background transparency).
> The ICOs had a solid black background where the normal transparency is
> (I'm guessing its the bitmap without the transparency layer applied). Is
> there any way around this, thus making the background of the inkpicture
> image transparent?
>
> I've tried Blob as an OLE, which gets me a box, but no image and nothing I
> can apply bitmap() to. I've tried a Paint.Picture OLE and PBrush OLE,
> neither of which seemed to work or be what I wanted, judging by the forum
> comments I've seen. So is there a way to get transparent backgrounds for
> images (preferably without having to resort to a 3rd party pay-for OLE/OCX
> control)? BTW, I'm using 10.5.2.7826 for refrence.
>
> Thanks for any help and sorry for intruding.
>
> Chris
>
> "Avi" <averell.saldanha@gmail.com> wrote in message
> news:ac9cca83-3319-42eb-a06a-9d37938c2049@c34g2000yqi.googlegroups.com...
>> How do I set a bitmap(blob) to a picture control on a tab datawindow.
>> I have the bitmap in a blob datatype. None of the setitem functions
>> work. For a Picture Control on a window, I would use SetPicture(). Is
>> there something similar to this ?
>
>


John Strano[Sybase] Posted on 2009-08-05 21:39:47.0Z
From: "John Strano[Sybase]" <nichtspamjstrano@csi.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <ac9cca83-3319-42eb-a06a-9d37938c2049@c34g2000yqi.googlegroups.com> <4a79e22d$3@forums-3-dub.sybase.com>
Subject: Re: Displaying BLOBs in datawindow
Lines: 58
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4a79fc23@forums-3-dub.sybase.com>
Date: 5 Aug 2009 14:39:47 -0700
X-Trace: forums-3-dub.sybase.com 1249508387 10.22.241.152 (5 Aug 2009 14:39:47 -0700)
X-Original-Trace: 5 Aug 2009 14:39:47 -0700, vip152.sybase.com
X-Authenticated-User: TeamSybase
Path: forums-1-dub!forums-master!forums-3-dub.sybase.com!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:89742
Article PK: 418931

>> Thanks for any help and sorry for intruding.

No intrusion Chris. No need for an apology.

Hopefully someone with first hand experience will jump in and we'll both
learn something.

--
John Strano - Sybase Technology Evangelist

blog: http://powerbuilder.johnstrano.com/

"Chris Kean" <christopher.kean@stld-cci.com> wrote in message
news:4a79e22d$3@forums-3-dub.sybase.com...
> Not to throw myself into someone else's thread, but I was actual working
> on this same thing right now and have run into a problem.
>
> Regarding John's comment, the inkpicture route works fine, so long as when
> you're setting it up you make sure to select your image blob as the "Large
> Binary Column for Background Image" and some other column for "Large
> Binary Column for Ink data". PB wont let them be the same column, and the
> "Ink data" column wont show up for displaying the image (I stared at a
> blank box for about half an hour before I figured this one out playing
> around with the control).
>
> Here's the problem I'm having: I've read that the inkpicture can handle
> BMPs, JPGs, GIFs, and ICOs. I've verified all but the JPG (as it doesn't
> really pertain to what I'm doing) but I was wondering if there was a way
> to use the transparent background found in the GIF and ICO files? The GIFs
> I loaded with the inkpicture had their full backgrounds (usually the ugly
> fuschia/magenta/magic pink color that I use for background transparency).
> The ICOs had a solid black background where the normal transparency is
> (I'm guessing its the bitmap without the transparency layer applied). Is
> there any way around this, thus making the background of the inkpicture
> image transparent?
>
> I've tried Blob as an OLE, which gets me a box, but no image and nothing I
> can apply bitmap() to. I've tried a Paint.Picture OLE and PBrush OLE,
> neither of which seemed to work or be what I wanted, judging by the forum
> comments I've seen. So is there a way to get transparent backgrounds for
> images (preferably without having to resort to a 3rd party pay-for OLE/OCX
> control)? BTW, I'm using 10.5.2.7826 for refrence.
>
> Thanks for any help and sorry for intruding.
>
> Chris
>
> "Avi" <averell.saldanha@gmail.com> wrote in message
> news:ac9cca83-3319-42eb-a06a-9d37938c2049@c34g2000yqi.googlegroups.com...
>> How do I set a bitmap(blob) to a picture control on a tab datawindow.
>> I have the bitmap in a blob datatype. None of the setitem functions
>> work. For a Picture Control on a window, I would use SetPicture(). Is
>> there something similar to this ?
>
>