Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

PB 11.1 application crashes - help needed

2 posts in DataWindow Last posting was on 2010-04-05 16:47:21.0Z
Mazibar Posted on 2008-10-02 13:45:49.0Z
From: Mazibar <mazibar76@rediffmail.com>
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: PB 11.1 application crashes - help needed
Date: Thu, 2 Oct 2008 06:45:49 -0700 (PDT)
Organization: http://groups.google.com
Lines: 33
Message-ID: <cb229fa7-ba85-4b9c-9bd0-67a442dcaa97@k30g2000hse.googlegroups.com>
NNTP-Posting-Host: 213.61.164.152
Mime-Version: 1.0
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
X-Trace: posting.google.com 1222955150 27977 127.0.0.1 (2 Oct 2008 13:45:50 GMT)
X-Complaints-To: groups-abuse@google.com
NNTP-Posting-Date: Thu, 2 Oct 2008 13:45:50 +0000 (UTC)
Cc: mazibar76@rediffmail.com
Complaints-To: groups-abuse@google.com
Injection-Info: k30g2000hse.googlegroups.com; posting-host=213.61.164.152; posting-account=vdx9_QkAAACR5K45Uhx6ta__SUcyvYAk
User-Agent: G2/1.0
X-HTTP-UserAgent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1),gzip(gfe),gzip(gfe)
Path: forums-1-dub!forums-master!newssvr.sybase.com!news-sj-1.sprintlink.net!news-peer1.sprintlink.net!newsfeed.yul.equant.net!nntp1.roc.gblx.net!nntp.gblx.net!nntp.gblx.net!nlpi057.nbdc.sbc.com!prodigy.net!border1.nntp.dca.giganews.com!nntp.giganews.com!postnews.google.com!k30g2000hse.googlegroups.com!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87901
Article PK: 417156

Hi,

Recently we've migrated our PB6.5 application to PB11.1 Build 8123.
Our OS is XP with SP2. All are working fine (after some fixes here and
there...) in PB11.1 except one issue.

The issue is - when we are trying to preview a report, the application
is crahing and getting closed. It works well in PB6.5. In PB11.1, this
is happening from dev. environment as well as EXE. In 'Event Viewer ->
Application' log, we find the this message -
"Faulting application pb110.exe, version 11.1.0.8123, faulting module
pbdwe110.dll, version 11.1.0.8123, fault address 0x001e7922."

On debugging, we found that the application is crashing in the
following line of code -

adw.Object.dwc_loc.object.data = ids.object.data

Here,
- adw is a composite datawindow passed by reference with report object
dwc_loc.
- dwc_loc and ids are similar - having the same 123 columns in same
sequence. These objects have 2 groups. There are number of computed
fields also.


Please note that the application crashes when number of rows in "ids"
is more than 2. It works fine if "ids" has 1 or 2 rows.

We appreciate your help/suggestion on this.

Thanks,
Mazibar


Irene Posted on 2010-04-05 16:47:21.0Z
Sender: 4aa0.4bba13c2.1804289383@sybase.com
From: Irene
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: PB 11.1 application crashes - help needed
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4bba1419.4ab1.1681692777@sybase.com>
References: <cb229fa7-ba85-4b9c-9bd0-67a442dcaa97@k30g2000hse.googlegroups.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 5 Apr 2010 09:47:21 -0700
X-Trace: forums-1-dub 1270486041 10.22.241.41 (5 Apr 2010 09:47:21 -0700)
X-Original-Trace: 5 Apr 2010 09:47:21 -0700, 10.22.241.41
Lines: 45
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:90999
Article PK: 410606

Hi, were you able to get solution for your problem? I get
similar error, which is hard to replicate and I was
wondering if there is a solution.

Thanks!

Irene

> Hi,
>
> Recently we've migrated our PB6.5 application to PB11.1
> Build 8123. Our OS is XP with SP2. All are working fine
> (after some fixes here and there...) in PB11.1 except one
> issue.
>
> The issue is - when we are trying to preview a report, the
> application is crahing and getting closed. It works well
> in PB6.5. In PB11.1, this is happening from dev.
> environment as well as EXE. In 'Event Viewer ->
> Application' log, we find the this message - "Faulting
> application pb110.exe, version 11.1.0.8123, faulting
> module pbdwe110.dll, version 11.1.0.8123, fault address
> 0x001e7922."
>
> On debugging, we found that the application is crashing in
> the following line of code -
>
> adw.Object.dwc_loc.object.data = ids.object.data
>
> Here,
> - adw is a composite datawindow passed by reference with
> report object dwc_loc.
> - dwc_loc and ids are similar - having the same 123
> columns in same sequence. These objects have 2 groups.
> There are number of computed fields also.
>
>
> Please note that the application crashes when number of
> rows in "ids" is more than 2. It works fine if "ids" has 1
> or 2 rows.
>
> We appreciate your help/suggestion on this.
>
> Thanks,
> Mazibar