Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

issue with treeview datawindow

3 posts in DataWindow Last posting was on 2009-01-20 16:29:18.0Z
Brijesh Posted on 2009-01-20 13:22:19.0Z
From: Brijesh <brijesh.kumar77@gmail.com>
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: issue with treeview datawindow
Date: Tue, 20 Jan 2009 05:22:19 -0800 (PST)
Organization: http://groups.google.com
Lines: 9
Message-ID: <cdb9fd1b-5dfe-4f72-ab25-2914ab7c61b6@d36g2000prf.googlegroups.com>
NNTP-Posting-Host: 192.223.158.46
Mime-Version: 1.0
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
X-Trace: posting.google.com 1232457739 25149 127.0.0.1 (20 Jan 2009 13:22:19 GMT)
X-Complaints-To: groups-abuse@google.com
NNTP-Posting-Date: Tue, 20 Jan 2009 13:22:19 +0000 (UTC)
Complaints-To: groups-abuse@google.com
Injection-Info: d36g2000prf.googlegroups.com; posting-host=192.223.158.46; posting-account=vrluqAoAAAD31PxYm4dG-2VCp98LIaQB
User-Agent: G2/1.0
X-HTTP-UserAgent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; IE 6.0 SP1 (FID r3.0); SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727),gzip(gfe),gzip(gfe)
Path: forums-1-dub!forums-master!newssvr.sybase.com!news-sj-1.sprintlink.net!news-peer1.sprintlink.net!nntp1.phx1.gblx.net!nntp.gblx.net!nntp.gblx.net!border2.nntp.dca.giganews.com!nntp.giganews.com!postnews.google.com!d36g2000prf.googlegroups.com!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:88642
Article PK: 417896

Hi group,
I am creating a treeview datawindow. When i populate the data in
design mode, it display the tree structure. but when i insert the data
using setitem, it does not display the parent node anymore.

I thank you all for your support

Regards,
-Guddu


"Jason 'Bug' Fenter [TeamSybase]" <NO_SPAMMING_jason.fenter_ Posted on 2009-01-20 16:12:22.0Z
From: "Jason 'Bug' Fenter [TeamSybase]" <NO_SPAMMING_jason.fenter_@_teamsybase.com>
User-Agent: Thunderbird 2.0.0.19 (Windows/20081209)
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: issue with treeview datawindow
References: <cdb9fd1b-5dfe-4f72-ab25-2914ab7c61b6@d36g2000prf.googlegroups.com>
In-Reply-To: <cdb9fd1b-5dfe-4f72-ab25-2914ab7c61b6@d36g2000prf.googlegroups.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4975f7e6$1@forums-1-dub>
Date: 20 Jan 2009 08:12:22 -0800
X-Trace: forums-1-dub 1232467942 10.22.241.152 (20 Jan 2009 08:12:22 -0800)
X-Original-Trace: 20 Jan 2009 08:12:22 -0800, vip152.sybase.com
Lines: 18
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:88643
Article PK: 417897

Are you setting all of the values needed for the grouping / nesting? If
so, then you probably need a GroupCalc() afterwards to get it to display
properly.

By the way, please don't cross-post. :)

Brijesh wrote:
> Hi group,
> I am creating a treeview datawindow. When i populate the data in
> design mode, it display the tree structure. but when i insert the data
> using setitem, it does not display the parent node anymore.
>
> I thank you all for your support
>
> Regards,
> -Guddu


Brijesh Posted on 2009-01-20 16:29:18.0Z
From: Brijesh <brijesh.kumar77@gmail.com>
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: issue with treeview datawindow
Date: Tue, 20 Jan 2009 08:29:18 -0800 (PST)
Organization: http://groups.google.com
Lines: 29
Message-ID: <485534f9-9445-45bf-8111-86b99a1e18ca@p2g2000prf.googlegroups.com>
References: <cdb9fd1b-5dfe-4f72-ab25-2914ab7c61b6@d36g2000prf.googlegroups.com> <4975f7e6$1@forums-1-dub>
NNTP-Posting-Host: 192.223.158.46
Mime-Version: 1.0
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
X-Trace: posting.google.com 1232468959 27085 127.0.0.1 (20 Jan 2009 16:29:19 GMT)
X-Complaints-To: groups-abuse@google.com
NNTP-Posting-Date: Tue, 20 Jan 2009 16:29:19 +0000 (UTC)
Complaints-To: groups-abuse@google.com
Injection-Info: p2g2000prf.googlegroups.com; posting-host=192.223.158.46; posting-account=vrluqAoAAAD31PxYm4dG-2VCp98LIaQB
User-Agent: G2/1.0
X-HTTP-UserAgent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; IE 6.0 SP1 (FID r3.0); SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727),gzip(gfe),gzip(gfe)
Path: forums-1-dub!forums-master!newssvr.sybase.com!news-sj-1.sprintlink.net!news-peer1.sprintlink.net!nntp1.phx1.gblx.net!nntp.gblx.net!nntp.gblx.net!border2.nntp.dca.giganews.com!nntp.giganews.com!postnews.google.com!p2g2000prf.googlegroups.com!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:88644
Article PK: 417898

On Jan 20, 9:12 pm, "Jason 'Bug' Fenter [TeamSybase]"

<NO_SPAMMING_jason.fenter_@_teamsybase.com> wrote:
> Are you setting all of the values needed for the grouping / nesting? If
> so, then you probably need a GroupCalc() afterwards to get it to display
> properly.
>
> By the way, please don't cross-post. :)
>
>
>
> Brijesh wrote:
> > Hi group,
> > I am creating a treeview datawindow. When i populate the data in
> > design mode, it display the tree structure. but when i insert the data
> > using setitem, it does not display the parent node anymore.
>
> > I thank you all for your support
>
> > Regards,
> > -Guddu- Hide quoted text -
>
> - Show quoted text -

thanks for your help. little issue still persists.. if i add single
record to the group, it does not display any data. But if i add more
than one row then it display the group.

thanks
-guddu