Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Adding column to datasource

2 posts in DataWindow Last posting was on 2008-06-24 18:16:16.0Z
vanimm Posted on 2008-06-24 15:52:41.0Z
From: vanimm@gmail.com
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Adding column to datasource
Date: Tue, 24 Jun 2008 08:52:41 -0700 (PDT)
Organization: http://groups.google.com
Lines: 14
Message-ID: <ddf95d9e-d295-4a84-9b2c-d74ae42bcd5a@c58g2000hsc.googlegroups.com>
NNTP-Posting-Host: 67.129.188.2
Mime-Version: 1.0
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
X-Trace: posting.google.com 1214322761 9934 127.0.0.1 (24 Jun 2008 15:52:41 GMT)
X-Complaints-To: groups-abuse@google.com
NNTP-Posting-Date: Tue, 24 Jun 2008 15:52:41 +0000 (UTC)
Complaints-To: groups-abuse@google.com
Injection-Info: c58g2000hsc.googlegroups.com; posting-host=67.129.188.2; posting-account=zer2fgoAAADYhYCSBxn99PadbQDfrEoc
User-Agent: G2/1.0
X-HTTP-UserAgent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14,gzip(gfe),gzip(gfe)
Path: forums-1-dub!forums-master!newssvr.sybase.com!news-sj-1.sprintlink.net!news-peer1.sprintlink.net!nntp1.phx1.gblx.net!nntp.gblx.net!nntp.gblx.net!border2.nntp.dca.giganews.com!nntp.giganews.com!postnews.google.com!c58g2000hsc.googlegroups.com!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87239
Article PK: 416500

Hi,

I very recently started working with PB as the person who used to
handle it retired. I have managed to get by with small changes but am
lost with intricate details. I am trying to add 2 columns to the
datasource (query) of a datawindow. The query runs fine in ISQL window
but whenever I try to run the app locally the report/datawindow shows
up completely blank. Is there some link I am missing somewhere that
will reflect the SQL changes? I have tried searching online and in
books but I haven't found anything that would answer my question
specifically. I really appreciate any and all responses!

Thanks
Vani


"Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel Posted on 2008-06-24 18:16:16.0Z
From: "Jerry Siegel [TeamSybase]" <jNOsSPAMsiegel@yahoo!.com>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <ddf95d9e-d295-4a84-9b2c-d74ae42bcd5a@c58g2000hsc.googlegroups.com>
Subject: Re: Adding column to datasource
Lines: 26
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.5512
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5512
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <486139f0$1@forums-1-dub>
Date: 24 Jun 2008 11:16:16 -0700
X-Trace: forums-1-dub 1214331376 10.22.241.152 (24 Jun 2008 11:16:16 -0700)
X-Original-Trace: 24 Jun 2008 11:16:16 -0700, vip152.sybase.com
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:87240
Article PK: 416498

Completely blank would suggest that no rows are being retrieved. It is
possible that something you did changed the WHERE clause or confused some
code that is modifying the WHERE clause, as is common for reports.
I would set a breakpoint in the debugger where the retrieval begins and see
what is happening. Put a temporary line of code in the SQLPreview event of
the DW control so you can see the SQL that is actually going to the
database.

<vanimm@gmail.com> wrote in message
news:ddf95d9e-d295-4a84-9b2c-d74ae42bcd5a@c58g2000hsc.googlegroups.com...
> Hi,
>
> I very recently started working with PB as the person who used to
> handle it retired. I have managed to get by with small changes but am
> lost with intricate details. I am trying to add 2 columns to the
> datasource (query) of a datawindow. The query runs fine in ISQL window
> but whenever I try to run the app locally the report/datawindow shows
> up completely blank. Is there some link I am missing somewhere that
> will reflect the SQL changes? I have tried searching online and in
> books but I haven't found anything that would answer my question
> specifically. I really appreciate any and all responses!
>
> Thanks
> Vani