Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Sybase- installing jar

8 posts in General Discussion Last posting was on 2010-08-03 01:08:10.0Z
Laksh Posted on 2010-01-05 09:30:53.0Z
From: Laksh <laksh.sainath@gmail.com>
Newsgroups: sybase.public.ase.general
Subject: Sybase- installing jar
Date: Tue, 5 Jan 2010 01:30:53 -0800 (PST)
Organization: http://groups.google.com
Lines: 6
Message-ID: <ea79f99e-eb31-40aa-9248-5dc6bf052d06@a6g2000yqm.googlegroups.com>
NNTP-Posting-Host: 203.99.195.64
Mime-Version: 1.0
Content-Type: text/plain; charset=ISO-8859-1
X-Trace: posting.google.com 1262683853 27735 127.0.0.1 (5 Jan 2010 09:30:53 GMT)
X-Complaints-To: groups-abuse@google.com
NNTP-Posting-Date: Tue, 5 Jan 2010 09:30:53 +0000 (UTC)
Complaints-To: groups-abuse@google.com
Injection-Info: a6g2000yqm.googlegroups.com; posting-host=203.99.195.64; posting-account=j5dFNgoAAAAnz7QWJoQx0ITZXFR2KIfQ
User-Agent: G2/1.0
X-HTTP-Via: HTTP/1.0 ctsintcoswga[0AED7D51] (Websense-Content_Gateway/7.1.2 [uSc ])
X-HTTP-UserAgent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 2.0.50727; MS-RTC LM 8; InfoPath.2; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022),gzip(gfe),gzip(gfe)
Path: forums-1-dub!forums-master!newssvr.sybase.com!news-sj-1.sprintlink.net!news-peer1.sprintlink.net!newsfeed.yul.equant.net!transit4.readnews.com!news-out.readnews.com!news-xxxfer.readnews.com!postnews.google.com!a6g2000yqm.googlegroups.com!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28824
Article PK: 78066

Hi,

While trying to install java jar file in Sybase ASE15.0.3, I am
getting error - " jar does not represent a valid Java class file." I
have compiled the java file using jdk1.6. The same version is
available in Sybase ASE. Please help!!!


J Posted on 2010-01-05 18:30:54.0Z
From: jtotally_bogus@sbcglobal.net (J)
Newsgroups: sybase.public.ase.general
Subject: Re: Sybase- installing jar
Reply-To: J@bogusemailAddress.com
Message-ID: <4b43853b.8557144@forums.sybase.com>
References: <ea79f99e-eb31-40aa-9248-5dc6bf052d06@a6g2000yqm.googlegroups.com>
X-Newsreader: Forte Free Agent 1.21/32.243
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 5 Jan 2010 10:30:54 -0800
X-Trace: forums-1-dub 1262716254 10.22.241.152 (5 Jan 2010 10:30:54 -0800)
X-Original-Trace: 5 Jan 2010 10:30:54 -0800, vip152.sybase.com
Lines: 15
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28828
Article PK: 78068

On Tue, 5 Jan 2010 01:30:53 -0800 (PST), Laksh
<laksh.sainath@gmail.com> wrote:

What is the output of : jar -tf <your jar file>?
What is the complete install command and the output from the command?

Jay

>Hi,
>
>While trying to install java jar file in Sybase ASE15.0.3, I am
>getting error - " jar does not represent a valid Java class file." I
>have compiled the java file using jdk1.6. The same version is
>available in Sybase ASE. Please help!!!


Laksh Posted on 2010-01-06 10:32:17.0Z
From: Laksh <laksh.sainath@gmail.com>
Newsgroups: sybase.public.ase.general
Subject: Re: Sybase- installing jar
Date: Wed, 6 Jan 2010 02:32:17 -0800 (PST)
Organization: http://groups.google.com
Lines: 45
Message-ID: <356d12a9-ca47-49c0-b017-c528cd929a06@f5g2000yqh.googlegroups.com>
References: <ea79f99e-eb31-40aa-9248-5dc6bf052d06@a6g2000yqm.googlegroups.com> <4b43853b.8557144@forums.sybase.com>
NNTP-Posting-Host: 203.99.195.64
Mime-Version: 1.0
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
X-Trace: posting.google.com 1262773937 26425 127.0.0.1 (6 Jan 2010 10:32:17 GMT)
X-Complaints-To: groups-abuse@google.com
NNTP-Posting-Date: Wed, 6 Jan 2010 10:32:17 +0000 (UTC)
Complaints-To: groups-abuse@google.com
Injection-Info: f5g2000yqh.googlegroups.com; posting-host=203.99.195.64; posting-account=j5dFNgoAAAAnz7QWJoQx0ITZXFR2KIfQ
User-Agent: G2/1.0
X-HTTP-Via: HTTP/1.0 ctsintcoswga[0AED7D51] (Websense-Content_Gateway/7.1.2 [uSc ])
X-HTTP-UserAgent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 2.0.50727; MS-RTC LM 8; InfoPath.2; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022),gzip(gfe),gzip(gfe)
Path: forums-1-dub!forums-master!newssvr.sybase.com!news-sj-1.sprintlink.net!news-peer1.sprintlink.net!newsfeed.yul.equant.net!news-out.readnews.com!transit4.readnews.com!postnews.google.com!f5g2000yqh.googlegroups.com!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28832
Article PK: 78074


On Jan 5, 11:30 pm, jtotally_bo...@sbcglobal.net (J) wrote:
> On Tue, 5 Jan 2010 01:30:53 -0800 (PST), Laksh
>
> <laksh.sain...@gmail.com> wrote:
>
> What is the output of : jar -tf <your jar file>?
> What is the complete install command and the output from the command?
>
> Jay
>
>
>
> >Hi,
>
> >While trying to install java jar file in Sybase ASE15.0.3, I am
> >getting error - " jar does not represent a valid Java class file." I
> >have compiled the java file using jdk1.6. The same version is
> >available in Sybase ASE. Please help!!!- Hide quoted text -
>
> - Show quoted text -

Hi,

I am trying to install jar named Date.jar with one class and below is
the output of command jar -tf Date.jar,

META-INF/
META-INF/MANIFEST.MF
DateTimeFormat.class

Install Command:

JAR name
Date
Command
D:\SybaseClient4.3\OCS-15_0\bin\instjava.exe -new -f D:\Lakshmi
\DateTimeFormat\Date.jar -j Date -S SybaseServer -D DCipherDev -U
vignesh -P <password>

Output:

com.sybase.aseplugin.ASEException: Server Message: CTSINTCOVDSL3 - Msg
10795, Level 16, State 1:
The file 'DateTimeFormat.class' contained in the jar does not
represent a valid Java class file.


J Posted on 2010-01-06 19:05:41.0Z
From: jtotally_bogus@sbcglobal.net (J)
Newsgroups: sybase.public.ase.general
Subject: Re: Sybase- installing jar
Reply-To: J@bogusemailAddress.com
Message-ID: <4b44dae6.96020079@forums.sybase.com>
References: <ea79f99e-eb31-40aa-9248-5dc6bf052d06@a6g2000yqm.googlegroups.com> <4b43853b.8557144@forums.sybase.com> <356d12a9-ca47-49c0-b017-c528cd929a06@f5g2000yqh.googlegroups.com>
X-Newsreader: Forte Free Agent 1.21/32.243
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 6 Jan 2010 11:05:41 -0800
X-Trace: forums-1-dub 1262804741 10.22.241.152 (6 Jan 2010 11:05:41 -0800)
X-Original-Trace: 6 Jan 2010 11:05:41 -0800, vip152.sybase.com
Lines: 58
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28836
Article PK: 78079

On Wed, 6 Jan 2010 02:32:17 -0800 (PST), Laksh
<laksh.sainath@gmail.com> wrote:

That all looks ok to me. If you made the jar file like:
jar cvf0 <jar> *.class file then I think the setup is ok.

If the version is 15.0.3 and up then I think you might have to resolve
this thru a tech support case unless the class is sufficiently simple
to post. Does it happen with all classes or only this one?

Jay

>On Jan 5, 11:30=A0pm, jtotally_bo...@sbcglobal.net (J) wrote:
>> On Tue, 5 Jan 2010 01:30:53 -0800 (PST), Laksh
>>
>> <laksh.sain...@gmail.com> wrote:
>>
>> What is the output of : jar -tf <your jar file>?
>> What is the complete install command and the output from the command?
>>
>> Jay
>>
>>
>>
>> >Hi,
>>
>> >While trying to install java jar file in Sybase ASE15.0.3, I am
>> >getting error - " jar does not represent a valid Java class file." I
>> >have compiled the java file using jdk1.6. The same version is
>> >available in Sybase ASE. Please help!!!- Hide quoted text -
>>
>> - Show quoted text -
>
>Hi,
>
>I am trying to install jar named Date.jar with one class and below is
>the output of command jar -tf Date.jar,
>
>META-INF/
>META-INF/MANIFEST.MF
>DateTimeFormat.class
>
>Install Command:
>
>JAR name
> Date
>Command
> D:\SybaseClient4.3\OCS-15_0\bin\instjava.exe -new -f D:\Lakshmi
>\DateTimeFormat\Date.jar -j Date -S SybaseServer -D DCipherDev -U
>vignesh -P <password>
>
>Output:
>
>com.sybase.aseplugin.ASEException: Server Message: CTSINTCOVDSL3 - Msg
>10795, Level 16, State 1:
>The file 'DateTimeFormat.class' contained in the jar does not
>represent a valid Java class file.


Laksh Posted on 2010-01-07 07:05:27.0Z
Sender: 6c47.4b458455.1804289383@sybase.com
From: Laksh
Newsgroups: sybase.public.ase.general
Subject: Re: Sybase- installing jar
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4b4587b7.6cc2.1681692777@sybase.com>
References: <4b44dae6.96020079@forums.sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 6 Jan 2010 23:05:27 -0800
X-Trace: forums-1-dub 1262847927 10.22.241.41 (6 Jan 2010 23:05:27 -0800)
X-Original-Trace: 6 Jan 2010 23:05:27 -0800, 10.22.241.41
Lines: 12
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28842
Article PK: 78084

Whether we should use same jdk vesion in client side? JRE
version in Sybase ASE 15.0.3 is 6. I am using Sybase Central
4.3 to connect to Sybase. JDK version in client side is
1.4.2. But, I have compiled java file and created jar using
jdk6.

Please let me know, what might be the casue for this issue.
While installing ASE, java and pci is enabled and server is
restarted. Whether 'sybpcidb' database is to be created?

Thanks,
Lakshmi.


J Posted on 2010-01-08 15:38:44.0Z
From: jtotally_bogus@sbcglobal.net (J)
Newsgroups: sybase.public.ase.general
Subject: Re: Sybase- installing jar
Reply-To: J@bogusemailAddress.com
Message-ID: <4b474d94.45974788@forums.sybase.com>
References: <4b44dae6.96020079@forums.sybase.com> <4b4587b7.6cc2.1681692777@sybase.com>
X-Newsreader: Forte Free Agent 1.21/32.243
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 8 Jan 2010 07:38:44 -0800
X-Trace: forums-1-dub 1262965124 10.22.241.152 (8 Jan 2010 07:38:44 -0800)
X-Original-Trace: 8 Jan 2010 07:38:44 -0800, vip152.sybase.com
Lines: 36
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28849
Article PK: 78090

On 6 Jan 2010 23:05:27 -0800, Laksh wrote:

I wish I knew the answer. If you could tell us if this occurs on all
classes or only this one it would help. If the class is very simple
and you show it then one could try to reproduce the problem.

If not then you will need to pursue thru tech support with information
on all versions. e.g you say ASE 15.0.3 but the 'select @@version'
shows us an exact version of the server and the platform. Same for the
jdk's that you are using. Such details are necessary.

What do you mean "Whether 'sybpcidb' database is to be created?

I would have the server ready to run java which includes 'enable
java', 'enable pci' and the creation of the 'sybpcidb' before this but
I am not certain that it has to be done.

It is always good to enable all of the java stuff and do something
like 'select java.lang.Math.sqrt(2)' to assure java working in the
server before other activities.

Jay

>Whether we should use same jdk vesion in client side? JRE
>version in Sybase ASE 15.0.3 is 6. I am using Sybase Central
>4.3 to connect to Sybase. JDK version in client side is
>1.4.2. But, I have compiled java file and created jar using
>jdk6.
>
>Please let me know, what might be the casue for this issue.
>While installing ASE, java and pci is enabled and server is
>restarted. Whether 'sybpcidb' database is to be created?
>
>Thanks,
>Lakshmi.


Laksh Posted on 2010-01-11 06:42:44.0Z
From: Laksh <laksh.sainath@gmail.com>
Newsgroups: sybase.public.ase.general
Subject: Re: Sybase- installing jar
Date: Sun, 10 Jan 2010 22:42:44 -0800 (PST)
Organization: http://groups.google.com
Lines: 47
Message-ID: <e69ecfc2-e9d0-4d30-9370-839e5c2f804f@m3g2000yqf.googlegroups.com>
References: <4b44dae6.96020079@forums.sybase.com> <4b4587b7.6cc2.1681692777@sybase.com> <4b474d94.45974788@forums.sybase.com>
NNTP-Posting-Host: 203.99.195.64
Mime-Version: 1.0
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
X-Trace: posting.google.com 1263192165 27194 127.0.0.1 (11 Jan 2010 06:42:45 GMT)
X-Complaints-To: groups-abuse@google.com
NNTP-Posting-Date: Mon, 11 Jan 2010 06:42:45 +0000 (UTC)
Complaints-To: groups-abuse@google.com
Injection-Info: m3g2000yqf.googlegroups.com; posting-host=203.99.195.64; posting-account=j5dFNgoAAAAnz7QWJoQx0ITZXFR2KIfQ
User-Agent: G2/1.0
X-HTTP-Via: HTTP/1.0 ctsintcoswgb[0AED7D52] (Websense-Content_Gateway/7.1.2 [uSc ])
X-HTTP-UserAgent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 2.0.50727; MS-RTC LM 8; InfoPath.2; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022),gzip(gfe),gzip(gfe)
Path: forums-1-dub!forums-master!newssvr.sybase.com!news-sj-1.sprintlink.net!news-peer1.sprintlink.net!nntp1.phx1.gblx.net!nntp.gblx.net!nntp.gblx.net!newsfeed.news2me.com!nx01.iad01.newshosting.com!newshosting.com!198.186.194.249.MISMATCH!news-out.readnews.com!transit3.readnews.com!postnews.google.com!m3g2000yqf.googlegroups.com!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:28861
Article PK: 78102


On Jan 8, 8:38 pm, jtotally_bo...@sbcglobal.net (J) wrote:
> On 6 Jan 2010 23:05:27 -0800, Laksh wrote:
>
> I wish I knew the answer. If you could tell us if this occurs on all
> classes or only this one it would help.  If the class is very simple
> and you show it then one could try to reproduce the problem.
>
> If not then you will need to pursue thru tech support with information
> on all versions. e.g you say ASE 15.0.3 but the 'select @@version'
> shows us an exact version of the server and the platform. Same for the
> jdk's that you are using. Such details are necessary.
>
> What do you mean "Whether 'sybpcidb' database is to be created?
>
> I would have the server ready to run java which includes 'enable
> java', 'enable pci' and the creation of the 'sybpcidb' before this but
> I am not certain that it has to be done.
>
> It is always good to enable all of the java stuff and do something
> like 'select java.lang.Math.sqrt(2)' to assure java working in the
> server before other activities.
>
> Jay
>
>
>
> >Whether we should use same jdk vesion in client side? JRE
> >version in Sybase ASE 15.0.3 is 6. I am using Sybase Central
> >4.3 to connect to Sybase. JDK version in client side is
> >1.4.2. But, I have compiled java file and created jar using
> >jdk6.
>
> >Please let me know, what might be the casue for this issue.
> >While installing ASE, java and pci is enabled and server is
> >restarted. Whether 'sybpcidb' database is to be created?
>
> >Thanks,
> >Lakshmi.- Hide quoted text -
>
> - Show quoted text -

Thanks Jay. This problem occurs for all the java classes. As you said,
I tired out 'select java.lang.Math.sqrt(2)' ,
but got error that ' cannot initialize java virtual machine because
either the java class library or PCA plugin library is missing'.
I guess, I should first create 'sybpcidb' and continue using java
classes.


Jorge Posted on 2010-08-03 01:08:10.0Z
From: "Jorge" <jrmurilloc@gmail.com>
Newsgroups: sybase.public.ase.general
Subject: Re: Sybase- installing jar
References: <4b44dae6.96020079@forums.sybase.com> <4b4587b7.6cc2.1681692777@sybase.com> <4b474d94.45974788@forums.sybase.com> <e69ecfc2-e9d0-4d30-9370-839e5c2f804f@m3g2000yqf.googlegroups.com>
X-Newsreader: newsgroupstats.hk
X-HTTP-Posting-Host: 190.232.181.74
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4c576bfa$1@forums-1-dub>
Date: 2 Aug 2010 18:08:10 -0700
X-Trace: forums-1-dub 1280797690 10.22.241.152 (2 Aug 2010 18:08:10 -0700)
X-Original-Trace: 2 Aug 2010 18:08:10 -0700, vip152.sybase.com
Lines: 73
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:29436
Article PK: 78669

Hi there,
I went trough the same problem, here's how it finally worked:

You need to complete 3 tasks :
1. Create the database sybpcidb
isql -Usa -P -SSUSE -i$SYBASE/$SYBASE_ASE/scripts/installpcidb -oinstallpcidbLog
2. you need to enable java:
sp_configure ¡§enable java¡¨, 1
3. you need to enable pci :
sp_configure 'enable pci',1

for the third step you will need to increase some memory parameters to get it to work, write me if you need details about it

Hope this help
Jorge

--
Android Usenet Reader
http://android.newsgroupstats.hk

Free News Reader
http://put.hk
http://put.hk/reader/forums.sybase.com/sybase.public.ase.general.html

Laksh <laksh.sainath@gmail.com> wrote:
> On Jan 8, 8:38 pm, jtotally_bo...@sbcglobal.net (J) wrote:
> > On 6 Jan 2010 23:05:27 -0800, Laksh wrote:
> >
> > I wish I knew the answer. If you could tell us if this occurs on all
> > classes or only this one it would help.  If the class is very simple
> > and you show it then one could try to reproduce the problem.
> >
> > If not then you will need to pursue thru tech support with information
> > on all versions. e.g you say ASE 15.0.3 but the 'select @@version'
> > shows us an exact version of the server and the platform. Same for the
> > jdk's that you are using. Such details are necessary.
> >
> > What do you mean "Whether 'sybpcidb' database is to be created?
> >
> > I would have the server ready to run java which includes 'enable
> > java', 'enable pci' and the creation of the 'sybpcidb' before this but
> > I am not certain that it has to be done.
> >
> > It is always good to enable all of the java stuff and do something
> > like 'select java.lang.Math.sqrt(2)' to assure java working in the
> > server before other activities.
> >
> > Jay
> >
> >
> >
> > >Whether we should use same jdk vesion in client side? JRE
> > >version in Sybase ASE 15.0.3 is 6. I am using Sybase Central
> > >4.3 to connect to Sybase. JDK version in client side is
> > >1.4.2. But, I have compiled java file and created jar using
> > >jdk6.
> >
> > >Please let me know, what might be the casue for this issue.
> > >While installing ASE, java and pci is enabled and server is
> > >restarted. Whether 'sybpcidb' database is to be created?
> >
> > >Thanks,
> > >Lakshmi.- Hide quoted text -
> >
> > - Show quoted text -
> Thanks Jay. This problem occurs for all the java classes. As you said,
> I tired out 'select java.lang.Math.sqrt(2)' ,
> but got error that ' cannot initialize java virtual machine because
> either the java class library or PCA plugin library is missing'.
> I guess, I should first create 'sybpcidb' and continue using java
> classes.