Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Unable to start XP Server

4 posts in Windows NT Last posting was on 2001-04-19 06:09:44.0Z
Thuc Posted on 2001-04-18 05:33:16.0Z
From: "Thuc" <tdo@elders.com.au>
Subject: Unable to start XP Server
Date: Wed, 18 Apr 2001 15:03:16 +0930
Lines: 28
Organization: Elders
X-Newsreader: Microsoft Outlook Express 4.72.3110.5
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.3110.3
Message-ID: <eySJDv8xAHA.205@forums.sybase.com>
Newsgroups: sybase.public.sqlserver.nt
NNTP-Posting-Host: 203.38.229.146
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:940
Article PK: 1087547

Hi,

I get the following error messages in the xp server log at start up. I've
configured the "start mail session" to 1.

I'm on Adaptive Server Enterprise/12.0.0.2/P/SWR 9503 ESD 2/NT (IX86)/OS
4.0/1667/32bit/OPT

Any Ideas?

Thanks in advance,
Thuc


04/18/01 02:45:17 PM Sybmail encountered CMC Error:
The service, user name, or password specified were invalid, so logon
cannot be completed..
04/18/01 02:45:17 PM PROD_ASE_XP: XP Server Error: 16142/10/1: Server
process address 0x406720 not in pool in 'srv_sendstatus'
.
04/18/01 02:45:17 PM PROD_ASE_XP: XP Server Error: 16142/10/1: Server
process address 0x406720 not in pool in 'srv_sendinfo()'
.
04/18/01 02:45:17 PM PROD_ASE_XP: XP Server Error: 16142/10/1: Server
process address 0x406720 not in pool in 'srv_senddone()'
.


Jim Egan Posted on 2001-04-18 14:57:39.0Z
From: Jim Egan <dbaguru@eganomics.com>
Subject: Re: Unable to start XP Server
Date: Wed, 18 Apr 2001 08:57:39 -0600
Message-ID: <MPG.1547594fd5331ee798b2a4@forums.sybase.com>
References: <eySJDv8xAHA.205@forums.sybase.com>
Reply-To: eganjp@compuserve.com
X-Newsreader: MicroPlanet Gravity v2.50
Newsgroups: sybase.public.sqlserver.nt
Lines: 53
NNTP-Posting-Host: jpe650.sybase.com 157.133.56.43
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:936
Article PK: 1087544


tdo@elders.com.au wrote...
> Hi,
>
> I get the following error messages in the xp server log at start up. I've
> configured the "start mail session" to 1.
>
> I'm on Adaptive Server Enterprise/12.0.0.2/P/SWR 9503 ESD 2/NT (IX86)/OS
> 4.0/1667/32bit/OPT
>
> Any Ideas?
>
> Thanks in advance,
> Thuc
>
>
> 04/18/01 02:45:17 PM Sybmail encountered CMC Error:
> The service, user name, or password specified were invalid, so logon
> cannot be completed..
> 04/18/01 02:45:17 PM PROD_ASE_XP: XP Server Error: 16142/10/1: Server
> process address 0x406720 not in pool in 'srv_sendstatus'
> .
> 04/18/01 02:45:17 PM PROD_ASE_XP: XP Server Error: 16142/10/1: Server
> process address 0x406720 not in pool in 'srv_sendinfo()'
> .
> 04/18/01 02:45:17 PM PROD_ASE_XP: XP Server Error: 16142/10/1: Server
> process address 0x406720 not in pool in 'srv_senddone()'
> .
>
>
>

Just to make sure you can get to xp_server, can you execute the following command:
xp_cmdshell 'C:\'

It may be that you are trying to run an external process under a context that lacks
permission. Here is an excerpt from the xp_cmdshell command in the online help:

The user context in which an operating system command is executed via xp_cmdshell is
controlled by the value of the xp_cmdshell context configuration parameter. If this
parameter is set to 1 (the default), xp_cmdshell restricts permission to users with System
Administration privileges at the operating system level. If this parameter is set to 0,
xp_cmdshell uses the security context of the operating system account under which Adaptive
Server is running. Therefore, using xp_cmdshell with the xp_cmdshell context configuration
parameter set to 0, any user can execute operating system commands using the permissions of
the account running Adaptive Server. This account may have fewer restrictions than the
user's own account.
--
Jim Egan [TeamSybase]
Senior Consultant
Sybase Professional Services

Get your free subscription to PowerTimes at http://www.powertimes.com


Thuc Posted on 2001-04-19 00:39:31.0Z
From: "Thuc" <tdo@elders.com.au>
References: <eySJDv8xAHA.205@forums.sybase.com> <MPG.1547594fd5331ee798b2a4@forums.sybase.com>
Subject: Re: Unable to start XP Server
Date: Thu, 19 Apr 2001 10:09:31 +0930
Lines: 33
Organization: Elders
X-Newsreader: Microsoft Outlook Express 4.72.3110.5
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.3110.3
Message-ID: <2vkgnvGyAHA.261@forums.sybase.com>
Newsgroups: sybase.public.sqlserver.nt
NNTP-Posting-Host: 203.38.229.146
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:932
Article PK: 1087539

Jim,

I've configured xp_cmdshell to 0. Running the command: xp_cmdshell 'C:\'
produced a different error.

XP server error log:

04/19/01 09:52:00 AM XP Server is now running.
04/19/01 09:52:02 AM Sybmail encountered CMC Error:
A function parameter was invalid. .

Server error log:

00:00000:00012:2001/04/19 09:56:38.88 kernel nl__connect: Could not connect
to site 'PROD_ASE_XP', socket 4.
00:00000:00012:2001/04/19 09:56:38.88 kernel nl__connect: net_connect
failed to connect to site 'PROD_ASE_XP'.
: No connection could be made because the target machine actively refused
it.

.
00:00000:00012:2001/04/19 09:56:41.43 kernel XP Server started
successfully.
00:00000:00012:2001/04/19 09:56:46.25 kernel Cannot send, host process
disconnected: PROD_ASE_XP spid: 12

The XP server services does not say "Started" even though I've configured
"start mail session" to 1.

cheers,
Thuc


Jim Egan Posted on 2001-04-19 06:09:44.0Z
From: Jim Egan <dbaguru@eganomics.com>
Subject: Re: Unable to start XP Server
Date: Thu, 19 Apr 2001 00:09:44 -0600
Message-ID: <MPG.15482f1557bdf8ba98b2b1@forums.sybase.com>
References: <eySJDv8xAHA.205@forums.sybase.com> <MPG.1547594fd5331ee798b2a4@forums.sybase.com> <2vkgnvGyAHA.261@forums.sybase.com>
Reply-To: eganjp@compuserve.com
X-Newsreader: MicroPlanet Gravity v2.50
Newsgroups: sybase.public.sqlserver.nt
Lines: 9
NNTP-Posting-Host: c1420400-b.hiland1.co.home.com 65.7.153.228
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:930
Article PK: 1087537

Well, that's about exhausted my knowledge of xp_server. Unless someone else can provide
some help here your next step should be to open a case with Tech Support.
--
Jim Egan [TeamSybase]
Senior Consultant
Sybase Professional Services

Get your free subscription to PowerTimes at http://www.powertimes.com