Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Powerbuilder 11.5 Querymode bug

2 posts in DataWindow Last posting was on 2009-02-09 15:16:01.0Z
DARKinVADER Posted on 2009-02-09 15:00:11.0Z
From: DARKinVADER <gabor.czibik@gmail.com>
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Powerbuilder 11.5 Querymode bug
Date: Mon, 9 Feb 2009 07:00:11 -0800 (PST)
Organization: http://groups.google.com
Lines: 21
Message-ID: <fa26c1ab-66cc-414d-b280-7b1684eab94b@k8g2000yqn.googlegroups.com>
NNTP-Posting-Host: 91.82.175.190
Mime-Version: 1.0
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
X-Trace: posting.google.com 1234191611 14060 127.0.0.1 (9 Feb 2009 15:00:11 GMT)
X-Complaints-To: groups-abuse@google.com
NNTP-Posting-Date: Mon, 9 Feb 2009 15:00:11 +0000 (UTC)
Complaints-To: groups-abuse@google.com
Injection-Info: k8g2000yqn.googlegroups.com; posting-host=91.82.175.190; posting-account=dhPQWQoAAAASdeDvzZ3tG_O1zpfamNkB
User-Agent: G2/1.0
X-HTTP-UserAgent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6 (.NET CLR 3.5.30729),gzip(gfe),gzip(gfe)
X-HTTP-Via: 1.1 proxy.qualysoft.hu (squid/3.0.STABLE7)
Path: forums-1-dub!forums-master!newssvr.sybase.com!news-sj-1.sprintlink.net!news-peer1.sprintlink.net!newsfeed.yul.equant.net!nntp1.roc.gblx.net!nntp.gblx.net!nntp.gblx.net!nlpi057.nbdc.sbc.com!prodigy.net!news.glorb.com!postnews.google.com!k8g2000yqn.googlegroups.com!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:88739
Article PK: 417989

Hi,

we have migrated our project from PB 11.2 to the new PB 11.5 and I
realized, that invisible datawindows began to appear on the screen.
I investigated the problem and it turned out, that if I have a
datawindow, with property visible = false. And somewhere in the code i
call this script:

dw_query.Querymode = 'yes'

the datawindow appears on the screen. I checked the visible property
after this line, and it stayed false. I have to call

dw_query.visible = false

after every querymode :)

I can post a very simple example too. I think I should open a Bug case
at Sybase, shouldm't I?

Have a nice day.


Terry Dykstra [TeamSybase] Posted on 2009-02-09 15:16:01.0Z
Reply-To: "Terry Dykstra [TeamSybase]" <dontreply_tddykstra@forestoil.ca.x>
From: "Terry Dykstra [TeamSybase]" <tddykstra@forestoil.ca>
Newsgroups: sybase.public.powerbuilder.datawindow
References: <fa26c1ab-66cc-414d-b280-7b1684eab94b@k8g2000yqn.googlegroups.com>
Subject: Re: Powerbuilder 11.5 Querymode bug
Lines: 34
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3138
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3198
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <499048b1$1@forums-1-dub>
Date: 9 Feb 2009 07:16:01 -0800
X-Trace: forums-1-dub 1234192561 10.22.241.152 (9 Feb 2009 07:16:01 -0800)
X-Original-Trace: 9 Feb 2009 07:16:01 -0800, vip152.sybase.com
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:88740
Article PK: 417995

Looks like a genuine bug.

--
Terry Dykstra (TeamSybase)
http://powerbuilder.codeXchange.sybase.com/
http://casexpress.sybase.com
product enhancement requests:
http://my.isug.com/cgi-bin/1/c/submit_enhancement

"DARKinVADER" <gabor.czibik@gmail.com> wrote in message
news:fa26c1ab-66cc-414d-b280-7b1684eab94b@k8g2000yqn.googlegroups.com...
> Hi,
>
> we have migrated our project from PB 11.2 to the new PB 11.5 and I
> realized, that invisible datawindows began to appear on the screen.
> I investigated the problem and it turned out, that if I have a
> datawindow, with property visible = false. And somewhere in the code i
> call this script:
>
> dw_query.Querymode = 'yes'
>
> the datawindow appears on the screen. I checked the visible property
> after this line, and it stayed false. I have to call
>
> dw_query.visible = false
>
> after every querymode :)
>
> I can post a very simple example too. I think I should open a Bug case
> at Sybase, shouldm't I?
>
> Have a nice day.