Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Again network

4 posts in Windows NT Last posting was on 2001-03-19 16:50:18.0Z
Voronkov Nick Posted on 2001-03-19 07:50:06.0Z
From: "Voronkov Nick" <Nikolay.Voronkov@flc-bookclub.com>
Subject: Again network
Date: Mon, 19 Mar 2001 09:50:06 +0200
Lines: 42
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2417.2000
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
Message-ID: <kpGHPvEsAHA.53@forums.sybase.com>
Newsgroups: sybase.public.sqlserver.nt
NNTP-Posting-Host: bravo.flc-bookclub.com 193.41.49.154
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:1072
Article PK: 1087674

Gentlemen !

I write about my problem again. Big thanks for all people which answered me.
But problem remained. I remind it.

We have ASE 11.9.2, two network cards in the server (Window NT, sercice
pack 6) and one virtual driver.

The cards : Intell PRO/100 Intelligent Server Adapter.
Type of virtual adapter : Intell Adaptive Load Balancing Team.

Our trouble : XP_Server does not work if tasks start on the server side. For
example I type in SQL Advantage on the server the next :
exec xp_cmdshell 'net send user_name Hello !!!' or exec xp_cmdshell 'dir
c:' After this the session hangs. But I can type these command with client
computers. ASE and XP_Server services start with SYSTEM account. I think it
is bound with permissions of account SYSTEM for network. I find nothing in
the documentation. Our network administrator says it is possible to destroy
the virtual adapter, but then network cards will have different IP
addresses. It is not proper for us.

Such delirium appears in the log of xp-server :
Mar 18 17:49:33 2001: CS-Library error Layer(2) Origin(4) Sev(6) 56 -
cs_locale: cslib user api layer: common library error: Failed to map a local
name to an object id!
Mar 18 17:49:33 2001: 16331 - Recursive Calls to srv__seterr() in spid: 6.
Thread terminated.

I have read all about xp_server. I install the next keys for our server :
xp_cmdshell context = 0
unified login required = 0
enable cis = 1
number of remote connections = 100
number of remote logins = 20

I removed all restrictions. XP_Server existsts in sysservers. Before some
time all was good, but our network administrator experimented with the
network adapaters. But he swears that all was returned back.

Nick


Jim Egan Posted on 2001-03-19 15:02:52.0Z
From: Jim Egan <dbaguru@eganomics.com>
Subject: Re: Again network
Date: Mon, 19 Mar 2001 08:02:52 -0700
Message-ID: <MPG.151fcd87cc9ba14498b1cc@forums.sybase.com>
References: <kpGHPvEsAHA.53@forums.sybase.com>
Reply-To: eganjp@compuserve.com
X-Newsreader: MicroPlanet Gravity v2.30
Newsgroups: sybase.public.sqlserver.nt
Lines: 13
NNTP-Posting-Host: jpe650.sybase.com 157.133.56.28
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:1070
Article PK: 1087670

The error "Failed to map a local name to an object id!" means it can't find the proper
localization in locales.dat/objectid.dat. Make sure your OpenClient install on the server
is correct. You may want to consider applying the latest EBF to make sure you have all the
necessary files and that they are in the correct location.
--
Jim Egan [TeamSybase]
Senior Consultant
Sybase Professional Services

Get your free subscription to PowerTimes at http://www.powertimes.com


Voronkov Nick Posted on 2001-03-19 15:29:42.0Z
From: "Voronkov Nick" <Nikolay.Voronkov@flc-bookclub.com>
References: <kpGHPvEsAHA.53@forums.sybase.com> <MPG.151fcd87cc9ba14498b1cc@forums.sybase.com>
Subject: Re: Again network
Date: Mon, 19 Mar 2001 17:29:42 +0200
Lines: 26
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2417.2000
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
Message-ID: <nHDGFwIsAHA.199@forums.sybase.com>
Newsgroups: sybase.public.sqlserver.nt
NNTP-Posting-Host: bravo.flc-bookclub.com 193.41.49.154
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:1069
Article PK: 1087671


Jim Egan wrote :

> The error "Failed to map a local name to an object id!" means it can't
find the proper
> localization in locales.dat/objectid.dat. Make sure your OpenClient
install on the server
> is correct. You may want to consider applying the latest EBF to make sure
you have all the
> necessary files and that they are in the correct location.

Well, it is so. But I think it is not so important. There is other message :

Mar 18 17:49:33 2001: 16331 - Recursive Calls to srv__seterr() in spid: 6.
Thread terminated.

These messages appear by pairs. I think the second line is basic. We can not
model this situation on our secondary server. It has only one network
adapter and XP Server works correctly. I exactly know our network
administrator changed settings for virtual adapter. I am as DBA changed
nothing. I very want to know how ASE works with network. Please tell me
where I can read about this.

Nick.


Jim Egan Posted on 2001-03-19 16:50:18.0Z
From: Jim Egan <dbaguru@eganomics.com>
Subject: Re: Again network
Date: Mon, 19 Mar 2001 09:50:18 -0700
Message-ID: <MPG.151fe6b07476ff8398b1cd@forums.sybase.com>
References: <kpGHPvEsAHA.53@forums.sybase.com> <MPG.151fcd87cc9ba14498b1cc@forums.sybase.com> <nHDGFwIsAHA.199@forums.sybase.com>
Reply-To: eganjp@compuserve.com
X-Newsreader: MicroPlanet Gravity v2.30
Newsgroups: sybase.public.sqlserver.nt
Lines: 11
NNTP-Posting-Host: jpe650.sybase.com 157.133.56.28
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:1068
Article PK: 1087672

As far as setting the network configuration goes, I would start with this book:
http://manuals.sybase.com/onlinebooks/group-as/asp1192e/aseinwnt/@Generic__BookView

Do you know if xp_server is running? How is it configured in your SQL.INI file?
--
Jim Egan [TeamSybase]
Senior Consultant
Sybase Professional Services

Get your free subscription to PowerTimes at http://www.powertimes.com