Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

ISQL in Batch File

3 posts in Windows NT Last posting was on 1999-12-12 10:33:36.0Z
Kelly Rowe Posted on 1999-12-11 13:11:21.0Z
From: "Kelly Rowe" <krowe@globalcardservices.com>
Subject: ISQL in Batch File
Date: Sat, 11 Dec 1999 08:11:21 -0500
Lines: 26
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2314.1300
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
Message-ID: <xifdbk9Q$GA.192@forums.sybase.com>
Newsgroups: sybase.public.sqlserver.nt
NNTP-Posting-Host: 208.30.1.69
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:2836
Article PK: 1090274

I'm having a bit of problem running ISQL in a Windows NT batch file. The
command line I'm using in the batch file is:

ISQL -U<login> -P<password> -iC:\DBA\Copy_Retrieval.sql

The input file, Copy_Retrieval.sql is:

use retrieval_copy
go
exec USP_truncate_retrieval
waitfor delay 00:00:15
exec USP_copy_retrieval

ISQL starts and ends without ever executing the stored procedures. Anyone
have an idea what might be wrong here? The system is Sybase 11.0.2
w/EBF8559 on NT 4.0 w/SP5. The login running the batch file is an
administrator on the NT server and the NT domain, and the Sybase login used
for ISQL has the sa role on the database server.

Thanks for any assistance!

Kelly Rowe
Senior Engineer - DBA
Global Card Services, Inc.


Alan Ramsay Posted on 1999-12-12 10:33:36.0Z
From: "Alan Ramsay" <alan@dotdash.org.uk>
References: <xifdbk9Q$GA.192@forums.sybase.com>
Subject: Re: ISQL in Batch File
Date: Sun, 12 Dec 1999 10:33:36 -0000
Lines: 13
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
Message-ID: <k9VhZ1IR$GA.191@forums.sybase.com>
Newsgroups: sybase.public.sqlserver.nt
NNTP-Posting-Host: da136d187.dialup.callnetuk.com 212.67.136.187
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:2833
Article PK: 1090271


"Kelly Rowe" <krowe@globalcardservices.com> wrote in message
news:xifdbk9Q$GA.192@forums.sybase.com...
> I'm having a bit of problem running ISQL in a Windows NT batch file. The
> command line I'm using in the batch file is:
>
> ISQL -U<login> -P<password> -iC:\DBA\Copy_Retrieval.sql

In case DSQUERY isn't set up correctly, I always like to add -S<servername>
too, especially if there is more than one ASE running on the box.

Alan


Rob Verschoor Posted on 1999-12-11 14:42:32.0Z
From: "Rob Verschoor" <rob@sypron.nl>
References: <xifdbk9Q$GA.192@forums.sybase.com>
Subject: Re: ISQL in Batch File
Date: Sat, 11 Dec 1999 15:42:32 +0100
Lines: 47
Organization: Sypron B.V.
X-Newsreader: Microsoft Outlook Express 4.71.1712.3
X-MimeOLE: Produced By Microsoft MimeOLE V4.71.1712.3
Message-ID: <Sze73Z#Q$GA.289@forums.sybase.com>
Newsgroups: sybase.public.sqlserver.nt
NNTP-Posting-Host: i307.ztm.euronet.nl 194.134.67.68
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:2835
Article PK: 1090273

You should add a final "go" at the end; without it, ISQL will not send the
preceding commands to the server and these will therefore not be executed.

HTH,

Rob
--
----------------------------------------------------------------------
Rob Verschoor

Certified Sybase ASE 11.5 Administrator (Professional)
Certified DBA/Performance & Tuning Specialist for Sybase System 11

email mailto:rob@sypron.nl.*No*Spam*Please*
WWW http://www.euronet.nl/~syp_rob
snail Sypron B.V., P.O.Box 10695, 2501HR Den Haag, The Netherlands
----------------------------------------------------------------------

Kelly Rowe wrote in message ...
>I'm having a bit of problem running ISQL in a Windows NT batch file. The
>command line I'm using in the batch file is:
>
>ISQL -U<login> -P<password> -iC:\DBA\Copy_Retrieval.sql
>
>The input file, Copy_Retrieval.sql is:
>
>use retrieval_copy
>go
>exec USP_truncate_retrieval
>waitfor delay 00:00:15
>exec USP_copy_retrieval
>
>ISQL starts and ends without ever executing the stored procedures. Anyone
>have an idea what might be wrong here? The system is Sybase 11.0.2
>w/EBF8559 on NT 4.0 w/SP5. The login running the batch file is an
>administrator on the NT server and the NT domain, and the Sybase login used
>for ISQL has the sa role on the database server.
>
>Thanks for any assistance!
>
>Kelly Rowe
>Senior Engineer - DBA
>Global Card Services, Inc.
>
>